Comments
121 - 136 of 136 Comments Last updated Jan 20, 2014
First Prev
of 7
Next Last

Since: Mar 07

Reston, VA

#121 Sep 30, 2009
Trina wrote:
<quoted text> Possibly.. Let me ask you what type of oil are you using? I personally have not had this problem.. Possibly wrong oil.. appears to be viscosity prblm.. First rule out fuel system contamination.. Not sure.. will ck on for you.. I use lucas fuel injector cleaner every 1500 miles and in addition I am going to start using ZMAX.. If the C. Shelby can endorse product and use in the 700 horsepower Super Snake.. I am going to use in my HEMI.. Basically penetrates down to metal.. is actually absorbed into the engine metal parts.. conditions the engine.. makes sense.. Anyway.. fuel system cleaning, throttle body cleaning, and very the type of oil that you are putting in vehicle.. then ck exhaust system.. but I am assuming that smoke coming from engine.. If so may possibly be a engine seal leak. Okay.. Peace
I use only synthetic oil - and at every other change, I do use BG44K. It's a GREAT fuel system cleaner.

Speaking of tranny: No more than every 30,000 - FLUSH the fluid (not a drain and fill - actual FLUSH) to replace all old fluid.
rick h

Newberg, OR

#122 Jan 8, 2010
Herb wrote:
I have a 2005 Magnum R/T and I have a noise in the rear end or bearing noise in the rear. Dose any one have this.
i have 05 rt and have same symtom. only had it 3 days it has 56k miles and looks and runs well otherwise. but, does have a grinding sound in the rearend? when turning hard left or right either forward or backwards. have you figured yours out?

Since: Mar 07

Reston, VA

#123 Jan 13, 2010
rick h wrote:
<quoted text>
i have 05 rt and have same symtom. only had it 3 days it has 56k miles and looks and runs well otherwise. but, does have a grinding sound in the rearend? when turning hard left or right either forward or backwards. have you figured yours out?
Have you taken it in to the dealership? That's a power train issue..
Jeff

Hamilton, Canada

#124 Apr 17, 2010
Does anyone else having A/C issues? 2005 RT, A/C wants to blow warmer air intermittently. Shut system down A/C starts cool again. In cabin recirculation makes the air blow warm? How about the front wiper settings, have been told the system is car speed senistive? When wipers are set at an interval, the delay time is inconsistent.
toby

United States

#125 Jun 19, 2010
Herb wrote:
I have a 2005 Magnum R/T and I have a noise in the rear end or bearing noise in the rear. Dose any one have this.
Yes I had that problem. It shuddered around 40 mph to 60. I replaved tranny and its smooth now.
thank

United States

#126 Jun 29, 2011
Thank you so much!! I am so discouraged with Dodge as a whole. Exact same issues with mine. Never could duplicate until conveniently the warranty has expired.
Robert wrote:
I have had my magnum in several times for the BAS sensor and long cranks times. It has caused the car to run very poorly. They are unable to find out what it is. Is anyone else having these problems
shad

Windsor, Canada

#127 Sep 17, 2011
does anybody know of any chip out there that acually works and will not damage my car i need to find a way to get better gas milage?
Sabrina

Fort Lauderdale, FL

#128 Jan 22, 2012
Wow after reading all of these bad experiences I am probably not going ro get a 05 magnum

Since: Mar 07

Reston, VA

#129 Feb 3, 2012
Sabrina,

Of all of the 05 Magnums that have been sold, you are going to take these few negative posts and decide to condemn the vehicle altogether? Really?
DodgeLover12

Las Vegas, NV

#130 Jun 18, 2012
I have a 05 Dodge Mganum V8 5.7 Hemi when I'm at a red light for a few the car will just shut off I don't have any other problems and when I start the car there's no problem driving or starting it back up does anyone knoe why it could jus cut off I've had the battery and transmission checked they're both perfect

Since: Mar 07

Reston, VA

#131 Oct 5, 2012
DodgeLover12 wrote:
I have a 05 Dodge Mganum V8 5.7 Hemi when I'm at a red light for a few the car will just shut off I don't have any other problems and when I start the car there's no problem driving or starting it back up does anyone knoe why it could jus cut off I've had the battery and transmission checked they're both perfect
There are a million reasons why a car will just shut off. You have to determine, 1st, if it's a fuel problem or an electrical problem.
rjust

Los Angeles, CA

#132 Nov 29, 2012
Herb wrote:
I have a 2005 Magnum R/T and I have a noise in the rear end or bearing noise in the rear. Dose any one have this.
YES! can't figure it either- very irritating
Dennis Crouse

Butler, PA

#133 Dec 27, 2012
i'm ok with all the stuff on the automatic trans .but surly someone knows what fluid they take and how in the world to check it at home .!
chambers

United States

#134 Feb 2, 2013
How would i be able to listen to my ipod with my factory stereo?
BullRider Molina

Fort Lauderdale, FL

#135 Aug 15, 2013
Robert wrote:
I have had my magnum in several times for the BAS sensor and long cranks times. It has caused the car to run very poorly. They are unable to find out what it is. Is anyone else having these problems
The long crank time is fixed with replacement of Starter Relay, fuse box under hood, slot 9, part number 05269988AA, about $16. Easy.
I have same problem with BAS and not resolved yet
Jay -Bob

Nanaimo, Canada

#136 Jan 20, 2014
Ray wrote:
I have a 2005 Magnum RT Hemi. Everytime I accelerate I smell a bad exhaust odor inside the cab area. Engine also idles rough. Does anyone else have these problems?
The problem with exaust fumes in the cabin of all years of magnums, stems from the rubber seal gasket at the rear lift gate- Open up your liftgate and check condition of rubber seal-As they age they shrink and you end up with a big hole at the base, and in come the fumes at idle or when you hammer on the throttle- buy a new gasket at the dealer and replace- Or if you are cheap like me, fill the hole with a little silicone RTV put some tape over it, And then adjust the latch so it pulls the lift gate down more when its closed- The latch is the gold colored u-shaped steel you can see with the liftgate open-Just remove 4 screws holding the cover, mark the lach position with a felt tip marker , slack off the two torx screws and move it down 1/8 inch or 3mm, put her back together.- Bobs your uncle and now you can breath again.

Tell me when this thread is updated: (Registration is not required)

Add to my Tracker Send me an email

First Prev
of 7
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Dodge Magnum Discussions

Title Updated Last By Comments
Chrysler Extends Fuel-Tank Warranty on 2006 V-8... Jul '14 Dodge Man 1
shift box problems! (May '09) Jul '14 Anisa 112
how to reset the computer on 05 dodge magnum (Dec '08) Jul '14 Miguel 86
Dodge magnum 2006 sxt 3.5 brake indicator light... Mar '14 Natalia 1
"05 magnum w/ 6cyl engine - 5.5ltr (Feb '09) Nov '13 B Wilson 2
05 dodge magnum 2.7 noise @ idle - lifters or t... (Mar '13) Nov '13 Steve 2
Dodge Magnum (Sep '13) Sep '13 Rballmickey 1

Buy a New Car


Zipcode:
•••
Enter and win $5000
•••

Dodge Magnum People Search

Addresses and phone numbers for FREE

•••