Problems with my 1998 Dodge Grand Car...
jmersereau

Canada

#383 Apr 23, 2009
I found this fix on another forum and it worked great for me...

So, for anyone who was thinking of running off to the dealer and forking out hundreds for part(s) and labour. Donít do it. Chances are, removing the FCM yourself, cleaning it, replacing it will save you hundreds. Forget wasting your time trying to get it done through Dodge. It takes all of 10 minutes and your good to go.

In case anyone wants to know: It is a very simple process.
1. Just remove the plastic cover over the PDC ( which is the black cover beside the battery.)
2. Looking at the front of the PDC is a silver housing with 4 torx screws.
3. Remove the 4 screws.
4. Pull out the FCM housing.( It separates from the PDC )
5. Looking at the FCM, youíll see 2 rows of needle pins, and 1 row of flat pins.
6. The flat pins are the culprits, what I did was use a fine small file and cleaned both sides of the flat pins only. They appeared to have a white coating of buildup on them.
7. Then I took small needle nose pliers and gave each flat pin a very small slight twist. Not to much, but a noticeable twist.
8. I re-inserted the FCM into the PDC, tighten back the 4 torx screws and voila!
jmersereau

Canada

#384 Apr 23, 2009
Sorry left off two steps, I sprayed electrical contact cleaner over everything and let it evaporate. Then I put dielectric grease on all the contacts to prevent the corrosion from coming back
Wilson

New Milford, NJ

#385 Apr 23, 2009
Instrument cluster not working. the BCM...Where do I find the BCM so I can clean the pins...1998 Dodge Van...Thanks
jmersereau

Canada

#386 Apr 24, 2009
I believe the BCM is located under the dash above the Emerg Brake.
albert new york

United States

#387 Apr 28, 2009
need help. Has anyone experienced this intermittent problem?: sometimes my car will not start...the engine turns over then immediately shuts down...if i let it sit for a while it starts and will run fine for a few months then i get the same problem again...this has happened to me about 10 times in the last year...also during this failure it will not turn over when i turn the key...again - if i let it sit for a while it will run fine...Help
jennifer

Allentown, PA

#388 May 6, 2009
I have a 98 dodge grand caravan and my anti theft device shutdown after my battery went and my starter since they have been replaced now the van wont start does anyone know how to reset the anti theft system or just disable it thank you
dunderquack

Louisville, CO

#389 May 19, 2009
Jason wrote:
My 1998 Dodge grand Caravan has a leak from the windshield site which the accumulates water at the area behind the dashboard and dash compartment. already applied silicone sealant to the rubber for the windshield but water is still seeping in during heavy downpours and when the van is parked.
Water not seeping into the electronics, yet.
Any ideas on where this is coming from and how to take care of it?
The drain hoses (2 of them) from the windshield cowl may be plugged. Mine were. Cleaning them out fixed my leak.
dunderquack

Louisville, CO

#390 May 19, 2009
The drain hoses (2 of them) from the windshield cowl may be plugged with decayed leaves and gunk. It's fairly easy to located and remove the hoses where they attach to the cowl. Open up the hood and give it a whirl. This fixed my leak.
dunderquack

Louisville, CO

#391 May 19, 2009
albert new york wrote:
need help. Has anyone experienced this intermittent problem?: sometimes my car will not start...the engine turns over then immediately shuts down...if i let it sit for a while it starts and will run fine for a few months then i get the same problem again...this has happened to me about 10 times in the last year...also during this failure it will not turn over when i turn the key...again - if i let it sit for a while it will run fine...Help
My 1998 Grand Caravan does this too. I can either sit and wait. and wait. And it will finally work again - or - and this is weird - I pound away on the top of the dash, over the instrument cluster, with my fists, and the problem is solved. No kidding.
albert

Eastchester, NY

#392 May 20, 2009
dude im fed up wit this S??? Im getting rid of it. Cant afford it anymore.I rather have a toyota which is reliable.but as i read all this i see it has been a problem for a long time and nobody even chrisler them selfs dont have a salution.wonna hear something funny in the begining when it did not want to start,i called a tolltruck to bring it to my mechanic and when the truck got there,A HOUR LATER.The guy turned my car on and pulled it right on the flatbed truck? I said looking right at the truck driver, AINT THIS A B#$@%.
Matt

Asheville, NC

#393 May 24, 2009
I have a 1998 dodge caravan sport and have had the guages quit working intermittently then finally permanently... Or so I thought. I have read all the posts on resolding the inst panel and the pcm to replacing the 300-ohm resister and all that fun stuff. This weekend I went camping with my boys and found that there is one specific spot about 2/3rds toward the hot side on the cabin air control and blink everything came back. I tinkered a bit to see if I could make it stop and sure enough it did when I slid the dial all the way to cold then slid back to 2/3rd's and in about 30 seconds all the guages came back again. Not sure if it is the slider switch or what but will do more research as time permits. Good luck all I know it is very frustrating and potentially expensive to fix.
wiseone

Martin, KY

#394 May 25, 2009
Sue wrote:
I replaced my windshield and that fixed the water problem. But I tried a bunch of stuff first. Nothing worked but changing the windshield. It's been fine ever since.
I also have trouble with the serpentine belt. I usually need to replace it once a year. I guess it's just a flaw that year has. Mine is usually still under warrenty from the shop and I just pay for labor.
I also have trouble with the cruise controls on the steering column going dead. If I move the adjustable steering column it fixes it.... usually. But not permanantly. I'll look into the wiring and the clock spring.
Thanks for the ideas.
<quoted text>
I think that everyone should bring suit against the dodge co. my van is sitting in the yard and won't start. We can go down the road and the gauges drop and then it quits running. We replaced the coil pack and the computer twice .
John

Atlanta, GA

#395 May 27, 2009
Over past year or two, I've had identical problem that Joe is having. My '98 Caravan has about 185,000 miles. Full service tune-up did not solve problem. Replaced ignition switch; no solution. Most recently had instrument cluster removed and examined; found nothing. My very reliable independent mechanic thinks it may be one of the computers but can't pinpoint it with his equipment. Thinks dealer may be able to. Unfortunately, I've not been overly pleased with dealers on past maintenance issues. Next step undecided.
joe vitelli wrote:
I need help. Has anyone experienced this intermittent problem?: sometimes my car will not start...the engine turns over then immediately shuts down...if i let it sit for a while it starts and will run fine for a few months then i get the same problem again...this has happened to me about 10 times in the last year...also during this failure it will not turn over when i turn the key...again - if i let it sit for a while it will run fine...Help
dead dodge

Mechanicsville, VA

#396 Jun 3, 2009
How to remove instrument cluster panel on 98 caravan
Christiaan Brown

Mesa, AZ

#397 Jun 20, 2009
sMILEs wrote:
Just now having problems with electrical system on 98 Grand Caravan 223000 miles. Electric fans will not come on for radiator. The relay and fuses are good. One rear vent window will not open or close and on the Heater/AC area four lights flash on and off while driving for 15 minutes and then go off until I restart the car. I have temporarily solved the fan situation with a toggle switch to the battery. I would like to nip this in the bud without dumping thousands into a car that is one major problem from the Junk yard. Any suggestions.
The radiator fan controller is a solid state variable relay to run the fans at different speeds it is about $55.00 and is located on the frame behind the air box next to the drivers side of the radiator, two bolts and disconnect the wire and it's off. replace that and your fans will run correctly. the vent window motor should be replaced, I had the same problem.
Christiaan Brown

Mesa, AZ

#398 Jun 20, 2009
For everyone that is having the insturment cluster go dead while driving and/or cannot get the engine to start (cranks, Starts then dies and then won't even crank over) the problem is in the insturment cluster. there is a printed circuit board on the back of the insturment cluster that has the connectors to the wiring harness one or more of the copper lans (the copper wires printed on the board has pulled away from the circut board and is making intermittanat contact. this is made worse be changes in temperature as the board expands and contracts. if you have a low voltage soldering iron and are handy with it remove the insturment cluster and remove the cover on the back of the display and scratch away the plastic covering on the loose pins to get more contact surface for the solder than using a rosen core solder re-solder the connections that were loose. that will fix the problem as the computer monitors the cluster.
Christiaan Brown

Mesa, AZ

#399 Jun 20, 2009
jennifer wrote:
I have a 98 dodge grand caravan and my anti theft device shutdown after my battery went and my starter since they have been replaced now the van wont start does anyone know how to reset the anti theft system or just disable it thank you

the anti-theft system is built into the engine control computer and cannot be disabled as far as i know. the engine computer may need to be replaced.
Vic in Colorado springs

United States

#400 Jun 28, 2009
I have a 1998 Dodge Grandcaravan with a 3.0 by airbag light is on and will not go off, my cruise control stopped at the same time. The car has not been in an accident it has 157787 miles. I changed the fuse al ready.
Suzy

Springfield, MO

#401 Jul 3, 2009
I have a 98 Dodge Caravan. We had a problem where every time you step on the brake you heard a loud spring noise and the brake would not catch. My husband replaced the front brake pads about 6 months ago and we are having the same problem again. Does anyone have any ideas as to what this could be, and does anyone know where to look for the ABS system?
john

United States

#402 Jul 12, 2009
service engine light came on in 98 caravan.starts right up,runs.when you put it in drive feel clunk and engine stalls.starts right back up.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Dodge Grand Caravan Discussions

Title Updated Last By Comments
2005 Dodge caravan won't start (May '11) Apr 25 Joe Hensley 35
Blown rod Apr 24 Joe 1
leak near top left hand side of radiator Apr 17 PAULT1105 1
2012 dodge gran caravan daytime lights do not work Apr 14 Maurice 1
06 Grand Caravan rear A/C evaporator leak (Jul '08) Apr 14 jamestsanders 360
Poll Have your headlights flicker/flash while driving? (Jan '09) Apr 13 brandonb 87
2006 grand caravan brake lights turn signal (Oct '08) Apr 8 Mikeybnoway87 10
More from around the web