Radio doesn't work after battery change
BBB

Jonesboro, GA

#22 Jul 26, 2010
I changed my battery on my 2008 PT Cruiser and now the radio, air conditioner does not work. Also the door lock does not respond to my automatic key lock.
Alton

Houston, TX

#23 Aug 3, 2010
you guys are having power shortage. battery was too weak to power everything. check the fuse on the back of the radio and the radio fuse in the fuse box. those would go before the radio I"ll bet.
Doubly frusterated

United States

#24 Sep 18, 2010
I have the same eq flashing problem after battery change. No one seems to have a answer.
Big Joe

Temecula, CA

#25 Sep 18, 2010
All radios have a 4 digit code. Comes with car. Could be on back of radio or listed in car
manual. If you don't have the code the dealer will charge $45. To reset. Newer model Chryslers have a chip in the key so, not only radio doesn't work but the alarm, and door locks, too.
Fort Wayne

United States

#26 Sep 23, 2010
"Doubly frustrated"]I have the same eq flashing problem after battery change. No one seems to have a answer.
After $ 80 diagnostic, dealer mechanic found no problem and still no answer to why the EQ light flashes even when the key is not in the ignition. The Battery dies if not started for few days. To be safe I had the radio unplugged. Very upset that no one seems to have answer nd I don't have radio/cd player either.
Casey

United States

#27 Sep 30, 2010
I have the 2001 Chrysler T&C the radio only works on AM. No FM or preset buttons. I haven't tried the cd player. Anybody having problems like that?
Colleen

Mechanicsville, VA

#28 Nov 1, 2010
My radio won't turn on at all. All other electronic features are working.
MRoberts

Calhoun City, MS

#29 Nov 16, 2010
Same thing happened with our '01 Town and Country. The battery went dead, when I tried to start it, the equalizer lights were flashing, but nothing else on the radio/cd player worked. Even when I was jumped off it still didn't work, and hasn't worked for about a month now...very frustrating. I was hoping to find some help. I don't want to pay to get it checked if they can't find anything.
Colleen

Mechanicsville, VA

#30 Nov 16, 2010
My mechanic fixed my radio by disconnecting the battery completely and letting all the power from everything drain completely. Once he reattached the battery the radio came back on with my HD in tact. I was so worried I was going to lose 1100 songs I had downloaded but all of them were still there.
Colleen

Mechanicsville, VA

#31 Nov 16, 2010
I has something to do with removing all the cables to the battery and letting all the power run out in all the systems in the car. Once you reattached the battery everything reboots and my radio came back on. My battery had died too but jumping it didn't restart the radio. The battery actually has to be completely disconnected. Hope this helps you.
rachel g

Clemmons, NC

#32 Dec 15, 2010
maria wrote:
The same problem with the cd player after changing the battery wont work lights flashing called chrysler head quarters said there is no anti-theft code for it and dont understand whats going on.I will be writing to chrysler about it maybe everybody with this problem should maybe they should put a recall and find out what the problem is.I will be posting the address soon maybe we should all write about this problem and they should do something about it.
Any comments received from Chrysler? I replaced by battery and now the lights are flashing but the radio won't work. Dealership said that the radio was "shorted". I think this a a scam. Any more information or solutions available?
dusts

Rio Grande City, TX

#33 Feb 9, 2011
have you tried checking the fuses for radio/cdplayer?
LuLu

Greenville, NC

#34 Apr 25, 2011
Craig261 wrote:
<quoted text>
Did you figure out how to resolve this problem. I've got the same situation with my '01 T & C. Battery died. Radio didn't work after change.
I had the same problem. Went over year without a radio/CD player.
The charge to the battery killed the radio, which kept draining my battery. I had to get another radio. A local mechanic found a used one and put it in. Radio works fine now, but still waiting for a CD replacement .
MRoberts

Athens, GA

#35 May 25, 2011
This happened to us also, exactally. We tried to remove the radio ourselves to replace it, but then the security system of the van locked it down so we couldn't start the van up or anything. Everything was locked down like it thought we were stealing the radio. We finally got it to start after doing a lot of stuff to it. How can we replace the radio if it thinks we are stealing the radio and it locks up?
RickTC2007

Elizabeth, NJ

#36 Jun 1, 2011
I had a similar problem 5/30/2011. I had to replace the OEM battery in my 2007 T&C on Memorial Day afternoon. The next day the radio acted as if the antenna had been disconnected. There was no AM at all, and the FM band would get snatches of stations that I never heard of, and when they came in they would be on every preset, from one end of the dial to another. CD worked fine.

Out of desperation, I disconnected the negative cable from the battery for about 5-6 hours. When I hooked it back up, everything worked fine. I can't explain why it worked, only that it did.

Good luck to all.

Nansinator

Salt Lake City, UT

#38 Jul 29, 2011
tafkap777 wrote:
I changed the battery in my 2001 T&C and now the radio doesn't work. All I get is blinking lights on the equalizer. Is this some sort of security issue or something? Any ideas?
I had this problem in my H3. The battery died, I changed it out and then the radio, seat belt warning and key left in the ignition warnings all stopped working. I took off the neg. side connection of the battery, waited 5 minutes then hooked it back up and POOF it is all back to perfection, working great. Thank god for the internet and people helping other people with these types of forums. THANKS
hola

La Porte, IN

#39 Aug 8, 2011
hey i dont have a t$c but it happened to my civic. u need to call the dealer or chrysler n give them ur vin number and enter the code to get it to work again
Clytle

Las Vegas, NV

#40 Sep 1, 2011
It worked .disconnect negative terminal from battery for a few minutes,radio now works.thank you
otopp

Waldorf, MD

#41 Sep 6, 2011
My 2001 t&c has no blinking lights or anything..time displays..when I put a disc in it acts as if it wants to play but does nothing..there is no fuse for the radio nor the outlet this sucks....what the problem????
Richard

Las Cruces, NM

#42 Sep 10, 2011
Hey everyone,

If you have a blinking light, this is a problem of the anti-theft device in the radio itself. If a modern factory radio is disconnected from power, it thinks the radio has been stolen. Every new car comes with a five digit code, sometimes printed in the owners manual, for the radio. Turn on the power and then enter the five digit code using the program numbers. Should do the trick.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chrysler Town and Country Discussions

Title Updated Last By Comments
Tapping from passenger side firewall area when ... Sep 18 Steve2010ruth 1
Chrysler Town and Country transmission issue??? Sep 4 Mitch 1
2009 adjustment pedals switch Sep 1 Bangaang 1
Town & Country Sliding Door Pillar Buttons (Jan '10) Aug '16 Miriam 54
News FCA Ramps Up Rollout of 2017 Chrysler Pacifica ... Jul '16 Trump 9
low tire pressure light (Oct '06) Jul '16 Call me Wally 25
Holden astra 08 radio and rear wiper not workin... Jul '16 Ben 1
More from around the web