Power Steering pump
BIG VIC

Tarrytown, NY

#21 Nov 5, 2010
Have a 07 pt cruser the high presure line is leaking from the fitting behide the pump, install two o rings still leaking.. Is anybody having the same problems?
Jennifer

United States

#22 Jan 22, 2011
Biggie wrote:
My wife has a 01 Cruiser, she complained about some whining sounds a few days ago, last night on her way home from work she complained about not having any power steering. I check it out, fluid level looks good, no leaks but no power steering. I need some advice/help! Thanks, Biggie
I am having same problems. There was a recall on one of the power steering hoses however if it caused more damage they will ONLY replace the hose. fluid was good but we added more just incase and it all came out. I get a loud humming, whinning noise and it wont turn. it looks like belt is moving but not the pulley.
This car is complete garbage. I paid $2,000.00 on an extended warranty that covers nothing, Chrysler will not help in any way, or the dealer I bought it from and I have put almost $2,000.00 into it myself. Every time I fix something a month later something else goes wrong. I will never in life buy another Chrysler product. If someone even shows me a Chryseler product on their lot and says it's a dollar I will give them $10.00 to start it on fire. They have the worst customer service.
They build for looks. Not for quality or for the American people.
CHRYSLER LEARN FROM FORD,PAY BACK YOUR BAIL OUT MONEY YOU SUCK
pt from hell

United States

#23 Jan 22, 2011
I know exactly how you feel. I also will never buy another Chrysler product new or used. The problem is that they use cheap supplier parts and you end up with an unreliable vehicle.
Marquette

Laurens, SC

#24 May 26, 2011
Terry wrote:
I have a 2001 Cruiser and am having problems with the power steering pump. Noisy-sounds like fluid is low or out. Fluid level is fine-but mechanic says there is air in the fluid! No visible leaks of fluid on garage floor or pump. Any similar issues out there?
Yes, I too have that same problem it started yesterday.
drophit

Philadelphia, PA

#25 Jun 12, 2011
the problem is with the design .. putting a filter into the bottom of a resevoir so as to make it unserviceable is a terrible idea .. the retro fix is a higher pressure line to accomodate a clogged fluid source full of air.. the other oddity is having to cool power steering fluid should tell you something about the design as well ... leaks at the rack as a result of the heat .... really bad stufg
dave p

Commerce Township, MI

#26 Jun 29, 2011
mine was doing the same thing need to flush it out after i did that it was fine
Robin

United States

#27 Jan 6, 2012
I have a 01 pt cruiser it's been fine until it started making a loud whining every time it cranked up and got worse when I turn the steering wheel my husband had a heck of time replacing the pump took 8 hours drove next day sounded worse than b 4 it was replaced then the hose on bottom busted took 2 days 2 find a wrench 2 get 2 bottom end replaced finally and it still sounds like a furl and ......what the heck is wrong with it? Can anyone tell me what 2 do 2 fix HELP!!!!!!!
gman

Dallas, TX

#28 Feb 23, 2012
I have replaced 3 power steering pump on my 06 F350 6.0lt.Ford the front seal keeps blowing out on the pump does anyone have an explanation for this
granpa

United States

#29 Jun 2, 2012
thank you guys for posting all your problems ,and all your solving tips to fix them .it has really been a help to read these posts.I can't afford the shops nor buying the parts ,it helps to get to the root of the problem thanks .
pt remorse

Dickinson, ND

#30 Jan 30, 2013
Four flippin rack in pinions. Really. Always a leak. Can one mess up installing these things. I had to buy two. I am tired and this is getting real old. I think i need to buy a new car.
Debbe

Trinity, TX

#31 Mar 30, 2013
I have also had the same problem with my 01 PT Cruiser. Put 3 power steering pumps on, 2 high presure lines, and now having another power steering pump and the racken pinion steering replaced due to a leak on the passenger side. I hope this fixes it. So sick of this problem I could just scream.
freddie

Ada, OH

#32 Jan 1, 2014
my 02 pt is making steering squaling sounds is it pump reservoir preasure hose???
freddie

Ada, OH

#33 Jan 1, 2014
my 02 pt is squaling like a tipical pwr. st. pmp. noise , or is it. most reader comments lean to a stopped up screen somewhere HELP
Izzy

Jackson, MI

#34 Jan 31, 2014
Our PT power steering went out suddenly while we were on the highway. No weird noises, just hard to turn wheel. No leakage either. Any ideas?
christi

Baltimore, MD

#35 Feb 27, 2014
How much does it cost to replace the power steering pump?
jpubs

Los Angeles, CA

#36 Aug 21, 2014
Ed McConnell wrote:
Same problem... except I've "smoked" 4 pumps and 4 racks!!!! The shop keeps putting new ones in and they just keep failing? It just happened again today now I'm bringing it back for the 5TH TIME... They are telling me it's defective pumps?
Any suggestions
Well I have heard the filter in the reservoir gets clogged so no fluid is able to circulate. Remove the reservoir then clean it with carberator, cleaner then flush with water let dry and replace.
jpubs

Los Angeles, CA

#37 Aug 21, 2014
ptc2001 wrote:
I have a 2001 PT. I have this whining also.I was told to remove the fluid from the reservoir and replace it with the "Lucus Power Steering Fluid", which is a very thick substance. Afterwards, the power steering pump won't work. When I crank the vehicle up, the hose from the power steering reservior colapes and fluid sometimes comes out the reservoir cap, not thru the pin hole on top, but from under the cap. Please advise.....
the filter in the bottom of the reservoir is clogged take it off and clean it using carberator cleaner then back flush it with water. Let dry then reinstall it on car.
jpubs

Los Angeles, CA

#38 Aug 21, 2014
Robin wrote:
I have a 01 pt cruiser it's been fine until it started making a loud whining every time it cranked up and got worse when I turn the steering wheel my husband had a heck of time replacing the pump took 8 hours drove next day sounded worse than b 4 it was replaced then the hose on bottom busted took 2 days 2 find a wrench 2 get 2 bottom end replaced finally and it still sounds like a furl and ......what the heck is wrong with it? Can anyone tell me what 2 do 2 fix HELP!!!!!!!
he didn't flush out the fluid reservoir and it's still cloged
kurtcooksalot16

Orlando, FL

#39 Dec 9, 2014
It is starting to get really cold around where I live. The main thing that might happen this winter is having the pumps freeze over. They seem to burst when they freeze up. http://www.valleypumpnw.com/well-pumps/
David0529

United States

#40 Feb 8, 2016
Can anyone tell me if an 03 Pt Crusier has an electric power steering pump,or a belt ran pump?My sister had the hub bearing ,and tie rod changed.Now she said it hard to turn and feels like it doesn't have powere steering. It's full of fluid and no winning noise.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chrysler PT Cruiser Discussions

Title Updated Last By Comments
pt cruiser overheating (Feb '06) Jun 22 Pee on Cruiser to... 818
Alternator Removal and Replace on 2002 PT Cruis... (Sep '06) Jun 20 Rlittle 54
water leak on front passenger side (Jul '09) Jun 4 EmetS 16
battery and starting problems (Mar '06) Jun 3 mack 192
A/C problems (Feb '07) Jun 1 shayshay 61
Ac May 29 Kevin 1
2006 PT cruiser May '16 Louis 1
More from around the web