My Car also makes winding sound when I accelerate

Posted in the Chrysler 300M Forum

Dustin

Fairfax, VA

#1 Dec 7, 2006
I have a 1999 300m with just over 100k on it. When I turn on the A/C mare care makes a load squeaking noise. My Car also makes winding sound when I accelerate. Is this related to the A/C evaporator. Other than this car rides strong.
Chris

Coppell, TX

#2 Dec 8, 2006
Try replacing the belt for the AC
vega

Brooklyn, NY

#3 Aug 31, 2009
Chris wrote:
Try replacing the belt for the AC
I had the winding noise also when accelerating. Change timming belt it should be changed at 105k per maint. scheduel and also change water pump while ur at it and hyrolic tensioner. also replace ac belt and power steering belt and pulleys. this should cover all noises for sure.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chrysler 300M Discussions

Title Updated Last By Comments
2002 Chrysler 300 special front bumpercover Dec 2 Steven Agnitsch 1
Where is battery situated on Chrysler 300m (Mar '06) Nov '14 leo 39
Bought 2001 300m, need some help....new to me. Nov '14 martell12 1
2002 300m special tranny problems (Oct '07) Oct '14 kwaljames 36
2000 Chrysler 300M Engine Stall / Failure (Apr '06) Aug '14 Miranda 351
Chrysler 300M Check Engine Light (Sep '10) Aug '14 Lilayea 10
Tires on 300M special (Apr '14) Aug '14 KelH 3
More from around the web