Chrysler 300 Climate Control Light no...

Chrysler 300 Climate Control Light not working

Posted in the Chrysler 300 Forum

First Prev
of 4
Next Last
Alfred

Morgan Hill, CA

#1 Jan 14, 2008
My chrysler 300 climate control stopped working, i checked fuses all seem fine. Has anybody had this problem, or does anyone know what i can do to fix it? Thanks

Judged:

133

55

1

Reply »
Report Abuse Judge it!
Frank

Wakefield, MA

#2 Sep 3, 2008
Alfred wrote:
My chrysler 300 climate control stopped working, i checked fuses all seem fine. Has anybody had this problem, or does anyone know what i can do to fix it? Thanks
Just had the same problem today, 100 miles after warrantee expired. Does anyone know the cause?
Carlos

Grand Rapids, MI

#3 Sep 30, 2008
I just got a used 06 Chrysler 300 and the climate control area don't light up when the rest of the center console and dashboard light up. Is it suppose to light up?
fishfan

Sacramento, CA

#4 Dec 30, 2008
I have the same problem, I took the center dash apart and there are 4 small bulbs inside for the climate control. I do not know yet if the bulbs are replaceable or if the whole control box needs to be replaced.
Dave G

Menominee, MI

#5 Dec 4, 2009
Alfred wrote:
My chrysler 300 climate control stopped working, i checked fuses all seem fine. Has anybody had this problem, or does anyone know what i can do to fix it? Thanks
Did anyone ever get a fix for this problem? I am having the same issue with the climate controls and the airbag red light. The answers I am getting from the dealership are not helping. Thanks!
Alicia

Sioux Falls, SD

#6 Dec 4, 2009
I have a 06 Chrysler 300 and the climate control area lights quit working, there is a replacement light board or you can replace the whole unit which can be is about $485 with labor.
kingston

Gary, IN

#7 Dec 9, 2009
While driving my 300 my light goes on and off ... took it to the dealer and they can't solve the problem ... one dealer told me, my keys are to heavy .... please help
Ronald Carlson

Woodburn, OR

#8 Feb 8, 2010
My climate control does not blow warm air out of the
panel vents when on automatic climate control
Stevo

Tacoma, WA

#9 Jul 4, 2010
My 06 300 climate control works just fine, however the lights never did work. I didn't notice right away cause I was driving it mostly during the daylight. I just got it in may 2010 I plan to take it back and see if they will correct it on them. I'll let you know what they say!
Stevo

Tacoma, WA

#10 Jul 4, 2010
Oh I forgot to ask, how do you take the center console apart?
Duane

Apex, NC

#11 Oct 13, 2010
you basically just pull the trim panel off - only six clips holding it in place (at least on a Magnum - very similar). The climate controls and buttons are attached to the panel, the radio is attached to the dash. I start at the top, then the two clips on the sides are tough, then you can get a better grip on the bottom two once the top and sides are loose.
Nathan

Spokane, WA

#12 Oct 19, 2010
I have an 2004, the climeate control seems to work, but we cant see what the temp is becouse the lights are out.
anthony

Saint Paul, MN

#13 Nov 24, 2010
chrysler should have to make good on the no lights problem since it is very prevalent to the 300's the bulbs are junk and many of them burn out within months but being the kind of company that doesnt care about thier own dealers what do they care about customers.I'm just sayin'
Vincenzo

Glens Falls, NY

#14 Dec 19, 2010
If anyone gets an answer on the climate control lights issue, please post the fix. My 05 T&C has the same problem and I believe the climate control panel is the same or similar to the panel in the 300.
marc

Dublin, Ireland

#15 May 18, 2011
i have a 06 300c and some of the dash lights are dim and when i tap them they go bright again,is it easy to change the bulbs one by one
Dano

United States

#16 May 24, 2011
I have the same problem with the climate control panel (lights don't work) in my 1999 chrysler 300m. Has anyone fixed the problem yet? All I see is that is everybody has the same or similar problems, but know one has posted how they fixed it yet. Can the light bulbs be replaced or do we have to replace the hole panel?
Rich Lake

Vancouver, WA

#17 Jul 25, 2011
2005 Chrysler 300, climate control panel does not work (no fan, a/c, heat, rear window de-ice, nothing works) have checked fuses, changed panel, no help. anybody have any ideas ????
help
Rich
Freese

Rice Lake, WI

#18 Oct 28, 2011
Rich Lake wrote:
2005 Chrysler 300, climate control panel does not work (no fan, a/c, heat, rear window de-ice, nothing works) have checked fuses, changed panel, no help. anybody have any ideas ????
help
Rich
It appears that the problem is in the temperature climate control head. The Temperature Control Head is the unit in the dash that displays temperature and status of the climate and has the nobs and buttons on it. When the light is out and all other functions still work the fix is to replace the control head. If your heater or AC is exhibiting any of the following symptoms the problem is most likely with the digital motor speed control unit.
The blower is stuck on high
The blower is dead.
The blower can still run when the car is turned off.
All functions on your digital climate control work ok except the blower fan speed.
Jan Knudsen

Vissenbjerg, Denmark

#19 Oct 28, 2011
It is easy to replace the light bulbs, but this is not the cause of the probelm with no light in the display.
I have have the same problem and have come to conclusion that the probelm is with the Transistor (or IGBT) on the Print Board (PCBA). The transistor is situated next to the multi connector for the connection cable. The transistor is supplying power to the display light.
Light comes back in the display when I twickle a little with thje transistor (can only be done when PCBA is dismantled from the Clima Control Unit and connected via the multi connetor)
One or more of the 3 legs of the transistor seems to have loose connection inside the transistor or the transistor has delaminated. In any case the transistor is falty.
Solution: Replace the transistor.
G in Fl

Orlando, FL

#20 Nov 18, 2011
Just got a used '06 300. Drove on a rainy night and window fogged up...couldn't see the climate control or button display for front defogger because it wasn't lit. Almost drove off the road trying to find overhead light to see. Should I try replacing bulbs, can it be done or has anyone found that its faulty wiring? I called the manuf.'s 800 # and a guy said all models are different they don't know if it is supposed to light up. He did know that his girlfriend'a Honda doesn't! Thanks Chrysler employee you were very helpful!

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 4
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chrysler 300 Discussions

Title Updated Last By Comments
News Dodge Charger, Jeep Cherokee, Chrysler 300 reca... 11 hr checkit 5
News Cars that tell you when they're broken (Dec '14) Aug 11 Paula Thompson 3
Chrysler 300c Stalls (Oct '07) Aug 1 Karen LV 165
News FCA to recall 1.1 million vehicles for confusin... Apr '16 who 1
News Fiat Chrysler's recall, Toyota's earthquake woe... Apr '16 more of 1
News Fiat Chrysler recalling more than 1.1 million v... Apr '16 fred 4
Check Engine Light on for 3 days (Apr '06) Apr '16 Msdnicety 117
More from around the web