Honda Pilot Owners: Problems & Solutions

Honda Pilot Owners: Problems & Solutions

There are 1960 comments on the Edmunds.com story from Jan 27, 2006, titled Honda Pilot Owners: Problems & Solutions. In it, Edmunds.com reports that:

Created by KarenS in the Maintenance & Repair Message Board. Your Host is mr_shiftright What is this discussion about? Honda Pilot, SUV, Electric, Engine, Steering # 1514 of 1523 Re: Pilot 2006 Pro Con [ty2005] ...

Join the discussion below, or Read more at Edmunds.com.

Howard Derdiger

Pekin, IL

#989 Dec 18, 2008
Have they figured out the problem, Mine makes noise at about 46 MPH and the RPM at about 1000
Howard Derdiger

Pekin, IL

#990 Dec 18, 2008
I have a 2004 Pilot EXL with 76K miles. About 6 months ago i started hearing a noise when going about 46 MPH and keeping the RPM at about 1100. It sounds like some vibration coming from the front or the engine. Honda Mechanic could not fix.
Has anyone had this problem or found a solution to it. Thanks, Howard
jkwoods

Dallas, TX

#991 Dec 19, 2008
nsu wrote:
Our 2007 Honda Pilot is experiencing a loud humming noise, sounds like a deep bass vibration coming over the stereo system. Only problem with this analysis is that the noise still happens when the sound system is OFF! First experienced right after Labor Day 2008. At that time it only vibrated loudly at stop signs. Also, if you opened the window it would stop. Took in to dealer and they searched for any recalls. Honda told them to replace the noise dampener. Guess what, the noise is 100 times worse. Now the noise is audible on the road 75% of the time. It seems to occur when the car is not requiring gas to be fed. Going up hill no noise, when you crest hill and car kicks in the eco, the noise starts, as soon as requires gas again it goes off. This noise is very loud and very annoying. Pretty much, the noise comes from the back passenger side of the third row area.
HAS ANYONE HAD THIS PROBLEM SOLVED? WHAT DID THE DEALER DO TO SOLVE IT? PLEASE POST SO I CAN TELL THEM WHAT NEEDS FIXED. SOON!!!
nsu- Has anyone responded to your post? We are having the exact same problem with our 2007 Pilot. I called the Honda service department yesterday to ask if they had heard of this and they hadn't.
One thing I did try today -- when I am stopped and the vibration starts, I pressed the break pedal as far as it would go and the vibration stopped. So, I'm not sure if it has to do with the break system, but that's what I'm leaning toward. If I find anything I'll post it here.
Jim

Northumberland, PA

#992 Dec 25, 2008
I have a 2007 honda pilot. The interior light was left on and the battery went dead. I jumped the car and entered the "code" into the radio to get it to work. Radio lights up, shows the channel, time etc but no sound. At highest volume level (40) I can barely hear some sound coming out of one of the rear speakers.
Anyone have any ideas what to do?
Judith Ortiz

Rocky Hill, CT

#993 Dec 27, 2008
If a purchase and install a remote car starter do I deplite my warranty on my Honda 2006 Odessey?
Tony Thomas

Kansas City, MO

#994 Dec 28, 2008
The A?C in my 2003 Pilot stopped working. No air, hot or cold comes through the air vents.
tricia

Hasbrouck Heights, NJ

#995 Dec 28, 2008
we have had the same problems with 2006 Honda Pilot so dissapointed have you found a solution to cleaning the water stains off the seats - we have grey -
G-Man

Fort Myers, FL

#996 Dec 31, 2008
Mike wrote:
I get the Helicopter noise when the windows are down I'm sure its some kind of harmonic ..I dont Think its anything to worry about<quoted text>
I get the same noise when i roll down the windows on the highway (speeds in excess of 40 MPH.
G-Man

Fort Myers, FL

#997 Dec 31, 2008
I get the same noise when i roll down the windows on the highway (speeds in excess of 40 MPH.
G-Man

Fort Myers, FL

#998 Jan 1, 2009
I had the same problem with my 1997 Honda Civic. I discovered a clogged drainage hose on the A/C. Pine needles were the culprit. I cleaned the carpet but have been unable to get rid of the musty smell.
abailey wrote:
I have a 2003 Honda Pilot with almost 80K miles and I noticed a gurgling noise when putting on the brake and turning right. It only happened when the air conditioning was on so the dealership had a hard time replicating it. When they did, they said it was a clog in the air conditioning water hose and they unclogged it. Now the car smells like mold. The dealership offered to pull up the carpeting and clean it out for $500. The mold smell causes anyone who rides in the vehicle to cough after about 25 minutes.
<quoted text>
alisa

Pflugerville, TX

#999 Jan 2, 2009
thank goodness for your note! Worked like a dream and saved me goodness only knows what kind of headaches! thanx
jack wrote:
<quoted text>
try this, have your anti theft code card ready, vehicle full stop, engine not running...then at passenger's side under dash fuse box, locate the #13 fuse, theres a diagram on the fuse box itself, remove it for 10 seconds then return it from where you pulled it. afterwards, input code at radio then drive the vehicle the usual. if it still blinks, go to a trusted mech to have it scanned cause the powertrain control module senses some abnormality thats why it blinks... maybe temperature sensor or pressure switches of the transmission....
sometimes...again, sometimes a transmission fluid change does the trick. year today is 2007 your pilot model 2003, every 3yrs ,as per manual, change transmission fluid along w/ brake fluid.
keep us posted, goodluck and good day!
Jenn

Hayes, VA

#1000 Jan 3, 2009
I just took my 2007 Pilot in Friday for oil, tire rotation, front roter resurfacing and brake pads.

Drove it home with no problems, even turned off the engine for a few stops along the way.

I drove my husbands truck today and when I got home, decided I wanted to back the Pilot up a little.

I have NOTHING from it, no juice! Not even a click like a starter/battery issue. I can't get dash lights on. No doors were left open and no lights on. I just checked it over. Connections to the battery look good.

Any ideas???? [email protected]
I Hasan

Pelham, NY

#1001 Jan 4, 2009
Bought 2009 Pilot. Driving on the highway, is feels a draft from the driver side window. My wife was in the car with me, and she notice that passenger side window has the same issue, also, you can hear wind noise while drving although window are closed. Anybody has the same issue or what's the fix?
Sabrina

Phoenix, AZ

#1002 Jan 4, 2009
Mel wrote:
The rear air conditioning on my 2003 Honda Pilot just quit. I've checked the fuses and they are fine. Anyone out there who has had a similar problem?
I had the same problem a few years back, took it to the dealer where they replaced something under warranty. Now it's happened again. Haven't went to the dealer yet for fear it is no longer covered by warranty.
DANNY

Durham, NC

#1003 Jan 5, 2009
ALL HONDAS HAVE AN EXCESSIVE AMOUNT OF ROAD NOISE, RATTLES, BODY FLEX SQUEAKS, AND WIND NOISE. THAT, YOU CAN NOT DO ANYTHING ABOUT, SHEET METAL IS TOO THIN AND VERY LITTLE SOUND DEADENING MATERIAL IS USED. MY WIFE WANTED A PILOT UNTIL WE ROADTESTED AN 06 MODEL AND IT EXHIBITED THE EXACT SAME TRANSMISSION STUTTERS WHICH TO ME FELT LIKE AN ELECTRONIC PROGRAMMING ISSUE MORE THAN A MECHANICAL MALFUNCTION, THIS IN FACT IS VERY COMMON WITH ALL NEWER VEHICLES.
tdcruz

Cleveland, OH

#1004 Jan 6, 2009
Nissa wrote:
My Pilot is acting really weird. When it is in Park or Neutral, the engine revs up and down significantly but I'm not touching anything. It's fine in Drive. This started yesterday. Today, when I started it up, the Malfunction Indicator Light and the VTM-4 Light both came on. I have no idea what' caused this. It had been sitting in the cold, unused, for about 4 days while I was away, but I don't see how that could be an issue, though someone mentioned it might.
I own a 2004 Honda Pilot with over 100K on it so far I had this problem that you described I took my Pilot to Auto zone and had them diagnosed it for free it turned out to be an IAC (idle air control) sensor what I did was bought a $3 can of throttle body cleaner spray and did this to fix my problem 1)remove the plastic cover over the valve cover (4 bolts)@0 removed the air cleaner cover and diconnected a few of the vacuum hoses connected to the assembly (good idea to change your air filter at this time) and unscrewed the clamp that holds the large air intake hose to the throttle body.3)once I've removed all the parts it was easy access to the throttle body and cleaned out the entire throttle body with the cleaner spray I purchased per the directions on the can.$) I disconnected the negative battery terminal to reset the engine light. then reassemble saved myself a few hundred dollars the honda dealership wanted $298.00 to do the job when all I needed was a book and a $3 can of throttle body cleaner and a helpful Autozone employee
tdcruz

Cleveland, OH

#1005 Jan 6, 2009
I have a 2004 honda pilot I have condensation build up in my right headlight assembly I cant seem to get rid of I inspected the assembly and it is intact the only way I get it to clear up is by taking out the headlight and use a hairdryer to dry it up inside any other solutions out there?
MZH

Newark, NJ

#1006 Jan 7, 2009
Ghop wrote:
<quoted text> I have a 2004 pilot and have experienced the exact same thing as you. Dealer assured me there is nothing wrong but just like you it happens every couple of months or so.
I have the beginning of a similar problem with my Honda 2004 Pilot. Battery went dead, Restarted fine when jumped. I changed battery. Fine for two weeks. At routine oil change, Honda dealer says battery (which he does not know is brand new) is low and recommends changing. Sounds like a charging problem, and not a battery problem to me.
Sandie

Broadview Heights, OH

#1007 Jan 7, 2009
My 2006 Pilot which has less than 17,000 miles had engine problems in December when I attempted to take it on my first road trip. Without any warning signs the engine burnt a hole through one of the pistons and lost all compression in the cylinders.
Honda is covering the repairs but will not tell me if this is an issue with the 2006 Pilots. Has anyone else had this issue
Josiah

Edmonds, WA

#1008 Jan 10, 2009
My seat broke the same way. I looked underneath and it looks like just an L shaped bracket that is supposed to hold the front part of the seat down so that it doesn't rock back is broken. I'm going to see if someone can weld it for me.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Discussions

Title Updated Last By Comments
VAG scanner foxwell nt500 good or bad? 8 hr lanrce 1
My Monte Carlo Wont Start (Apr '10) 17 hr Blackheart 37
News If Chevrolet Suburban Won't Start It Could Be S... (Jun '09) Jun 23 Dizzy 219
News Volkswagen Looks To Compete With Tesla Jun 21 Solarman 1
suburban wont start Jun 20 stacy 1
News Strategic Vision Total Quality Awards Claim Ame... Jun 18 Solarman 1
96 Blazer Transmission Problems (Oct '06) Jun 18 Gerald Dixon 143
More from around the web