Honda Pilot Owners: Problems & Solutions

Honda Pilot Owners: Problems & Solutions

There are 1990 comments on the Edmunds.com story from Jan 27, 2006, titled Honda Pilot Owners: Problems & Solutions. In it, Edmunds.com reports that:

Created by KarenS in the Maintenance & Repair Message Board. Your Host is mr_shiftright What is this discussion about? Honda Pilot, SUV, Electric, Engine, Steering # 1514 of 1523 Re: Pilot 2006 Pro Con [ty2005] ...

Join the discussion below, or Read more at Edmunds.com.

rfsully

United States

#908 Aug 21, 2008
I have a 2005 Honda Pilot with Nav. The nav system generates small white dots for every destination you have stopped at. After a while, they accumulate, it gets annoying, and in general is not useful. Does anyone know how to erase them?
Tracey - Ontario Canada

London, Canada

#909 Aug 22, 2008
Anyone know any hit men for a 2003 Pilot?
Our car alarm goes off on it's own. It doesn't matter where it's parked or if it's day or 12:30 at night. We've taken it in to the dealership 3 times and of course it doesn't go off while sitting in their parking lot all day...but 5 minutes after we get it home it goes off. We now have to remove all belongings and leave it unlocked or our house will be bricked and I'm not kidding.
Does anyone have any ideas? Please a marriage is on the line...
Dan

Columbia, MO

#910 Aug 28, 2008
Megan P wrote:
I have a 2004 Honda Pilot and it has been what the dealer calls 'stalling' interminably until the other day when it just wouldn't start at all - so the dealer has had my car for 3 days now unable to diagnose this strange problem - b/c it only happens sometimes. Anyone else have this problem?
2003 with about 80k. I had the intermittent stalling issue. Took it to my mechanic and it is an issue with EGR valve. Apparently it is a known issue and will be covered by Honda for something like 8 years and 84k miles. If you are past that , it won't be covered by Honda and they said it has to be done at the dealership. Ours it at the shop now getting fixed
pet

Dover, DE

#911 Aug 29, 2008
my 2003 pilot has 110,000 miles. when i accelerate it pulls to the left, this happens at any speed?

Tires show sign of aliment and are the same size
sjames

Stillwater, MN

#912 Sep 1, 2008
Stephan wrote:
2003 honda Pilot. At 30mph, or at 50 mph, when coasting and RPM's are low (1300-1500) get a slight grinding noise that lasts for half a second, and keeps occuring every 5 seconds until speeds is increased, or gear shifts. Always goes away when dealership tries to diagnose it. When the sound occurs I get a blip in the RPM's too.
Wondering if it is a loose underbody engine panel that vibrates?? Does anyone know what I can do about this strange sound?
<quoted text>
I have this same exact problem with my 2004 Pilot. Did you ever figure out what was wrong?
Craig

Portland, OR

#913 Sep 2, 2008
I've got a 2004 Honda Pilot with 48K that's developed a starting problem...when I turn the key, the tach and odometer flutter and the starter won't turn over. Had the battery checked, and it appears to be fine. Eventually it starts and then all is fine, except that on occasion the oil light will stay lit (oil level checks out).
YHC

Smyrna, GA

#914 Sep 3, 2008
Craig wrote:
I've got a 2004 Honda Pilot with 48K that's developed a starting problem...when I turn the key, the tach and odometer flutter and the starter won't turn over. Had the battery checked, and it appears to be fine. Eventually it starts and then all is fine, except that on occasion the oil light will stay lit (oil level checks out).
I just had the same problem on my 2004 Pilot (44k miles). I actually had the problem before (maybe ~30k miles) and had to jump start it--seemed to fix the problem then. Seems like this has been a frequent problem on '03 and '04 models. Would love to know what the fix is, too...
T Yung

East Bridgewater, MA

#915 Sep 3, 2008
YHC wrote:
<quoted text>
I just had the same problem on my 2004 Pilot (44k miles). I actually had the problem before (maybe ~30k miles) and had to jump start it--seemed to fix the problem then. Seems like this has been a frequent problem on '03 and '04 models. Would love to know what the fix is, too...
After you get it started, does the AUTO window feature function properly?, if not, then it may be time to replace the battery.
Michelle

Aurora, CO

#916 Sep 3, 2008
I have an 03 pilot when I step on the gas it sounds like a plane engine I let up and you cannot hear it.
I think it is my tranny anyone have this issue? Also replacement part for driver seat adjuster assembly does anyone know where to go?
sybil

Toledo, OH

#917 Sep 10, 2008
Rob,
Did anyone answer this?

I have a 2004 Pilot with the flashing D. It seemed a little low, though the stick is hard to read, so I added about a quart of fluid. It flashed far less often. Only one time, I think. We just bought this car with 46K miles on it, so I drained and replaced the tranny fluid twice. I'm on a trip, but the wife says the D is flashing more often now. I have a feeling I didn't add enough fluid. Again, it smears all over the dipstick and is hard to read when you are in a hurry. My wife took it to Schuck's but they couldn't get a code with their reader. I guess a trip to the stealer is next, but they told me it would be $90 to diagnose. First I'm going to fill the fluid to the high side of the stick and see what happens. Let's keep each other updated on this one.
Thx.
sybil

Toledo, OH

#918 Sep 10, 2008
Two worsening symptoms, starting 2-3 years ago in my '03 Pilot:#1) The ENTIRE vehicle vibrates, sometime violently. It's random with inconsistent occurance.#2) Not always connected to the vibration is a whirring sound that seems to be coming from the left side of the dashboard when the windows are closed but if I have the window down and can get a better listen while driving slowly, I can definitely hear that it's coming from the underside and sounds like vibrating metal.(catalytic converter cover???)

I have taken it back to the dealer 3 times with no success. When it's taken out for a test drive, my Pilot won't act up (sort of like when a toothache stops hurting when you go to the dentist).

I don't know if the two issues are related; they do not occur simultaneously but it does seem that after the whirring sound occurs several times, the car will vibrate. That isn't always true but in trying to find some sort of relationship between the whirring and the vibration, this is about the only thing I can determine and even that isn't consistent.
RJ Cox

United States

#919 Sep 16, 2008
it the transmission.....the tcm is telling you that there is possible failure! take it to the nearest honda dealership as soon as possible.
Sammy

Bloomfield Hills, MI

#920 Sep 16, 2008
My 04 Honda has Wiper problems. The wipers start from the wiper switch and can't be turned off from the switch. I have to stop the engine and restart to turn off the wipers. I replaced the Wiper switch, but the problem continues to exist. Any help in resolving the issue is appreciated.
T Yung

East Bridgewater, MA

#921 Sep 17, 2008
Sammy wrote:
My 04 Honda has Wiper problems. The wipers start from the wiper switch and can't be turned off from the switch. I have to stop the engine and restart to turn off the wipers. I replaced the Wiper switch, but the problem continues to exist. Any help in resolving the issue is appreciated.
Have you tried replacing the relay?
Mandy

Walnutport, PA

#922 Sep 17, 2008
I have a 2007 Pilot EX-L (got it in October of 06). The first winter I had it when the temp was less than 20 degrees outside, the airbag light would come on. Took it in and they reset the error on the sensor and said I should be good to go. A week later the sensor came back on, took it back in and this time they replaced it. All was well until the next winter when it came on again. They replaced the same sensor again after keeping it for 3 days until the part came in. Waiting to see what happens this winter with that...

I left for work this morning to find that now the ABS, BRAKE and VSA lights are on and won't go off even after restarting and sitting all day..so tomorrow it goes back for the 4th time for warranty repair in less than 2 years!
Mike

Winnipeg, Canada

#923 Sep 17, 2008
My battery went dead from the lights being left on, I jumped it and the battery is fine again, but now I can't eject my DVD, and the screen says to "load DVD", but there is one in already. I also can't play the DVD. The light is also on that there is a DVD in the player. Everything else works on the radio and CD player. Any help? I tried disconnecting the battery to reset the computer, but that didn't help either.
Honda Loyalist

United States

#924 Sep 20, 2008
My wife and I have a 2006 Pilot EX that has had virtually no problems other than a couple of leaves in the ac blower fan that were making noise. I was able to drop the fan and remove those myself. Other than that, it has been a great vehicle. On the highway we can even get 23 mpg regularly, even with a full load of people, using cruise control and via our K&N air filter. It rides great, handles excellent for an SUV and pulls strong throughout the RPM range. We have had no fit and finish issues or any of the other pesky problems mentioned in this forum. My first car was a 91 Prelude Si, which I drove for 10 years. Even though it eventually blew a gasket, mainly my fault for driving it overheated and leaking coolant once, it was another great vehicle. I am in the market now for a new 09 Fit. Love the Hondas, and I just wanted to state that your problems seem to be anomalies, mostly.
John C

Antioch, CA

#925 Sep 20, 2008
Wendy wrote:
My 2003 Honda Pilot is having some A/C problems. It has 43,000 miles on it. I've started having problems last week. The A/C works for short periods of time,depending on the speed that you are going. SHort trips(like 4 miles) it works great anything more than that it goes out. Plus, for the last month when I park the car I started hearing a loud fan running on it. Hubby seems to think it may have something to do with the engine.I am wondering if you Honda acted crazy like that. I also replaced the battery 4 weeks ago at the dealership. <quoted text>
Hi Wendy,

IF you search the web, you will find this is a common problem. I had the EXACT same symptoms you did and just fixed the problem, and took a number of pictures also. If you're interested you can email me at [email protected], and I can tell you what needs to be done. The parts cost about $100 from the dealer, you may be able to get them for a little less...

John.
suda

Saint Petersburg, FL

#926 Sep 20, 2008
Kim wrote:
I have a 2004 honda pilot -Please help - my battery went dead and now I have no radio, clock, etc. It says "code" and after reading the manual, it was supposed to be reset after 3 days. It has been a week and still no change. Anyone else had this problem?? Maybe the dealership has codes??
the code should be on the door of your glove compartment.
Rob

Englewood, OH

#927 Sep 21, 2008
sybil wrote:
Two worsening symptoms, starting 2-3 years ago in my '03 Pilot:#1) The ENTIRE vehicle vibrates, sometime violently. It's random with inconsistent occurance.#2) Not always connected to the vibration is a whirring sound that seems to be coming from the left side of the dashboard when the windows are closed but if I have the window down and can get a better listen while driving slowly, I can definitely hear that it's coming from the underside and sounds like vibrating metal.(catalytic converter cover???)
I have taken it back to the dealer 3 times with no success. When it's taken out for a test drive, my Pilot won't act up (sort of like when a toothache stops hurting when you go to the dentist).
I don't know if the two issues are related; they do not occur simultaneously but it does seem that after the whirring sound occurs several times, the car will vibrate. That isn't always true but in trying to find some sort of relationship between the whirring and the vibration, this is about the only thing I can determine and even that isn't consistent.
The 2nd issue sounds similar to something I have noticed on our 08 pilot. we discovered it was an issue w/ the air conditioner. I found a lot of these service people do not really know what they are doing unless you hold their hand be as specific as possible i.e. tell them where to look.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Discussions

Title Updated Last By Comments
My Monte Carlo Wont Start (Apr '10) 13 hr van 67
News China's Buick Velite 5 is a Volt with a nose job Thu glasspilot 2
News Locked-And-Loaded Electric Audi SUV Starts Taki... Apr 24 Solarman 1
News If Chevrolet Suburban Won't Start It Could Be S... (Jun '09) Apr 19 Anonymous 259
News Why Can't Other Plug-In Hybrids Copy Chevy Volt... (Mar '15) Apr 18 wxxyz 44
Dome lights and trunk not working 2010 Chevy Ma... Apr 17 Filly05 1
News Reports: 2004-2006 Chevy Uplander Sliding Door ... (Aug '07) Apr 14 nedobs 177
More from around the web