Chevrolet Malibu Owners: Problems & Solutions

Created by KarenS in the Maintenance & Repair Message Board. Your Host is mr_shiftright What is this discussion about? Chevrolet Malibu, Chevrolet Malibu Maxx, Sedan, Electric, Engine # 2962 of 2971 Visor and ... Full Story
GMR

Barrie, Canada

#1517 Oct 22, 2008
Jessie M wrote:
I have a 2007 Malibu. I've been having problems with the rear light system. First, my rear right signal light went out, then the left a few days later. The front signals work fine, and the dash signal indicators go twice as fast as they did before the rear signal lights went out.
Now my whole tail light system is being screwy. Sometimes the lights work...sometimes they don't. I noticed just yesterday morning that they were working when I unlocked my car via remote, but that afternoon, they didn't.
My husband checked the fuse box, and everything looks fine, so I'm thinking it's a wiring problem. It wouldn't be a bulb issue, would it?
Help? PLEASE?
Until recently I would have agreed ,`Not the bulbs' ; however, have just had a freaky intermittent problem with wifes Dodge Spirit; after the usual exhaustive check of wiring and grounding points the problem persisted until I changed what was apparently a perfectly good bulb; then end of problem !
Try bulb change first as it's easiest; then work through grounding points; then wiring.
jackdaw

Calgary, Canada

#1518 Oct 22, 2008
Jessie M wrote:
I have a 2007 Malibu. I've been having problems with the rear light system. First, my rear right signal light went out, then the left a few days later. The front signals work fine, and the dash signal indicators go twice as fast as they did before the rear signal lights went out.
Now my whole tail light system is being screwy. Sometimes the lights work...sometimes they don't. I noticed just yesterday morning that they were working when I unlocked my car via remote, but that afternoon, they didn't.
My husband checked the fuse box, and everything looks fine, so I'm thinking it's a wiring problem. It wouldn't be a bulb issue, would it?
Help? PLEASE?
I can agree with Mike in his answer to check by replacing the bulbs to see if that solves the problem. My thinking is that its not that easy as the wiring system is completely different from older systems. Most or all control signals are through the BCM (body control module) The wirings now carry more than one signal which are analysed by the BCM and routed to the proper destination. This is where most elect problems arise as the BCM gets conflicting information and we end up with irritating glitches. I'm not sure about the 2007 Malibu but on the 98 Malibu there is a circuit board in each tailight which seem to cause these problems. I changed the circuit board and that solved my problem. Hope this helps.
smorris

Kenton, OH

#1519 Oct 23, 2008
This has been a nightmare. I had a difficult time finding anyone that wanted to repair a Quad 4 engine. I was told it was difficult to get to the water pump. Should I do something about the mechanic who put the engine in? I paid $1500 to have the engine put in and it's always had problems since. I think I've put more anti-freeze in than gas. It leaks, the mechanic replaced faulty hose 4 times. Now the water pump is out and he wants to charge me $500 to fix it! What's wrong w/ this picture?
Sandy P

Wayside, WV

#1520 Oct 24, 2008
My Mom has a 99 Malibu, We are getting ready to have the Ignition Coil and Housing replaced for the 4th time. Any idea why this is happening so often?
Heather

Jamestown, NY

#1521 Oct 24, 2008
I have a 2005 Chevy Malibu Maxx (87,000 miles) with what appears to be a ghost! My power door locks "go crazy" by locking and unlocking themselves continuously. This happens while driving, parked, and even with the car completely shut off. I have often locked the car at night, and come out in the morning to find it had unlocked itself. This is an intermittent problem that will occur for a few days, then not happen for a week or so... repeat.

Also, the power lock buttons on both driver and passenger side do not work - I have to manually lock all 4 doors. I can unlock the doors from outside using a key, but cannot lock them in this manner. This problem occurs consistently, whether the "crazy ghost" is at work or not.

I believe there may be a connection to another problem with my battery dying when the doors are left open or accessories are left on for 5-15 minutes without the car running. This happened consistently for a few weeks, but has "magically" stopped.

In addition, my front passenger turning signal lamp will not work. The bulb has been replaced twice. The first time it worked for 3 days, then blew again. The second replacement bulb never worked once.

But wait, there's more! The Information Center randomly says "Low Coolant" or "Check Gas Cap" when there si no problem with either...

Could all this be related? Hopefully a simple wiring problem or short somewhere? This car is driving me nuts!
jackdaw

Calgary, Canada

#1522 Oct 25, 2008
Heather wrote:
I have a 2005 Chevy Malibu Maxx (87,000 miles) with what appears to be a ghost! My power door locks "go crazy" by locking and unlocking themselves continuously. This happens while driving, parked, and even with the car completely shut off. I have often locked the car at night, and come out in the morning to find it had unlocked itself. This is an intermittent problem that will occur for a few days, then not happen for a week or so... repeat.
Also, the power lock buttons on both driver and passenger side do not work - I have to manually lock all 4 doors. I can unlock the doors from outside using a key, but cannot lock them in this manner. This problem occurs consistently, whether the "crazy ghost" is at work or not.
I believe there may be a connection to another problem with my battery dying when the doors are left open or accessories are left on for 5-15 minutes without the car running. This happened consistently for a few weeks, but has "magically" stopped.
In addition, my front passenger turning signal lamp will not work. The bulb has been replaced twice. The first time it worked for 3 days, then blew again. The second replacement bulb never worked once.
But wait, there's more! The Information Center randomly says "Low Coolant" or "Check Gas Cap" when there si no problem with either...
Could all this be related? Hopefully a simple wiring problem or short somewhere? This car is driving me nuts!
Sounds like Body control module (BCM) problems
well

AOL

#1523 Oct 25, 2008
sounds like lots of issues with the malibu
Cannuck

Montréal, Canada

#1524 Oct 26, 2008
Shawnna wrote:
OK. Now, I checked the brake fluid, and made sure that it was full. It was. The light is still on and it keeps beeping at me everytime I hit the gas. The brake pedal appears to be up all the way. Any suggestion?
<quoted text>
It's probably something to do with your abs, sensors or one of your front hubs and bearings.
donna furr

United States

#1525 Oct 26, 2008
i had the same problem with my 02 malibu sometimes they worked and sometimes the failed me safty issue if you get hit in the rear the dealship had to replace the entire blinkner system
donna furr

United States

#1526 Oct 26, 2008
now my problem my just died and will not start now any ideas!!!
Jessie M

Fayetteville, NC

#1527 Oct 27, 2008
jackdaw wrote:
<quoted text>
I can agree with Mike in his answer to check by replacing the bulbs to see if that solves the problem. My thinking is that its not that easy as the wiring system is completely different from older systems. Most or all control signals are through the BCM (body control module) The wirings now carry more than one signal which are analysed by the BCM and routed to the proper destination. This is where most elect problems arise as the BCM gets conflicting information and we end up with irritating glitches. I'm not sure about the 2007 Malibu but on the 98 Malibu there is a circuit board in each tailight which seem to cause these problems. I changed the circuit board and that solved my problem. Hope this helps.
Ha! Turns out it was the bulbs...there was a short in one or both of the signal bulbs, and replacing them fixed the whole problem! Go figure...
opal C

Brady, TX

#1528 Nov 1, 2008
Where can I find a front passenger seat frame?
And how do I replace it? Mine is broken. Don't want to go through the dealership. 2004 Malibu LT. Love my car. I have only had maintenance problems except for the seat frame.
GMR

Barrie, Canada

#1529 Nov 1, 2008
opal C wrote:
Where can I find a front passenger seat frame?
And how do I replace it? Mine is broken. Don't want to go through the dealership. 2004 Malibu LT. Love my car. I have only had maintenance problems except for the seat frame.
Auto wreckers / Re-cyclers are best bet. Mine are always wlling to give advice on how to remove / replace parts.
Even better ; take your tools and take it off yourself if they permit; you save money plus get small parts such as clips and bolts; any mistakes dont chew up parts of your car.
Michelle

Midland, MI

#1530 Nov 2, 2008
I have just replaced my wheel bearing on 03 malibu. This is the second time in just over a year. Is anyone else having problems with wheel bearings or could this end up being a bigger (and more expensive) problem or is it just something that is a continuous problem? Any suggestions? Also, is there an easier way to get the heat shield off and get to the thermostat other than taking the air box off and the exhaust cross over pipe?
Golfnstuff

Saint Peters, MO

#1531 Nov 4, 2008
2004 Malibu. If I lock the door and later unlock with the key, the alarm goes off. If I use the key pushbutton to unlock the door, the alarm doesn't go off???? Any ideas? Will lifting the negative battery cable reset the system and fix the problem?
rick

United States

#1532 Nov 5, 2008
at what mileage does the timing belt needs to be changed on a 2002 malibu? i was told around 200k
GMR

Barrie, Canada

#1533 Nov 5, 2008
rick wrote:
at what mileage does the timing belt needs to be changed on a 2002 malibu? i was told around 200k
Thought they had a timing chain; not a belt !!
(Only change chains if there is a problem.)
pasquale

AOL

#1534 Nov 8, 2008
Michael wrote:
My 2004 Maxx has the turn signal issue on the left front. While getting that repaired, I found out the back disk brakes had 10% left on them, the fronts are hardly worn - estimated cost by the dealer $480. Current milage is 23,800 miles, no towing or heavy hauling. Is anybody else having brake issues? Any comments or solutions?
I had the same problem with both items mentioned on my 2005. Midas agreed to turn the rotors and the cost was $265.00. Now I believe the steering will go out soon. I will not renew my loyalty to chevrolet ever again.

“Treat each day as your last, ”

Since: Sep 07

Location hidden

#1535 Nov 9, 2008
Michelle wrote:
I have just replaced my wheel bearing on 03 malibu. This is the second time in just over a year. Is anyone else having problems with wheel bearings or could this end up being a bigger (and more expensive) problem or is it just something that is a continuous problem? Any suggestions? Also, is there an easier way to get the heat shield off and get to the thermostat other than taking the air box off and the exhaust cross over pipe?
Michelle, The wheel bearing thing is pretty common, you must purchase the better (or new) of the two after market bearings that are available, the cheap one won't last to the 12 month warranty period.

The thermostat is really not that bad a job, you don't have to take the heat shield off or cross over pipe like they say, you loosen the rear bolt (it has a slot in the housing not a hole for the bolt to go through) then remove the front bolt and the housing will come out of there, believe it or not.

Good Luck
Ashley

Montgomery, AL

#1536 Nov 10, 2008
Michael wrote:
My 2004 Maxx has the turn signal issue on the left front. While getting that repaired, I found out the back disk brakes had 10% left on them, the fronts are hardly worn - estimated cost by the dealer $480. Current milage is 23,800 miles, no towing or heavy hauling. Is anybody else having brake issues? Any comments or solutions?
My 2005 Malibu also has a turn signal problem. It works intermittently. I have changed the bulbs twice. Just going to deal with it considering I am now past my warranty. I also just had to replace the rear break pads and roters! The front if fine and still has a good eight months. The front sould have worn way quicker than the rear. You are not alone....just get your problems fixed before your warranty is up!! My problems stated at 37,000 miles.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Discussions

Title Updated Last By Comments
Chevy Impala Owners File Class Action Lawsuit A... (Jul '11) Mon rising sun 36
Honda Pilot Owners: Problems & Solutions (Feb '06) Mon liner 1,890
Who is BEST: Ford, Chevy or Dodge??? (Mar '08) Dec 15 Angela O 59
If Chevrolet Suburban Won't Start It Could Be S... (Jun '09) Dec 11 Furnace 134
Transfer Blurays for DLNA hard drive for output... Dec 10 HaileyLi 1
Should a Toyota guy go Chevy? (Mar '14) Dec 9 Beaks 46
A photo of General Motors headquarters located ... Dec 9 dollarsbill 4
More from around the web