Comments
1 - 3 of 3 Comments Last updated Jul 15, 2008
Hanlon

United States

|
Report Abuse
|
Judge it!
|
#1
Dec 26, 2006
 
When I am applying my brakes both my turn signal indicators come on. Last night when I used my turn signal (the left) it blinked really fast, so I thought my light was out. Now today when I hit the brakes both the indicator lights come on and when I use the turn signal it works fine.

Any thoughts?
kab

Tulsa, OK

|
Report Abuse
|
Judge it!
|
#2
Jan 15, 2007
 
Check the tail lights. One or both may require new circuit boards and pigtail. Very very common.
carrott

Windsor, Canada

|
Report Abuse
|
Judge it!
|
#3
Jul 15, 2008
 
Pull the plug off the circuit boards and look at the black wire terminal in the pigtail. It will probably look burnt Just replace the pigtail that needs it and all will be well. It is a bad ground.

Carrott

Tell me when this thread is updated: (Registration is not required)

Add to my Tracker Send me an email

Type in your comments below
Name
(appears on your post)
Comments
Characters left: 4000
Type the numbers you see in the image on the right:

Please note by clicking on "Post Comment" you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

12 Users are viewing the Chevrolet Venture Forum right now

Search the Chevrolet Venture Forum:
Title Updated Last By Comments
venture temperature gauge and cooling fans (May '07) Jul 24 gtorres 72
Chevy Venture overheating problem (Feb '09) Jul 20 noah 71
driver information center (DIC) (Mar '06) Jul 13 Jim 16
Changed drive axles and hubs now won't move Jul 4 Keith 1
2002 chevy venture front turn signals are not w... (Apr '13) Jun 30 fish_oil 8
2002 Chevy Venture Won't start. (Feb '12) Jun '14 tony 4
1998 Venture Window problems both windows (Aug '07) Jun '14 JJW 28
•••

Buy a New Car


Zipcode:
•••
Enter and win $5000
•••
•••