Uplander Transmission Problems
bee

Fountain, FL

#41 Sep 7, 2010
i have a 2006 uplander it started making a noise at few days after i got me transmission fluids changed. Then it was pulling to go into gear a few times until it just stopped going into gear after making stops. I have taken it to shop waiting to hear thier verdict.???
Regina

Oconomowoc, WI

#43 Oct 4, 2010
I have a 2006 chevy uplander and it is ticking like it is the lifters. I have replaced some many parts on this piece of shit.T he car dealer practically gave this vehicle to me and know I see WHY....
ahm

Victoria, Canada

#44 Oct 6, 2010
Hi john
i have problem in my 07 uplander transmession
it is 111 km
sometime i feel i pot gear ON (N) not on (D)
and it makes sound crash (huge)

what do you think .. if i change spark blugs and wires...it work

thanks
Robert Bertke

Middletown, OH

#45 Nov 1, 2010
at 99320 my transmission is beginning to slip as well. what are my options in getting this repaired?
Robert Bertke

Middletown, OH

#46 Nov 1, 2010
At 99325 my transmission is beginning to slip as well. What are my options in getting this repaired?
ola

Victoria, TX

#47 Nov 26, 2010
when I start to go my uplander jerks...Doesn't do it all the time.had transmission flushed and it did not help...it does it often now...what is causing this....yes it is a 2006 uplander
Digitafuture

Burlington, Canada

#48 Nov 26, 2010
There's a TSB (#08-07-30040) about transmission jerking having to do with the magnets inside the tranny being too small to collect the metal shavings, causing the shift modulator to malfunction.

It's happened a couple of times on my 07 SV6, I found that warming/running the engine for 30 seconds before driving away eliminated the problem.

Nest time the fluid is replaced, I'll have the magnets replaced too,
Randell

United States

#49 Dec 18, 2010
My 06 Uplander has and RPM surge, accompanied by hard shifts that are progressively getting worse. I took the neg batt cable off and it seemed to change the characteristics, but not fix the problem. Had the fluid and filter changed as well and that didn't help. So now, I'll start narrowing down from plug wires, speed sensors, and then go on to the valve body and PSI solenoid. These Uplanders are trash. My father retired from GM after 39 years about 10 years ago. We've both bought our last GM products. Never thought I'd ever buy a rice burner, but the home grown stuff just doesn't cut it anymore.
dave

United States

#50 Feb 5, 2011
having poblems with 07 uplander..... a real pos.. had engine replacedlast year, damn near all suspension parts, now trans. when cold it shifts fine, once warmed up it wont go anywhere.... any ideas???
Bill in Miami

Miami, FL

#51 Feb 7, 2011
Mike wrote:
I am having problems getting my uplander out of park. Anyone having same problem?
Yes, I started having problems getting mine out of park about two weeks ago and today it started shuddering and not going forward. Made it home and now I'm on the web trying to find out anything I can.
I have the same problem

Bridgewater, NJ

#52 Feb 7, 2011
Im sorprice their has not been a recall on these uplanders, seems like everyone is having the same problem, including me, they look nice but to many problems,
brooke

Cincinnati, OH

#53 Feb 15, 2011
My 07 Uplander is having a hard time shifting at take off. I have had it in the shop several times and they cannot find anything wrong! I am afraid that it will leaves us stranded and I have 2 small children. Any suggestions?
Uplanders are terrible

Vancouver, WA

#54 Feb 16, 2011
I'm wondering how to get a class action lawsuit for the Chevy Craplanders. Mine is an '05, and the engine blew up within 3 years, the transmition in 5, there's always a knocking sound, lights flickering, and now it makes a weird sound when I turn. I thought maybe it was because I had an '05, but it doesn't sound like they have fixed anything in the later models.

The only suggestion I have is keep your onstar subscription active because you'll need it when it leaves you stranded.
Rob

Winnipeg, Canada

#55 Mar 14, 2011
My 2007 uplander With 50,000 kms stalls the engine or kills the battery when I put it in reverse. Sometimes I,m lucky and it stutters and I can back up jerkily about ten feet or so before it quits on me. Anyone else with the same problem? Or solution?
Steve 2007 Chevy Uplander

Bradford, Canada

#56 Mar 25, 2011
Randell, I had the same problem, it was the VSS sensor. I pulled it and found it caked in metal dust. I cleaned it, reinstalled it, problem gone.
Randell wrote:
My 06 Uplander has and RPM surge, accompanied by hard shifts that are progressively getting worse. I took the neg batt cable off and it seemed to change the characteristics, but not fix the problem. Had the fluid and filter changed as well and that didn't help. So now, I'll start narrowing down from plug wires, speed sensors, and then go on to the valve body and PSI solenoid. These Uplanders are trash. My father retired from GM after 39 years about 10 years ago. We've both bought our last GM products. Never thought I'd ever buy a rice burner, but the home grown stuff just doesn't cut it anymore.
Steve 2007 Chevy Uplander

Bradford, Canada

#57 Mar 25, 2011
I have the problem of the transmission banging into drive in 1st gear. I will try a strong, rare earth magnet under the pan to collect metal dust and see if it works.

here is a TSB about the transmission in the Uplander, Montana, Relay, etc. I recommends removing the square magnet in the transmission oil pan and replacing it with two (2) old style round magnets, one in the pan and one on the filter. It show's where to place them.
The TSB explains about metal building up on the magnet and being too close to a PCM valve which affects the hydraulic pressure in the tranmission. I made the change when I changed the trans. oil. I wasn't having any problems at 60,000Miles when I changed the oil and I'm not having any trouble at 75,000Miles.
Steve 2007 Chevy Uplander

Bradford, Canada

#58 Apr 6, 2011
April 6, 2 weeks after I installed the Magnet. My wife drives the uplander and says the problem has decreased. I will keep you posted.
tjv

Dallas, TX

#59 Apr 6, 2011
Nadine wrote:
Can you give us the web address?
I had my transmission die at only 59000 miles, and 300 miles from home on my 2006. no towing and oil changed every 3000 miles. I am so upset about this and want as much info as possible. If anyone has advise or info, please advise me. My oil changes were at a certified licensed shop but not the dealership, so I am wondering if they will give me a problem with powertrain warranty.
Thanks in advance.
<quoted text>
what oil were you changing every 3000 ?? are you talking about the engine oil ? that has nothing to do with the transmission. the transmission also has fluid that needs to be changed every 25,000-30,000 miles.
Cynthia

Tucson, AZ

#60 Apr 22, 2011
Having some type of problems with mine at 85000 miles it started when I am at a standstill at a stop light or stop sign <resting> then go to give it gas to accelerate her a thunk and then a stagger then after a few seconds it starts to move. Took it several times to a chevy dealership complaining of it and yet they say they hook it up to a diagnostic machine and nothing indicates a problem??? Which I had to pay for the diagnos!! Is there anything legally we can do to make them pay attention and fix this??? I mean it happend right off I bought it off the lot and they mechanic told me the robotic arms that installed the tranny did not install it right!! They had to redo the whole tranny kit but of course that was when it was brand new and under their warranty!! I about ready to take it back to the dealership and find the guy whole sold it to me and raise wholly cain and picket their dealership till they resolve this situation. To top it off now my engine is also ticking!!!
John

Tampa, FL

#61 May 2, 2011
I went through the same issue with several dealers "saying" they couldn't find anything with my 2006 Uplander (read earlier posts). Not giving up, I kept the pressure on Chevrolet warranty program and Ferman Chevrolet on Adamo Drive in Tampa. My slippage and jolting issue was fixed and after driving at 20,000 since repairs, still no problem.

Here's what I wrote earlier in this forum:

"We picked up our 2006 Uplander with the transmission slip from the dealer last night and here's what was on the labor & parts form: Reconditioned trans, replaced forward band, both sprags, pressure control, solenoid and flushed cooler"

Keep in mind I fought hard to have this work done under my extended warranty before it ran out. I would imagine the repairs would have been expensive if it was out of pocket.

The bottom line: Never have auto service at a GM dealer if not under warranty and never purchase another GM product.

I felt your pain and frustration.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Uplander Discussions

Title Updated Last By Comments
08 Uplander will not start (Dec '08) Aug 23 Jtrim 44
News Reports: 2004-2006 Chevy Uplander Sliding Door ... (Aug '07) Aug 1 Kristi36mitch 176
Chevy Uplander A/C (May '07) Jul '16 king 13
Noise from front end, uplader (Feb '08) Jul '16 Joe the mechanic 72
Power loss Jul '16 Ruth 1
2005 chevy uplander hard to start (Sep '08) Jul '16 myself 33
stop talking about uplander and everyone shoul... (Oct '14) May '16 pissed off 2
More from around the web