Car shuts off when A/C on
First Prev
of 9
Next Last
Fabian

Naples, FL

#1 Jul 24, 2007
Hi! I hope somebody can help me with my problem, thanx.
everytime i turn on the a/c when the car is running the engine shuts off. but when im driving i can turn it on but it feels like it takes alot of power from the engine. i have a system on the car and somebody told me that the system is taking too much power from the battery. is this my problem. somebody help plz. its really hot here in florida.

Judged:

831

118

Reply »
Report Abuse Judge it!

Since: Jul 07

Choctaw, OK

#2 Jul 25, 2007
System? What kind of system?
Try disabling the system so it can't work and then see if the problem is still there.
Oscar

Mansfield, OH

#3 Aug 28, 2007
I have the same problem with my trailblazer 03
I seriously doubt it its my amplifier that is causing the problem. Would someone please reply
Jimmy

AOL

#4 Sep 1, 2007
I have an 03 Trailblazer that is doing the same thing. When it is at idle I can turn on the A/C and it will bog the engine to a point of stalling.
When the compressor clutch engages the idle goes way down. The compressor will disengage and the idle goes back up. It just cycles like this over and over till the engine eventually stalls. I thought it might be a bad compressor, but I don't know for sure. I could use some help. I can't drive it with the air because it pulls the power down and when you stop the engine will go dead.

Judged:

531

229

Reply »
Report Abuse Judge it!
Oscar

Mansfield, OH

#5 Sep 4, 2007
Jimmy wrote:
I have an 03 Trailblazer that is doing the same thing. When it is at idle I can turn on the A/C and it will bog the engine to a point of stalling.
When the compressor clutch engages the idle goes way down. The compressor will disengage and the idle goes back up. It just cycles like this over and over till the engine eventually stalls. I thought it might be a bad compressor, but I don't know for sure. I could use some help. I can't drive it with the air because it pulls the power down and when you stop the engine will go dead.
My Trailblazer is fine now thanks to God!
I can only give Him the glory for fixing my problem with the ac, cause I did nothing else except pray about it. I spoke with the dealer though and ask them about my situation. They say that when the battery is disconnected it is possible to lose some of the programming. That it would have to be brought in for reprogramming. I went about 2 weeks I think or it seemed. Before my problem was divinely solved! I thank God cause there was no way I was going to be able to afford what the dealer might have charged me. So just pray, there is power in prayer!!!!!!!!!!

Judged:

292

84

2

Reply »
Report Abuse Judge it!
Paul

Anaheim, CA

#6 Oct 22, 2007
I hope someone can help me on this. I have a 1995 Ford Explorer and when I turn the A/C on or heat on the engine makes a loud, rough noise and shuts off. I tried just turning the vent on and it works fine. Please help me solve this problem. Thanks!
hsd

Sydney, Australia

#7 Nov 16, 2007
LRon wrote:
System? What kind of system?
Try disabling the system so it can't work and then see if the problem is still there.
1. please check the ac belt tension.
2. please adjust the ac idle speed near throt as there is idle adjustment when ac is on (rpm goes up).
3. is your ac compressor working +properly.
a) serviced or not.
thnx
hsdadiala@yahoo.com.au
PGali

Randolph, MA

#8 Jan 14, 2008
Did you recently replace your battery?Because it sounds like you need to clean your throttle body assy.I had a similar situation.The sensor in that assy went back to defaults when power was disrupted and it is very easy to do...I will upload link...

Judged:

190

58

1

Reply »
Report Abuse Judge it!
noidea

Orange, CA

#9 Jan 20, 2008
so if i just put a system in my car and it is doing this the car is going to relearn itself but so far it is taking a while. I am not sure what to do.
Jim

Milford, OH

#10 May 14, 2008
PGali wrote:
Did you recently replace your battery?Because it sounds like you need to clean your throttle body assy.I had a similar situation.The sensor in that assy went back to defaults when power was disrupted and it is very easy to do...I will upload link...
Do you have the link?
Hage

United States

#11 Jun 6, 2008
PGali...Do you have the link that you said you would supply?
Humberto Arenas

Palm Bay, FL

#12 Jun 28, 2008
I have a problem with my car that it shuts off when I make a right turn, there is no problem when I make a left turn, it is only every time I make a right turn. Any advise would be really appreciate it.
Jacobs

United States

#13 Jul 27, 2008
Im at my wifes job waiting outside and i cut on my ac, the car started to make a weird noise then it cut off. I dont know what it may be so i tried it again when i got home and it keeps cutting off. If anyone can help me plz email me @ derrick1982us@yahoo.com
I dont think its the battery cause my car lights and everything cut on perfectly. Does anyone have any answers plz email me. Thank you
Greg

Bradenton, FL

#14 Sep 2, 2008
I seem to be having the same problem with our A/C unit killing the motor when engaged.I just replaced the battery yesterday! HELP!!!!!!
teheran

Jacksonville, FL

#15 Oct 27, 2008
My car made makes this weird noise as well and shuts off when i turn on the a/c or heater. I don't know if it my compressor or not. if anyone can help please email me at marzette10@hotmail.com
steph

San Antonio, TX

#16 Jan 26, 2009
I have a eclipse and every time I turn on AC my car will turn off but if i keep my foot on the gas it will stay on! I don't know what to do they already told me it was not the compressor! i don't know what else to think but the sensors .
I need help please....
joe

Lorain, OH

#17 Apr 26, 2009
my car shuts down after I drive it for about twenty minutes. my gauge says its in the 190 range. it just started doing this after i replaced the starter. its a 1986 pontiac trans am.after it sits over night it will start again. please help
Tammy

Hartsville, SC

#18 May 2, 2009
I also have an Eclipse and the engine dies if rpms drop when ac or defrost are on. Any advice?
steph wrote:
I have a eclipse and every time I turn on AC my car will turn off but if i keep my foot on the gas it will stay on! I don't know what to do they already told me it was not the compressor! i don't know what else to think but the sensors .
I need help please....
Darnell

Towson, MD

#19 May 6, 2009
Fabian wrote:
Hi! I hope somebody can help me with my problem, thanx.
everytime i turn on the a/c when the car is running the engine shuts off. but when im driving i can turn it on but it feels like it takes alot of power from the engine. i have a system on the car and somebody told me that the system is taking too much power from the battery. is this my problem. somebody help plz. its really hot here in florida.
I had the same problem and it took me 1yr to find a good post on the web. The idle air speed is imbedded in your throttle body.. More than likely you did something with your battery whether you changed it or it when dead. long story short, your computer has reset to the current settings and it reading the settings from the dirty throttle body. Make a run to the parts place and get some throttle body cleaner and follow the instructions. It has worked for me and now im riding in air and can idle with the air running without a problem. A 3 dollar fix can save alot of time and money at the dealer. good luck and hope your results were the same as mine.

Judged:

43

20

1

Reply »
Report Abuse Judge it!
Darnell

Towson, MD

#20 May 6, 2009
I forgot to mention my problem was with a 2002 Chevy Trailblazer

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 9
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet TrailBlazer* Discussions

Title Updated Last By Comments
2004 Trailblazer Tue Diana 2
2003 Chevy Trailblazer will not start (Jul '09) Feb 18 Trent 75
2002 TrailBlazer gas tank leak (Aug '06) Feb 18 chevybomb 179
Worst car ever (Oct '06) Feb 16 Shaura Brill 39
Brake pedal sinks to floor after bleeding (Sep '09) Feb 14 JESSICA 6
2005 Trailblazer Brake Lights (Sep '07) Feb 11 Hello 28
engine swap 4.2 2006 (Aug '11) Feb 7 AMZ121881 8
More from around the web