02 Trailblazer Electrical Problems HE...

02 Trailblazer Electrical Problems HELP!!!

First Prev
of 10
Next Last
Robb

AOL

#1 Nov 12, 2007
HI I have an 02 Trailblazer,..I am now having some weird problems and was hoping someone might have some insight to help me on this forum.
Truck was running fine,..I use my truck for work. So I take things out of the back of my Tailgate all day long. Well it started when I opened my tail,..and I looked at the dash and I had lights on and the radio went off? Well when I slammed the tail..the lights went off on the dash and the radio came back on.
So then a day came when it started raing...thats when the all the idiot lights came on in the dash.. The car continued to run and the speedomter worked, but the power windows did not, neither did the gas gauge,oil,battery,air conditoner,power locks and back wiper. or radio. Next day the rain stopped and everything worked fine. Now its only when it rains..I lose power to everything I just mentioned but the headlights and tailights still work.
I had someone put it on a computer to get the codes, the codes go to the tailgate control module. Not the one behind the driver seat..but was told its the one in the tailgate itself.
I then had someone who had access to a Tec 2 ( GM Tool) see if it would come up with anything. They said they found the errors...but the Tool could not communicate with the Tailgate Module??My question here is has anyone had this kind of problem,..and do you think it sounds like the tailgate module is the problem....or is there somewhere else I should check before I spend the money on a brand new tailgate module??The thing that is fishy is that i was told that the body control module ( behind the drivers seat) controls some of those idiot lights,..and the tailgate module controls the others? I had the Tec 2 communicate with the body control module and it couldnt communicate with the rear tailgate...which is why I am so pluzzled? One GM Mechanic told me to put in a new ignition switch as thay have that problem all the time at the dealership..so I did...still have the problem? Anyone??
thanks in advance
-Robb
Rey - Electrical

Englewood, CO

#2 Jan 18, 2008
I have the EXACT same problem. Let me know if you resolved your issue, I know the solution. Took me about 4 months to figure it out!
You can reach me at [email protected]
tommy

AOL

#3 Jan 18, 2008
if anyone could help me it would be nice. I am having a problem that started with my master window control switch, where I couldn't roll down any windows, but the locks, and window lock still worked. now the power that keeps the radio and what not on for a few minutes after you turn the car off doesn't work, it all just dies, i have checked all the fuses, all are fine. now the door locks don't work either from the Driver side, and the mirror control works for the drivers rear view mirror, but I can't do anything with the passenger side. please help, is there a fuse, relay or something I'm missing??
Jeremy Railsback

Warsaw, IN

#4 Jan 31, 2008
I too have a 02 trailblazer.
My problem is that the driver door seems to have no power to it.
But it does.
The mirror, window lock, windows, and dome light do not work from that door.
I took the panel off and found that there is power to one or two wires but I don't know what they are for.
If you have any pointers it would be great.
Thanks
Jeremy
Jeremy Railsback

Warsaw, IN

#5 Jan 31, 2008
I forgot to add that it has been this way for about 4 months now.
It started when my wife was washing it.
It worked on and off for a while but only when it was nice and warm outside.
If the temp dropped below about 55 it quit working again.
Since it's winter I'm guessing not much has changed.
Ren

Andover, MA

#6 Feb 1, 2008
Oh, I forgot to add that when the 05 cut off on me in the middle of the road, I had no power. I was locked inside. Nothing worked. It finally just started/cranked about 5 mins later and all the power accessories started to work again.
Littlejohn

Palatine, IL

#7 Feb 1, 2008
My drivers side head lamp doesn't work. I put a new light in, went to the oil change spot and they put a new one in and it still doesnt work, But my passenger side works fine. Help please. [email protected] American cars vehicles have disappointed me again. Is it time for a change?
Catwalk44

Yorkton, Canada

#8 Feb 9, 2008
Hi,

Just purchased a 2002 Trailblazer and am wondering about a light red flashing light that is located to the right of the radio tuner knob. I am not sure but I don't think the light was flashing when I first got it or maybe I did not notice it. I am thinking this is a security thing but am not sure. I don't know how I got it to start flashing if it wasn't before. Can someone tell me what this flashing light is??????????and if it can be turned off how I do that.

Thanks
robby7

AOL

#9 Feb 17, 2008
OK well I started this thread in Nov. of 07...it has taken me this long to find out what it was. All the symptoms of my problems have now been fixed and my truck is running like new again. I am going to tell you what the fix was but I can't guarentee this will be the answer to everyone electrical problem. OK....Here we go !!
After I had a GM Mechanic look at the truck. They put it on the Tech 2 ( GM Computer Tool)he found out that the trucks back computer the BCM was communication with the other computers in the car so they could not get any error codes from the memory so that they could properily diagnosis the problems. His suggestion...change the ignition switch. Why I asked? Because all the electrical problmes coming were fixed once that was changed. OK so I did that. Nothing fixed. Changed the BCM ( back computer...still not communicating with the other computers in the car nor is letting us getting the error codes from the computer.Changed the leadlight switch,..changed the windshield, pulled all the seats out of the trcuk ripped the carpet out and followed every wire in the whole truck to look for breaks or splits in the wiring. Checked the harness behind the firewall....still nothing.
Getting ready to sell the truck...I opened the hatch..looked into the truck and said let me get a screw driver and popped down the headliner.Looked in with a flashlight,saw a bunch of wires that I guess had something to do with my moonroof.put my hand in and then all of sudden " Booom"...I heard my power door locks go up & down. Which was one of my big problems. I pulled the wires out found the wire that was connected to the door locks...shortened the wire and reconnected it and then ...all my problems were gone. Another reason why I am so unhappy with my Truck this will most likely be the lastGM product I ever buy, becaus eof the lack of knowledge of the GM mechanics,..the GM Schmatics...and just the attitude of the mechanics. I was told by the mechnic that if I left it in the dealer shop...that I better have more money then time to get it fixed. Not what I wanted to hear.
I hope this helps anyone else.
All the Best
-Robby
btidwell

Valdosta, GA

#10 Mar 2, 2008
My 02 Chevy Trailblazer can't remember where the mirrors are supposed to be. When I click the remote on either driver one or two, they revert to either all the way up or down. Also, the radio sound settings (bass/treble) can be changed and it remember them, until I start the vehicle again. Are they related?
bary 1r

Cincinnati, OH

#11 Mar 4, 2008
Littlejohn wrote:
My drivers side head lamp doesn't work. I put a new light in, went to the oil change spot and they put a new one in and it still doesnt work, But my passenger side works fine. Help please. [email protected] American cars vehicles have disappointed me again. Is it time for a change?
each head light has its own fuse actualy 2, 1 for high beam and one for regular (driving) this shuld be in the engine compartment fuse box
Gordy

Milwaukee, WI

#12 Apr 5, 2008
This is for Tommy at AOL. Did you ever get an answer to your problem? I have an 02 also with the exact same problems that you have. I was told to check the circuit breakers in the rear fuse box under the rear passenger seat. Mine were okay but I still had the problem. So if you have received an answer, let me know.
Thanks.
Gordy

Milwaukee, WI

#13 Apr 5, 2008
Catwalk44 wrote:
Hi,
Just purchased a 2002 Trailblazer and am wondering about a light red flashing light that is located to the right of the radio tuner knob. I am not sure but I don't think the light was flashing when I first got it or maybe I did not notice it. I am thinking this is a security thing but am not sure. I don't know how I got it to start flashing if it wasn't before. Can someone tell me what this flashing light is??????????and if it can be turned off how I do that.
Thanks
That flashing red light is the alarm signal. It flashed indicating that the radio is equipped with an anti-theft alarm. It is nothing to worry about. It should flash red when the car is turned off.....
Todd

United States

#14 Apr 10, 2008
I have a 02 trailblazer, all dash lights went out including radio backlights and heater control backlights, took it to GM and they tell me I need a new cluster. there is somekind of control board on the backside of the cluster that is Bad. anyone know if this is true or is there any other way to correct?
Andy

Dunlap, TN

#15 May 17, 2008
I have a 02 trailblazer and none of the door locks with the remote. Changed batteries in both remotes, checked fuses, modules and circuit breakers and the locks still don't work. Any ideas? I like the truck and this is the only problem iI have had except I did have to replace the fan clutch at 85.000 miles. It has 88.0000 miles on it now. From reading this forum and infomation from other owners I probably won't be buying another GM vechicle. Any help would be appreciated.
jon pa

Reading, PA

#16 Jul 10, 2008
you may need to reprogram the remote you can get teh code online it has to do with your vehicle recognizing the remote yo u will have to reprogram all remotes you have at the same time.

Andy wrote:
I have a 02 trailblazer and none of the door locks with the remote. Changed batteries in both remotes, checked fuses, modules and circuit breakers and the locks still don't work. Any ideas? I like the truck and this is the only problem iI have had except I did have to replace the fan clutch at 85.000 miles. It has 88.0000 miles on it now. From reading this forum and infomation from other owners I probably won't be buying another GM vechicle. Any help would be appreciated.
Baldy

Scottsdale, AZ

#17 Jul 22, 2008
Jeremy,
Did you ever resolve? I have the 2002. Passenger lock, window, and mirror w/n/work, on my 4th battery, no brake lights.
Shell

United States

#18 Jul 28, 2008
I have a 2002 Trailblazer LS The speakers jut starting acting up. They fade in and out. Somtimes the music seems so far asway. After awhile they are fine.

Air/Heater lights on dash to control passenger temp has gone out too. When speakers are not working the low gas chime and door chimes don't work. Got any ideas?
JTW

United States

#19 Aug 12, 2008
my brake lights aren't working. I've replaced the bulbs and fuses, but still nothing. Anyone have any advice?
Jonathan

Ocala, FL

#20 Sep 14, 2008
My '02 Trailblazer, at random times, has all of the dash electronics, gauges, and the AC cut on and off while running. The dealer replaced the BCM for $500 and now it is doing the same thing again. After the BCM was replaced, I got a code saying the fan clutch needed was bad, so I replaced the fan clutch, now the dealer wants to unplug a random modules to see which (of 14) it might be...Any thoughts-I'm thinking some kind of ground issue, but not sure how to proceed.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 10
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet TrailBlazer Discussions

Title Updated Last By Comments
05 trailblazer won't move 8 hr Help 1
Transmission in my '03 Trailblazer dead (Sep '06) 12 hr Kenny 88
P1345 error code, very rough idling (Sep '06) Sat kpkonar1 86
2004 Trailblazer grinding/growling noise when a... (Feb '12) Apr 27 B_M_O 26
2006 Trailblazer won't start (Apr '07) Apr 24 Jkwan 175
2003 trailblazer key is stuck in ignition (Jan '08) Apr 24 Terrymc 55
Clicking/Ticking under Idle only. (Jan '07) Apr 23 MSexy 63
More from around the web