Humming Noise In 2003 Trailblazer LT
roberto

United States

#41 Sep 15, 2010
Vic wrote:
Have an 2003 TB W/ 108K milesd had noise in front of eng, changed w/pump, idler pulley, and tensioner assy, still had noise, changed fan clutch now quiet...Had front wheel noise, changed r/front w/bng now quiet again !!!
how much was the fan clutch
roberto

United States

#42 Sep 15, 2010
how much was the fan clutch
vic

Avon, OH

#43 Sep 17, 2010
Bought it on e-bay for around $70 OEM in box Vic
Dale

Amarillo, TX

#44 Oct 13, 2010
My 2006 trail blazer has the same humming sound. It started around 23,000 miles. It now has 36,000 and is still doing it. I will get it fixed if I ever get a little extra money.
phil

United States

#45 Oct 24, 2010
My 07 trailblazer is making a humming noise idk what it is my friend said it could be ac compressor another said idler pulley is this expensive to fix at ur local mechanic?? Help me out plz
vic

Lorain, OH

#46 Oct 25, 2010
Remove your accessory drive belt , and run the eng if the noise is not there it is something your belt drives, spin the pulleys independently and feel if any of them has a bad bearing, same for your alternator and waterpump !
Aaron

Lawrenceville, GA

#47 Apr 21, 2011
My 2006 Trailblazer LS is making a "Propeller" type of sound when I am driving over 25MPH. The faster I go, the louder it gets and it feels like a vibration. It is not tied to the RPM's as I can put it in neutral and rev the engine while stopped and hear zero propeller noise.

Any Ideas would be greatly appreciated on what it may be or how to check it. Since it only makes the noise above 25 MPH, it makes it difficult to diagnose in the garage.

Sound comes from the front of the truck.
vic

Lorain, OH

#48 Apr 22, 2011
Tom wrote:
We have a 2003 Trailblazer LT, with the 4.1L engine. It has 157,000 miles, and we have had no problems. Recently,we've had some really cold weather, and I've noticed a humming sound that wasn't there before.
The noise increases and decreases with the engine RPM's. It does it all the time, not just when the engine is cold. It's coming from the front of the engine compartment, so I'm thinking maybe alternator? I thought they usually made a squeak or a squeal when they are going out. Could it be the serpentine belt?
Other than this, we have had no problems with the car! Any help would be greatly appreciated!
I think you wil find the fan clutch needing replacement, When I did that I also changed the related idler bearings as they have rolled quite a few miles also and will eventually fail anyhow ! Vic
Randy

Americus, KS

#49 Apr 29, 2011
Have replaced both the alternator and waterpump on my 2005 and the growl continues. Will try the idler bearing first, but tend to side with Vic that most likely it's the fan clutch. They typically are the cause for waterpump bearing failure which was what happened on mine. Glad to know it wasn't internal on the motor, ran the motor briefly without the belt on and the noise was gone.
tom

Dearborn Heights, MI

#50 May 17, 2011
degonz02 wrote:
I have a loud whining noise on my 02 TB also. Changed the pulley but didn't work. Suspect bad A/C compressor clutch. With a/c off and clutch not moving the noise is very loud. With a/c on the noise almost disappears at idle, but gets loud when accelerating. Anyone else experienced this.
i have the same problem was going to change ac pump will this work
vic

Lorain, OH

#51 May 17, 2011
It does sound like the bearing in the clutch part of your compressor is going out. Only the bearing will need changed, but most dealers require changing of the clutch & bearing assembly ! No need to change the whole compressor ! Vic
Wisdom

Saint Louis, MO

#52 Jun 18, 2011
i have a 1997 Delta 88 and it is doing the same thing as have a loud whining noise Suspect bad A/C compressor clutch. With a/c off and clutch not moving the noise is very loud. With a/c on the noise almost disappears at idle, but gets loud when accelerating. Anyone else experienced
snw

Page, ND

#53 Jun 22, 2011
I have 2008 TB and it is definetely the AC Compressor. Is it ok to continue driving it without fixing?
Mongo

Rio Rancho, NM

#54 Jun 28, 2011
Pay very close attention to your water pump it sounds like alot of these previous post are about a humming or whinning noise. with your TB shut off try to wiggle your fan and look at the pulley while you do this. if your pulley wiggles at all replace your water pump asap!! the wiggling indicates that you water pump bearing is about to fail.
perry

Jacksonville, FL

#55 Jun 29, 2011
my 2003 trailblazer makes a raddling and sound like a tapping noise while the engine is running
GERTY-83

Garnavillo, IA

#56 Nov 17, 2011
I have an 03 TB and it sounds like a jet taking off when I take of from a complete stop. It hogs alot of power. I think it is the fan clutch is there anyone who has experienced this with there TB or anyone who may know what the problem is. Could it be a sensor that is tell the fan to run or is it the fan clutch itself.
Crystal Jansky

Chicago, IL

#57 Nov 19, 2011
I have a 2005 Trailblazer, makes loud whining noise only when driving, the faster you go the louder it gets. I read up on it on the internet, and we replaced the Idler Pully & Serpintine Belt. WOW it's so QUIET you cant even tell it's running :) Im so happy !! Thank you all for this awsome info !!
mike

United States

#58 Nov 20, 2011
2007 trailblazer, many many problems with this vehicle. Whining noise now starting, checked under hood and idler pulley seems to have some play. This has been the worse vehicle I have ever owned, nothing but problems. I could have probably paid this vehicle off with all the money I've spent on repairs, leaky transmission lines, leak in roof rear, breaks, rotors twice, failed gas guage, numerous engine adjustments at dealer, and now hopefully just idler pulley. I have been a GM fan all my life, but now I will never buy GM again. Toyota here I come, lol.
Benn21

Knoxville, TN

#59 Jul 20, 2013
My wife's '03 trailblazer is quiet until you put it in gear and start to go, then the loud whine from the engine, the transmission seems to lag a bit, it sounds like some of these other problems, but not sure. With today's computer chips and what not its hard to make an honest motor crank anymore...
Taveon

Jersey City, NJ

#60 Aug 7, 2013
Aaron wrote:
My 2006 Trailblazer LS is making a "Propeller" type of sound when I am driving over 25MPH. The faster I go, the louder it gets and it feels like a vibration. It is not tied to the RPM's as I can put it in neutral and rev the engine while stopped and hear zero propeller noise.
Any Ideas would be greatly appreciated on what it may be or how to check it. Since it only makes the noise above 25 MPH, it makes it difficult to diagnose in the garage.
Sound comes from the front of the truck.
Mines is doing the same did you ever fix the problem?

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet TrailBlazer* Discussions

Title Updated Last By Comments
Gets power but wont crank (Dec '13) 21 hr Donna 4
4l60e issues Oct 15 Matt sparks 1
2002 Chevy TrailBlazer LS no crank & check gage... Oct 13 Stephanie1293 1
02 Trailblazer Electrical Problems HELP!!! (Nov '07) Oct 13 Gun 202
Fuel Gauge Malfunction (Jul '08) Oct 13 Gun 215
2003 Trailblazer dash lights all go on when I s... (Apr '08) Oct 11 Lyndalee Alverson 22
Trailblazer - Reducted Engine Power (Aug '06) Oct 8 Goodgas 62
More from around the web