2003 Trailblazer LT - Fan Clutch

Posted in the Chevrolet TrailBlazer Forum

Comments

Showing posts 1 - 20 of22
< prev page
|
Go to last page| Jump to page:
Renee

La Habra, CA

|
Report Abuse
|
Judge it!
|
#1
Apr 23, 2008
 
I just recently had my vehicle in to the dealer and they replaced the thermostat, fan clutch and water pump (61K miles on the vehicle). The next morning when I started up the vehicle it sounded like a jet engine....it didn't stop until about 5 mins after driving. The dealer says that is normal as they just replaced the fan clutch...Is that sound normal?
paul

United States

|
Report Abuse
|
Judge it!
|
#2
May 7, 2008
 
my coworker today said his trailblazer was roaring. he had me look at it, sounded like the clutch fan wasn't disengaging. the truck is louder than it was.
he said it felt slugish too.
is the clutch fan a common proble.
Ryan

Villa Park, IL

|
Report Abuse
|
Judge it!
|
#3
Sep 3, 2008
 
it is normal for the fan to run loud after being replaced for awhile untill the oil in the clutch is dispersed evenly.
will

Houston, TX

|
Report Abuse
|
Judge it!
|
#4
Mar 31, 2009
 
I have a 2003 tb ext lt i recently crash my front end i repaired my truck myself but when i replaced the fan clutch, i connected the fan with wire from harness but their is another smaller connection attached to that wire and i do not know were it goes connected to. so it makes my check engine light come on therefore i can not pass inspection. can anybody help please?..
Anessa

United States

|
Report Abuse
|
Judge it!
|
#5
Aug 18, 2009
 
I have an 03 LTZ that once in a while sounds like a 747 landing and my drieway and the clutch fan also ticks all the time. The dealership says it's fine, sure is really annoying!
jerry astoria NY

Astoria, NY

|
Report Abuse
|
Judge it!
|
#6
Dec 9, 2009
 
Anessa wrote:
I have an 03 LTZ that once in a while sounds like a 747 landing and my drieway and the clutch fan also ticks all the time. The dealership says it's fine, sure is really annoying!
my trailblazer ticks only when i start it in the morning for about 2 minutes and than it stops as soon as the car gets worm. I don't think it is normal to be ticking all the time. I belive that the sound of a landing 747 and the ticking noise are a result of a bed clutch fan. hope this helps
vic

Avon, OH

|
Report Abuse
|
Judge it!
|
#7
Dec 9, 2009
 
will wrote:
I have a 2003 tb ext lt i recently crash my front end i repaired my truck myself but when i replaced the fan clutch, i connected the fan with wire from harness but their is another smaller connection attached to that wire and i do not know were it goes connected to. so it makes my check engine light come on therefore i can not pass inspection. can anybody help please?..
I'm not sure what wires you hooked up, I believe the harness feeds back to the engine computer to tell it the speed of the fan, and then electronicaly adjust as necessary, without all the wires connected the computer recognizes a problem and is letting you know through the check eng light
vic

Avon, OH

|
Report Abuse
|
Judge it!
|
#8
Dec 9, 2009
 

Judged:

1

Renee wrote:
I just recently had my vehicle in to the dealer and they replaced the thermostat, fan clutch and water pump (61K miles on the vehicle). The next morning when I started up the vehicle it sounded like a jet engine....it didn't stop until about 5 mins after driving. The dealer says that is normal as they just replaced the fan clutch...Is that sound normal?
Yes bear with it, eventually it will adjust and operate as your original clutch fan did !!!
Susan

Pompano Beach, FL

|
Report Abuse
|
Judge it!
|
#9
Jan 18, 2010
 
How long do I have to wait for my 2003 TB to "eventually" fix itself? My fan clutch was replaced close to a year ago, and I don't have the 747 noise all the time anymore - only for the first few minutes, until the car warms up. I don't drive it until the noise quiets down, and the tach shows a lower reading.

And is this related to the crappy gas milage I'm getting? It used get about 18 mpg around town, and now gets on average 10-12.
edward

Encino, CA

|
Report Abuse
|
Judge it!
|
#10
Jun 29, 2011
 
I have the same jet noise and it doesn't stop until I have driven for a mile. Mine started after I had my water pump changed. And its the fan. A friend of mine is going to check out my fan and see if it was properly bolted back in place. It seems that there is a special tool for that and most mechanics don't want to buy it for a one time job
GERTY-83

Garnavillo, IA

|
Report Abuse
|
Judge it!
|
#11
Nov 17, 2011
 
I have the same problem with my 03 TB sounds like a jet, is it ok to drive it like that and is it the fan clutch not disengaging.
Susan

Pompano Beach, FL

|
Report Abuse
|
Judge it!
|
#12
Nov 21, 2011
 
My clutch fan was replaced more than three years ago, and I still have the racing and roaring. I guess GM thinks it's "normal," because it seems to be the "norm." Normal doesn't always equate with right!!

Worse than the fan clutch is the instrument cluster problem, another common fault that GM won't admit to for a recall. My car shows anywhere from 0 mph in park to 95 mph. When on the highway, the speedometer currenty goes all the way around to just below zero. And tomorrow it may be back where it belongs.

All the gauges are jacked up, and I have to use my trip odometer to be sure when I need to buy gas. I sure can't rely on the gas gauge, although it's the one gauge that is usually where it belongs.
Bennett

Butler, GA

|
Report Abuse
|
Judge it!
|
#13
Jan 14, 2012
 
Can the electronic fan clutch be replaced with a regular heat sensor style with out messing up the computer? If so, what to do with the wires?
Jess

Winchester, VA

|
Report Abuse
|
Judge it!
|
#14
Mar 15, 2012
 
My 2004 LT started the whole jet plain noise driving back from a really long trip. Took it to a mechanic. He stated that the fan was wobbling (pretty severe too) and that the water pump went bad along with the serpentine belt. Also, stated that the 'jet noise' was from the fan clutch stuck on full throttle. I've also noticed slugish response since the noise. Too bad cars don't build equity like a house.
Mlj

Westminster, MD

|
Report Abuse
|
Judge it!
|
#15
Oct 24, 2012
 
Hi
I just replace my fan clutch 2day ago and drove it last night for the first time
When I turn it on it is loud like an airplane is it ok to drive ???????
I just am not use to the loud noise but the check engine went off and the heat works now .
2003TBLTZ

Miami, FL

|
Report Abuse
|
Judge it!
|
#16
Jul 29, 2013
 
This is a common problem... I am on my third fan clutch in 5 years... roaring sound... ticking from the dashboard... ignition that sometimes refuses to work... and now wipers that don't go on in the rain. A new battery (every year) solves some problems... but basically there is an electrical drain somewhere in the fan clutch that screws up instrumentation and tricks the computer into showing no codes
2003 TB CFL

Longwood, FL

|
Report Abuse
|
Judge it!
|
#17
Aug 24, 2013
 
I am having my fan run somewhat loud, but do not get a check engine light. I can read for codes and get the 1482 which indicates incorrect voltage at cooling fan circuit. It appears I have not had the issues most have had so early, my TB has 185K miles. Have not replaced fan clutch or water pump as I see so common. Anyone know how to really determine if the fan clutch is bad or if it is a wiring issue.
davenyc

Bronx, NY

|
Report Abuse
|
Judge it!
|
#18
Nov 27, 2013
 
will wrote:
I have a 2003 tb ext lt i recently crash my front end i repaired my truck myself but when i replaced the fan clutch, i connected the fan with wire from harness but their is another smaller connection attached to that wire and i do not know were it goes connected to. so it makes my check engine light come on therefore i can not pass inspection. can anybody help please?..
can u get a look at some1 blazer 2 c were it goes
davenyc

Bronx, NY

|
Report Abuse
|
Judge it!
|
#19
Nov 27, 2013
 
try to get a look at aunthor tbto see wat went wrong with your setup
davenyc

Bronx, NY

|
Report Abuse
|
Judge it!
|
#20
Nov 27, 2013
 
2003 TB CFL wrote:
I am having my fan run somewhat loud, but do not get a check engine light. I can read for codes and get the 1482 which indicates incorrect voltage at cooling fan circuit. It appears I have not had the issues most have had so early, my TB has 185K miles. Have not replaced fan clutch or water pump as I see so common. Anyone know how to really determine if the fan clutch is bad or if it is a wiring issue.
to see if clutch needs to be replacec spin your fan normal push if it goesto lighty mite be time to change i wud buy americanparts tobe safe

Tell me when this thread is updated: (Registration is not required)

Add to my Tracker Send me an email

Showing posts 1 - 20 of22
< prev page
|
Go to last page| Jump to page:
Type in your comments below
Name
(appears on your post)
Comments
Characters left: 4000
Type the numbers you see in the image on the right:

Please note by clicking on "Post Comment" you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

8 Users are viewing the Chevrolet TrailBlazer Forum right now

Search the Chevrolet TrailBlazer Forum:
Topic Updated Last By Comments
trailblazer just shutting off on me (Jun '07) Apr 15 AID12 48
2003 Chevy Trailblazer instrument panel malfunc... (Dec '07) Apr 14 Shaysa 68
2007 Trailblazer Transmission Problem (Feb '10) Apr 10 gary 35
Swapping badges on holden Colorado 7 to chev ba... Apr 9 Craig rains 1
Car shuts off when A/C on (Jul '07) Apr 7 Twin81 92
2006 Chevy Trailblazer Apr 5 Jim 1
Transmission in my '03 Trailblazer dead (Sep '06) Apr 4 Michelle 79
•••

Buy a New Car


Zipcode:
•••
•••
•••