2004 trailblazer front end noise

2004 trailblazer front end noise

First Prev
of 4
Next Last
Ed s

Cabot, VT

#1 Aug 1, 2008
I have a noise in the front end that sounds like an
out of ballance tire (growing). Checked tires for inflation and wheel weights and all seem fine. I then checked the wheel bearings and the left front had some movement. I replaced the hub and bearing and still have the noise. It increases with speed and at 51 mph it has a tinney sound to it. If I turn to the right the sound slows or stops. Turning to the left there is no change. If I engage the 4 wheel drive there is no change. Anyone have an idea what this is?
Chris

United States

#2 Nov 24, 2008
Exact same problem with my 03. New wheel bearings both sides. New rotors and brakes all the way around. Dealer replaced sway bar links. 6500 miles on firestone destination LE's rotated. My next guess is front differential output shaft bearings or inner cv joints getting worn. Anyone with info let us know. The sad part is only 67000 miles.
pete

AOL

#3 Dec 9, 2008
`04 having the same problem.. has anyone found out what the problem was
mike

United States

#4 Jan 10, 2009
pete wrote:
`04 having the same problem.. has anyone found out what the problem was
has any one had theirs fixed if so what was it
mark in ohio

Erie, PA

#5 Jan 10, 2009
same problem with mine just found out the 4 wheel drive isnt workn can anyone help
mark in ohio

Erie, PA

#6 Jan 10, 2009
same problem 04 makin noise 4 wheel drive not workin can anyone help
Patty

Youngstown, OH

#7 Jan 21, 2009
I had some kind of link replaced on mine, Had to do with the wheel bearing. Its was about 40 bucks each. My noise went away
Trailering

Charlottetown, Canada

#8 Feb 3, 2009
Axle Ratio - How do I find what mine is?
I am looking for the axle ratio for my 2003 Trailblazer EXT. Any ideas how I can access this information?
Gary

Hays, KS

#9 Feb 13, 2009
I have a 03 trailblazer and I am having the growing noise from the front end. When I turn right the noise goes almost away but when I turn left it gets louder. I had it align and they did not find anything wrong with it. I put new tires on it and still have the noise. The wheel bearing fell good still. Has anyone have had any luck finding a fix for this problem? Thanks Gary
Robert N Overton

South Bend, IN

#10 Feb 28, 2009
2003 Trailblazer, 33,300 miles. All brakes and rotors need replaced. Sway bar links all need replaced. 4 wheel drive comupter needs replaced. Front diff leaks needs repair and mybed bearings.
Dealer told me this is normal for the brakes and sway bar link. I bought this new. I take good care of my trucks. Gmc rep says so what more or less anyway. They don't care. I also have has to replace the rubber around the rear plate, left tail light, molding on driver left side where controls are at. Strunt on rear lift window. Scared to keep it...
04 Chev TB 4X4 owner

Etna Green, IN

#11 Mar 5, 2009
I purchased my 2004 Chevrolet TrailBlazer LS 4X4 new in December 2003 for my company car and now have 110,000 miles on it. I also had a growling noise in the front and the local Chevrolet dealer had to replace the front carrier assembly and left front hub. The dealer said the left front bearing was in three pieces when they took it apart. I had to spend just over $3000 to get it fixed and that was with a Jasper rebuilt front carrier assembly with a 3yr/100k warranty and a factory GM left front hub. I just picked it up yesterday and it was an expensive repair, but it has been a great vehicle especially in the snow. Good luck!
frank in kentville

Charlottetown, Canada

#12 Apr 2, 2009
mark in ohio wrote:
same problem with mine just found out the 4 wheel drive isnt workn can anyone help
i also have a 2005 and the 4x4 doesen,t work, can anyone help
frank in kentville

Charlottetown, Canada

#13 Apr 2, 2009
I have a 2005 and the 4x4 doesen,t work , can anyone help
Gary

Hays, KS

#14 Apr 28, 2009
I replace the right side wheel hub assy. and that fixed the noise problem. The bearing was just dry.
allen g

Pittsburgh, PA

#15 Jul 24, 2009
Gary wrote:
I have a 03 trailblazer and I am having the growing noise from the front end. When I turn right the noise goes almost away but when I turn left it gets louder. I had it align and they did not find anything wrong with it. I put new tires on it and still have the noise. The wheel bearing fell good still. Has anyone have had any luck finding a fix for this problem? Thanks Gary
"when turning left it is generally the right front bearing"
allen g

Pittsburgh, PA

#16 Jul 24, 2009
when turning left it is generaly the right front bearing
DC Mix

Berlin, MD

#17 Jul 25, 2009
2005 TB, same problem with the noise/vibration as previous post. Bearing, CV joints evetything checking out ok. Have limited it to the Front differential. Also found out my 4x4 isn't working either when i had it on a lift.
40K on Vehicle
Mike

Saint Louis, MO

#18 Sep 6, 2009
2003 trailblazer with front end noise like a tire is out of round. Changed tires same problem. Little vibration. With number of problems sounds like maybe a recall is in order.
Jerry

Albertson, NC

#19 Sep 28, 2009
My wife's 03 trailblazer is in the shop right now. She had a growling noise, bang and then cluck...her description. I had it towed in. Dealer said the front differential bearings siezed and the gears exploded leaving a hole in the diff case. My extended warrenty adjuster wants my service records. I have the oil changed every 3,000 and they are "suppose" to be checking the fluids. My advice is have your front diffs servicedd and keep the documents for future use. I've found one site were folks report similar occurances.

For you without 4WD, there is an electronic actuator associated with the 4WD selector switch. Check that. My developed some sort of short and would display flashing lights between the different wheel drives. I also had a nasty growl in the front end on decel from high way speeds. Not quite a grinding but sounded like the front end was about to fall out. Keeping gas applied would make it stop. Hope this helps.
jeanne buffalo ny

Niagara Falls, NY

#20 Jan 2, 2010
i am having the same problem with my 04 trialblazer with the 4wd i also replaced a wheel bearing but yet again when turning the wheel to the right the noise and vibration wld go away and come back when i straighen the wheel out and get worse as i turn to the left. it almost resembles a deep siren sound coming from the passenger front end, also when i apply the breaks it almost feels like i am going over a bump like they skip coming from the rear, as well as the spedometer acting real wacky i cld be going 10mph and will surpass 120 and get stuck there as well.... what to do???? i am sure the more i try and figure it out its only going to get more expensive.. having 5 kids in the house who can afford it... thanks

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 4
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet TrailBlazer Discussions

Title Updated Last By Comments
05 trailblazer shifter moves, car wont (Apr '13) 12 hr Vajmathis 15
Fan Clutch Problems, again .. (Mar '11) Jul 19 Dave Ramsey 6
Car shuts off when A/C on (Jul '07) Jul 16 Gerry 142
P1345 error code, very rough idling (Sep '06) Jul 15 Nellie 87
Loss of oil pressure at idle (Oct '09) Jul 11 Kim 121
o3 trailblazer Jul 10 raymbrain 1
stalls until up to running temperature Jul 6 VED 1
More from around the web