2003 Chev Trailblazer
JECTOR

Chicago, IL

#41 Jun 29, 2007
Does any know which is the procedure to calibrate or relearn the computer on a 2003 Trail blazer 4.2 engide after we change the battery, because i been having problems with my a/c after I changed it, the rpm goes down and has very tough iddle.
Angel

Raleigh, NC

#42 Jul 1, 2007
I have a 2003 trailblazer and the cruise control stop working. Can't find any blown fuse or anything. Does anyone know anything about the cruise control?
Dawn

Portage, MI

#43 Jul 2, 2007
I have a 2003 trailblazer. The other day while driving down the highway, the piece that sits above my rear window broke off and smashed. I still have the upper brake light, but the plastic piece was a goner, does anyone know the name of that piece or where I can get it. Thanks.
Jack

Virginia Beach, VA

#44 Jul 6, 2007
I have a 2003 trailblazer ext my a/c works when it feels like it. The fan blows at every setting, but no cold air is entering the vehicle. My a/c system is charged. To me it seems like the a/c clutch is not engaging. I have had this problem since 2003, have asked the dealer about a possible recall. The have said that the system is fine. Has anyone had this same problem? Any solutions?
RonH

Oklahoma City, OK

#45 Jul 6, 2007
Jack wrote:
I have a 2003 trailblazer ext my a/c works when it feels like it. The fan blows at every setting, but no cold air is entering the vehicle. My a/c system is charged. To me it seems like the a/c clutch is not engaging. I have had this problem since 2003, have asked the dealer about a possible recall. The have said that the system is fine. Has anyone had this same problem? Any solutions?
Wait, are you saying that since it was new you have never had a/c and the dealer says this is normal? That does not make sense.
milers84us

United States

#46 Jul 8, 2007
the 5th speed on my fan motor for air condition stop working on my 2003 trail blazer
does any body knows how to get to it to replace it.

Since: Jul 07

Choctaw, OK

#47 Jul 8, 2007
It's probably the resistor. Remove the panel under your glove box door. The resistor module is behind the panel. It's rectangular and has a screw at each end holding it in place.
ryan

Los Angeles, CA

#48 Jul 9, 2007
JECTOR wrote:
Does any know which is the procedure to calibrate or relearn the computer on a 2003 Trail blazer 4.2 engide after we change the battery, because i been having problems with my a/c after I changed it, the rpm goes down and has very tough iddle.
I have the same problem, please post if you know the fix! Thank you!
Jennifer

Tallulah, LA

#49 Jul 10, 2007
I have an 05 Trailblazer and I noticed the other day that my left rear speaker wasn't working anymore. I know that it isn't busted because there is no type of noise coming from it. I need to know if anyone else is having this same type of problem and what I need to do to fix it. Also.......... the lumbar control on my driver's side is messed up. Everytime I try to use it, it makes a terrible noise and will not work. Any suggestions on what to do with this? Anyone having problems with the seat panels (driver's and passenger's) breaking off? Cheaply made is what I would call them!
Dawn

Portage, MI

#50 Jul 10, 2007
I have been having issues with my a/c as well from time to time. Some days the cold air will work great and others it will only work on settings 1,2 and 3. 4 and 5 will only blow out luke warm air.
Leo FL

Melbourne, FL

#51 Jul 12, 2007
Claude wrote:
I am having a problem since I disconnected the battery. SInce then My AC won't work and when it is turned on, the RPM's begin to surge. The solenoid on the AC won't turn. Any ideas??
I just changed my Batteryover the weekend and i am having the same problem. my a/c works but only blowing out of the feet vents. Dealer said that it might be acutator and that it will be 4 hours labor plus $250 for the part ouch! i am going to try the idea with resetting the bat for 5 mins hope it works
Dan

Phoenix, AZ

#52 Jul 13, 2007
I also had the "change the battery and a/c won't blow" Had bad actuator under dash. How would you change the battery without screwing up this car-very frustrating. Also, temp heats up to about 225-235 durring the summer (Arizona) It's an 2003 LT and is supposed to have to newer fan clutch and latest software.
Very confusing. If I didn't like this car so much I'd take it out to the desert and shoot it.
Jon

Englewood, CO

#53 Jul 15, 2007
Ok I got a 2003 Trailblazer Ext... It makes a clicking noise from the right rear panel... Does any1 know what is in that panel because the chilton's book doesnt say anything please contact me at

email [email protected]
please title it Trailblazer

Thanks a bunch
Dave

Laredo, TX

#54 Jul 17, 2007
Don't know the full procedure but part is the same as my older truck. You turn the key to "on" without starting the engine and depress the gas pedal all the way to the floor and fully release several times. The PCM is looking for the min and max TPS values that it will assign 0% and 100% in the software.

At least twice a year, I pull the ecm fuse to dump the memory, and perform this procedure. It runs much better when the old data is gone, adjusting to seasonal gasoline blends and warmer/cooler weather.

Newer models store some of the data in EE2 memory I believe and that can only be cleared using a scan tool. So you would not have lost that during a battery swap.

Have heard stories of people plugging a 9V battery with adapter into the cig lighter to stop data loss, but don't know how efective that is.
Alex

Fredericksburg, VA

#55 Jul 17, 2007
anyone have instructions on how to replace a battery on a 2003 trailblazer ext? preferably with pictures since my girlfriend is doing it and I need to walk her through it, I'm out of state right now.
Thanks
Barbara

Columbus, OH

#56 Jul 18, 2007
I have the 2003 Trail Blazer and replaced the battery recently, the temperature stopped displaying but the compass does work. I tried resetting the temp per manual but stays in Celcious(sp) anyone know how to fix.
Melissa

Columbia, MD

#57 Jul 19, 2007
I have an 03 Trailblazer and have had a month from hell with it! SES light went on twice. Took to dealer on 6/22. Said it was the transmission control module switch. Replaced it. Dealer said there was excessive metal in transmission. Took car home on 6/26 and pulled into the grarage, turned car off for 1/2 hour and then turned back on and SES light back on. Returned to dealer. While at the dealer, technician backed into my Trailblazer with $80,000 corvette. Dealer replaced both front and rear bumpers at no charge. Still can't figure out why SES light on. Picked car up on 7/5 and SES light turned back on upon returning home. Returned car back to dealer on 7/9. Talked with service person yesterday, replaced transmission control switch again and engine harness. They have taken it for multiple test drives and still cannot get the SES light to go off. Car seems to run fine even though SES light is on! And yes I checked the gas cap!!

Any suggestions? I am totally frustrated and have called and complained to GM twice!
Polly

AOL

#58 Jul 20, 2007
just bought a 2006 chevy trailblazer, owners manual not in yet, cant figure out how to set the clock that I um accidentally unset..hehe. Can anyone help? there is nothing marked on the controls that say clock, so am at a loss.
thanks!
Dave

Laredo, TX

#59 Jul 22, 2007
Melissa: The computer will tell the technician exactly the SES light is on by a numeric code. They aren't telling you the full story apparrently, or they are just idiots.

There is a known problem with cracking of the fuel tank neck that ought to throw the same code as a loose gas cap. If that's the code, the tank should be checked. It cracks above the fuel level, so you smell it but don't get a leak.
Jay

Carrollton, TX

#60 Jul 23, 2007
Have you found a fix for your ac problem? Am taking my sister's car in for same thing. They got a new starter, now the air only comes out of feet vents.
Leo FL wrote:
<quoted text>
I just changed my Batteryover the weekend and i am having the same problem. my a/c works but only blowing out of the feet vents. Dealer said that it might be acutator and that it will be 4 hours labor plus $250 for the part ouch! i am going to try the idea with resetting the bat for 5 mins hope it works

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet TrailBlazer* Discussions

Title Updated Last By Comments
2005 Trailblazer - rear speakers stopped working (Jun '08) 17 hr john g 58
2003 Chevy Trailblazer will not start (Jul '09) Sat Jennylynn87 66
Gets power but wont crank (Dec '13) Oct 18 Donna 4
4l60e issues Oct 15 Matt sparks 1
2002 Chevy TrailBlazer LS no crank & check gage... Oct 13 Stephanie1293 1
02 Trailblazer Electrical Problems HELP!!! (Nov '07) Oct 13 Gun 202
Fuel Gauge Malfunction (Jul '08) Oct 13 Gun 215
More from around the web