2006 Trailblazer won't start
First Prev
of 10
Next Last
Glen

Herndon, VA

#1 Apr 22, 2007
For the second time on 6 weeks my 2006 Trailblazer will not start. Worked fine last time I used it (yesterday afternoon)and now it will not start.
Has anyone else had this problem? If so what was the cause and cure?
keith

Canada

#2 Jul 14, 2007
same thing happend to me, throttle body, $600 later

Since: Jul 07

Choctaw, OK

#3 Jul 15, 2007
How bout some more info? What are the symptoms? Is is just dead, or does it crank and not start? Does it try to start? What have you tried so far?
Trailblazer freek prob

Bronx, NY

#4 Aug 16, 2007
Fautly ignition switch.
I've had 2 of them already . 2005. LT
DavidBuffalo NY

Bronx, NY

#5 Aug 20, 2007
TBlazer will crank, but won't start. After having it towed, it starts fine at the garage. 38k miles, out of warranty so it will not easy to fix... I drove it home, now it won't start again. Anyone having the same problem find a solution?

Since: Jul 07

Choctaw, OK

#6 Aug 21, 2007
Start with the basics. In order to run, your engine must have air, fire, fuel. For starters and before you start throwing parts at it, find out which one is not happening.
Aly

Houtzdale, PA

#7 Aug 24, 2007
I am having the same problems with my '06. I turn it over and it won't start, turn it back and try again and it starts right up. Only problem is now when it does start the check engine light is on.
TRES FROM GA

Augusta, GA

#8 Aug 24, 2007
i have somewhat the same issue. i have a 06 trailblazer ls and when i turn the ignition on all the power options come on but when i turn the key to the next step to start it it will not turn over. mine is out of warranty 80,000 miles in a year. i have replaced the ignition switch 2 times. i thought this was the issue but no. i ran the ignition switch power wires all the way up to the fuse box under the hood and found that the relays for the starter is not engauging. even if i bypass the relay it still wont start because the ignition is not getting any power. i am still in the process now to find the issue. if anyone has any details please let me know or if i find out what it is i will write again. ps: i forgot to write that i thought it was the security system at first then i shut the system down and it still did not work. if you would like to bypass your alarm to see if that is your issue all you have to do is pull the power window switch from the driver side door and ground out the light green wire that goes to the switch.
Pauline

Goderich, Canada

#9 Aug 26, 2007
I have a 2005 t.b. that is whining. The rpm's are
revving. Took it to the dealer, said it's normal. It wasn't doing this before. Told me it could be the alternator, but even if he changed it, being as they are rebuilt. I probably wouldn't see any difference. He looked it over, took it for a test run, charged me $54.00
It whines as soon as you start it up.Can anyone help?
Robbie R

Stamford, CT

#10 Aug 27, 2007
Pauline wrote:
I have a 2005 t.b. that is whining. The rpm's are
revving. Took it to the dealer, said it's normal. It wasn't doing this before. Told me it could be the alternator, but even if he changed it, being as they are rebuilt. I probably wouldn't see any difference. He looked it over, took it for a test run, charged me $54.00
It whines as soon as you start it up.Can anyone help?
Try replacing the belt tensioner - mine did the same thing. Quiet as clam now.
Robbie R

Stamford, CT

#11 Aug 27, 2007
My 2004 did the same thing - replaced the belt tensioner. Quiet as a clam now.
Robbie R

Stamford, CT

#12 Aug 27, 2007
Pauline wrote:
I have a 2005 t.b. that is whining. The rpm's are
revving. Took it to the dealer, said it's normal. It wasn't doing this before. Told me it could be the alternator, but even if he changed it, being as they are rebuilt. I probably wouldn't see any difference. He looked it over, took it for a test run, charged me $54.00
It whines as soon as you start it up.Can anyone help?
My 2004 did the same thing - replaced the belt tensioner and its quiet as a clam now
Robbie R

Stamford, CT

#13 Aug 27, 2007
Pauline wrote:
I have a 2005 t.b. that is whining. The rpm's are
revving. Took it to the dealer, said it's normal. It wasn't doing this before. Told me it could be the alternator, but even if he changed it, being as they are rebuilt. I probably wouldn't see any difference. He looked it over, took it for a test run, charged me $54.00
It whines as soon as you start it up.Can anyone help?
Replaced the belt tensioner on my 2002 and its now quiet as a clam
Pauline

Goderich, Canada

#14 Aug 27, 2007
Robbie R wrote:
<quoted text>
Replaced the belt tensioner on my 2002 and its now quiet as a clam
Thank you for your quick reply. I made an appointment with another dealership for to-morrow. He thought it sounded like the clutch fan, but if he's wrong, he can try the belt tensioner.Kudos Robbie:
Have a great day....Pauline
michigan man

Zeeland, MI

#15 Aug 30, 2007
lol pauline I told you prolly your clutch fan a month ago.. good luck
Pauline

Goderich, Canada

#16 Aug 30, 2007
michigan man wrote:
lol pauline I told you prolly your clutch fan a month ago.. good luck
Yes you did, and I mentioned that to the other dealer who told me it was my generator. It wasn't.
I took it to a different dealership and had it fixed for $163.99
I'm happy to say it's purring like a kitten.
They replaced the idler pulley on the drive belt.

Many thanks to all of you, who took the time to let me know where the problem might be.
Hopefully this will help someone else.
It feels brand new again.......
Have a great day Trail Blazer Owners....
Guess I'll keep mine now.......
As if I could afford to trade it!
Jennifer

Silver Spring, MD

#17 Sep 7, 2007
I have a 2004 Trailblazer pass Warranty but only has 36,900 miles but I am having serious trouble starting my truck. I try to start my truck but instead the guages just go crazy and it wont start at all. Plus I am unable to even shift into nuetral. I was thinking maybe the security system is the cause. If anyone has any ideas please let me know. It even stalled while I was driving too.
Karen V

Bristol, CT

#18 Sep 10, 2007
I had a problem with my car starting at one point! Never guess what it was! The back hatch! When It was opened the car would not start! When I closed it, it would! Go figure
PAULINE, was the whinning noise similar to the sound of a dentist drilling a tooth?
Beth Gruesbeck

Denver, CO

#19 Sep 13, 2007
Jennifer, Silver Spring, MD. My 2004 Trailblazer is doing the exact same thing right now. Sometimes it starts & other times it is perfectly fine. Even stalled on me while driving as well! My mechanic is having trouble diagnosing the problem. I was wondering if you've had any luck fixing yours?
Beth Gruesbeck

Denver, CO

#20 Sep 13, 2007
Jennifer wrote:
I have a 2004 Trailblazer pass Warranty but only has 36,900 miles but I am having serious trouble starting my truck. I try to start my truck but instead the guages just go crazy and it wont start at all. Plus I am unable to even shift into nuetral. I was thinking maybe the security system is the cause. If anyone has any ideas please let me know. It even stalled while I was driving too.
Jennifer, Silver Spring, MD. My 2004 Trailblazer is doing the exact same thing right now. Sometimes it starts & other times it is perfectly fine. Even stalled on me while driving as well! My mechanic is having trouble diagnosing the problem. I was wondering if you've had any luck fixing yours?

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 10
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet TrailBlazer Discussions

Title Updated Last By Comments
Passenger window and door lock not working (Jul '07) 11 hr bray 27
Clicking/Ticking under Idle only. (Jan '07) Apr 24 Jessica 71
05 trailblazer shifter moves, car wont (Apr '13) Apr 23 Sick of the people 41
2003 Chevy Trailblazer instrument panel malfunc... (Dec '07) Apr 23 Ymayfield 76
05 Trailblazer vacuum/blower noise passengers s... Apr 22 MarieC 1
Trailblazer gas mileage (Mar '06) Apr 22 Surrounded by idiots 113
Trailblazer - Reducted Engine Power (Aug '06) Apr 21 Angela 57
More from around the web