Loss of oil pressure at idle
First Prev
of 7
Next Last
Brian

Boca Raton, FL

#1 Oct 14, 2009
I have an 02 tblazer that I tow a trailer with occasionally.141k miles without trouble Now after 45 minutes of towing oil pressure drops to zero at idle. the temp stays 210 not overheating.Is this engine bearing wear or a pump problem??
Willie-MN

Rantoul, IL

#2 Oct 16, 2009
I had the SAME thing and it was a problem with the wiring harness. They replaced the Oil Pressure sending unit and then it still read low. Then they hooked up a mechanical gauge to the engine and saw the pressure was fine.

Then they checked the wiring and found a bad wire or connection in the harness. The work record said they replaced the pigtail & wire harness to sending unit and all was OK.
The sensor was $74 & the Connector P/N 88988301 was $60.77, the labor was $366! It was covered under the end of the extended warranty.

I don;t know much more about it!

Good Luck!

Willie
Ricardo De Oliveira

Venezuela

#3 Feb 12, 2010
I have a 2002 Trail Blazer, 4.2 Engine, After I drive for a while, in every stop the gauge shows zero oil pressure and the message shut off the engine, did change the oil pump o-ring, chage the oil pression sensor in the carter, cleaned the oil colector. After that the oil pressure went down againg, them I did change the Cluster Assy. and the gauge keep showing cero after a while of running. I lefted the engine in idle for more than 10 minutes and the engine doesn´t sound different, It should start making a noise like no oil at all, It seems like the problem is in a wire or something like it. Can anybody help me? because even if there is no noise at all, I can trust when my wife drives the Trail. She doesn´t look the gas Gauge.
Rick Norfolk VA

Devon, PA

#4 May 20, 2010
I have the same problem with the oil pressure randomly dropping on my 02 trailblazer. Before I get my mechanic to go on a wild goose chase, did anyone get this problem resolved?
laszlo

Waterloo, Canada

#5 Jun 5, 2010
I have the same problem with my 02 trail blazer. For 2 years now.
DMS119

White Haven, PA

#6 Jun 10, 2010
i have an 02 trailblazer and the reduced engine power light came on every morning during the winter and it took forever for the truck to warm up. I was told to replace the throttle body and I did that. The light stayed off until the temp erature dropped below fifty degrees. Now the service engine light is on and the rpm odometer drops while I am driving. Sometimes the truck will completely shut off and other times it just slows down. I was told to replace the 02 sensor. I don't know what to do anymore. If anyone has any suggestions, please let me know.
Chris Fresno

Fresno, CA

#7 Aug 20, 2010
I have the same problem too. Oil pressure drops and then goes back up when I press the gas. I have a 2002 trailblazer.
Jim

Boulder City, NV

#8 Aug 26, 2010
DMS119 wrote:
i have an 02 trailblazer and the reduced engine power light came on every morning during the winter and it took forever for the truck to warm up. I was told to replace the throttle body and I did that. The light stayed off until the temp erature dropped below fifty degrees. Now the service engine light is on and the rpm odometer drops while I am driving. Sometimes the truck will completely shut off and other times it just slows down. I was told to replace the 02 sensor. I don't know what to do anymore. If anyone has any suggestions, please let me know.
there is a problem with these. there is a wire harness that goes to the fan clutch and sometime it will get warn thou. most commom to have a fan overspeed code if this is the problem. the fix is to replace the fan clutch assembly
nando

Converse, TX

#9 Mar 30, 2011
i have the same promblem with mine. At idle it drops and when i give it gas it goes back up to normal.I have a 2002 Trailblazer.would this be consider a recall
Hanco

Doha, Qatar

#10 Jun 30, 2011
Today i put keyword to search about oil pressure problem in trailblazer.. i hope i can solved my problem... but seem to be All still with trouble.
when i kept in iddle the pressure goes to "0".. but no abnormal sound in engine.. i have 2003 model..
Szewczyk

Memphis, TN

#11 Sep 1, 2011
Does anyone's air temperature change when they are idling with low oil pressure? I also have an 02 Trailbalzer and the problem just recently started. I can drive to work after the truck as sat all night with no problem. Truck sits in work parking lot - drive 16 miles home in the heat of the day - mostly interstate - and the light i get to at the off ramp - oil pressure gauge bottoms out and air conditioner starts to blow warm air. Has anyone heard anything more regarding this issue?
besttwinsaround

United States

#12 Sep 14, 2011
Szewczyk I have the SAME exact problem as you even the overnight, no prob in the morning and problem starts when I get off the pkwy after work... No change in temp or how it runs... Just the oil pressure drops and check gauges light comes on then after I drive in residential for about 15 min it stops dropping...
ZDM

Blythewood, SC

#13 Mar 2, 2012
This has gotta be a recall. Its to many people having the same problem. I have a 2002 Trail Blazer and everytime I crank it up the oil gauge want move and it reads low oil pressure shut engine off and after a few seconds the gauge will move up. When I stop at lights the gauge will drop down and when I hit the gas it goes back up.Chevorlet needs to do a recall on this.
Szewczyk

Memphis, TN

#14 Mar 2, 2012
I have been searching for contact information to reach some of the executives at GM. This issue can't be coincidence - they need to look into it and fix it. I think that if the information gets in the right hands they will take a look at the issue. I just have to find a way to get it to them. Any help finding email or mailing info would be greatly appreciated.
Griffin5

United States

#15 Mar 2, 2012
I have a 2005 Trail Blazer, I'm having the same problem with my oil pressure dropping at red lights. I agree there should be a recall!!!
Keith H

Lakewood, NJ

#16 Apr 30, 2012
I have an 04 trailblazer and the same problem...just started out of no where and the engine runs fine...not even sure how to fix it at this point. I never seen anything like this before that wasnt an oil pump issue but the actual oil pressure is fine
2002TrailBlazer

United States

#17 May 8, 2012
I have the same problem just called Chevrolet and they said most of the time its the oil pressure sending unit and that it wasent a recall and for them to check to see what the problem is they would charge more then $100 has anyone replaced the oil pressure sending unit Thanks
2003TrailBlazer

United States

#18 May 9, 2012
2003 TrailBlazer_Reduced Engine light came on after doing 65mph...got off the exit , slowed down&it tightened up and could not turn(barely)while it begin going about15mph, brakes tightened up and it stopped_Roadside came asap...someone could have been hurt_a friend says maybe im in need of new spark plugs.we shall see
Ryan Ramsey

Fort Worth, TX

#19 Jul 10, 2012
I have the exact same problem!! I have a 05 trailblazer 4.2 it will randomly die while at red lights. Oil pressure drops, engine light comes on. Turn car off, it turns right over no prob. This had been going on for about a year now...Recall Needed ASAP!!!
Amy

Saint Louis, MO

#20 Jul 13, 2012
I have an 05 Trailblazer. The gas gauge quit working about a yr ago & now its the oil pressure. As long as your going the oil pressure stays up once you stop it goes to 0. I also agree there needs to be a recall.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 7
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet TrailBlazer Discussions

Title Updated Last By Comments
trailblazer just shutting off on me (Jun '07) 13 hr LFR 110
Humming Noise In 2003 Trailblazer LT (Feb '07) Sat Famous Jett Jackson 72
Clicking/Ticking under Idle only. (Jan '07) Aug 24 camshaft followers 67
Car shuts off when A/C on (Jul '07) Aug 24 throttle body calb 146
Trailblazer just shut off! (Jun '06) Aug 22 Diess1970 240
Passenger window and door lock not working (Jul '07) Aug 21 RWH 24
04 TrailBlazer engine shuts off when AC is on Aug 17 JGnomercy 1
More from around the web