P1345 error code, very rough idling

Posted in the Chevrolet TrailBlazer Forum

First Prev
of 4
Next Last
Ben

Hollidaysburg, PA

#1 Sep 9, 2006
Hey fellow Trailblazer drivers, I just bought myself a used 2002 Trailblazer and after a week of driving it, the "Service Engine Soon" light comes on! You can imagine my reaction. Anyways, I hooked up a IDBII gadget and I get code p1345 - "Manufacturer Controlled Ignition System or Misfire." The light came on and it started running rough about 20 minutes after filling up on gas. Could the gas be a problem?(I'm hoping so.) Anyone have this code come up before? It idles very rough and often just dies while idling. Suggestions would be greatly appreciated. Thanks.
Lynn

Onalaska, WA

#2 Sep 19, 2006
Sounds like it was one of the recalls that never got fixed. Mine died one time while idling the other day, but it's been fine since then.

http://www.internetautoguide.com/auto-recalls...
Juan

Schaumburg, IL

#3 Oct 5, 2006
Hello I owned a 2002 trailblazer that shakes when cold after running it for a while you don't even feel the engine, another problem that i have is that if a run it for less than 10 minutes and turn it off it will not restart right away it just turns anyone having similar problems. please reply if you have any idea to what may be wrong.

thanks
Tron

Las Vegas, NV

#4 Oct 23, 2006
I also have a 02 trailblazer that just out of the blue started the rough idle and code P1345. I replaced the cam sensor and it got worse. I am trying to avoid the dealer, but, it is almost undrivable this way.
Larry

Norman, OK

#5 Mar 18, 2007
Ben wrote:
Hey fellow Trailblazer drivers, I just bought myself a used 2002 Trailblazer and after a week of driving it, the "Service Engine Soon" light comes on! You can imagine my reaction. Anyways, I hooked up a IDBII gadget and I get code p1345 - "Manufacturer Controlled Ignition System or Misfire." The light came on and it started running rough about 20 minutes after filling up on gas. Could the gas be a problem?(I'm hoping so.) Anyone have this code come up before? It idles very rough and often just dies while idling. Suggestions would be greatly appreciated. Thanks.
What was your fix
Ben

Laurel, MD

#6 Mar 30, 2007
Check for carbon build-up in the EGR valve. Years ago I found a good mechanic who would clean it out using a coat hanger. He had to charge a little bit for labor because it was hard to get to, but he said the dealership would just keep replacing it and charge an arm and a leg.
alex

Singapore, Singapore

#7 Apr 19, 2007
I got a Ford Laser 1.6 - the car will die off while driving after a while ( or when hot). Rest for 10 - 15 minutes it will fire up again & run normal till the next heat up. Any idea what going on with it ? Code read as P1345 as well but the car not rough idling. Any advise on solution ?
shrek

Marianna, FL

#8 May 8, 2007
on the 4.2L versions of the trailblazer there is a solenoid that changes the exhaust cam timing. p1345 is a crank/cam sensor correlation fault possibly due to a failure in this solenoid.other possible causes include engine timing, pcm, wiring, oil sludge build-up, etc. replacing either of the cam/crank sensors will only make this issue worse as the pcm has no idea which to trust anymore for the relearn process. i'm currently dealing with this issue and will provide a test or two for the cam phase shift solenoid if there is a possible way to do it easily.
dave

Mount Morris, NY

#9 May 8, 2007
Try the oxygen sensor on bank 1
Dave

El Cajon, CA

#10 May 12, 2007
shrek wrote:
on the 4.2L versions of the trailblazer there is a solenoid that changes the exhaust cam timing. p1345 is a crank/cam sensor correlation fault possibly due to a failure in this solenoid.other possible causes include engine timing, pcm, wiring, oil sludge build-up, etc. replacing either of the cam/crank sensors will only make this issue worse as the pcm has no idea which to trust anymore for the relearn process. i'm currently dealing with this issue and will provide a test or two for the cam phase shift solenoid if there is a possible way to do it easily.
I replaced the camshaft positioning sensor on my 2002 trailblazer and now it's getting 10 MPG. Anything you can think of that might help?
Hank

United States

#11 Jun 6, 2007
On my 02 Trailblazer, the Service Engine Soon light came on and the truck started idling very roughly. I also noticed that the oil pressure was slightly elevated from normal use. Just spoke with the dealer who advised me that the Camshaft Solenoid Valve needs to be replaced. Quoted me $263.54 for the part and labor.
Gordon

Homosassa, FL

#12 Jul 2, 2007
For the P1345 error code... Try adjusting the distributer until the SES goes out. If it does, then it is a (factory cheap) worn distributer gear causing the problem. Replace it.
Donna

United States

#13 Jul 20, 2007
My service engine soon light came on after I put gas in my blazer. I called the dealer and they told me to make sure the gas cap was on tight. I tighten it up and the light went away.
Dave

United States

#14 Sep 6, 2007
I have a 2001 Isuzu with a 5.7 GM engine. I got code P-1345. I changed cam & crank sensors, code still there. Put in a new dist. Code still there.
Complete tune up, new tank cap. HELP...what next?
P1345 code

New Berlin, WI

#15 Sep 24, 2007
We were having troubles with our 2003 Trailblazer, rought idling, high pitched fan belt, stalling. We went and bought the part, and installed it. Part was around $83. Easy installation, would have been around $200 plus to have dealer install. Anyways if you get this code, the GM part # is 12602516. No problems now.
P1345 code installation

New Berlin, WI

#16 Sep 24, 2007
Also, you must remove the power steering pump (13mm) bolt, 3 ea. And 10 mm bolt to remove the part and some fancy finessing to get the wire butt connector off of the sensor. The job takes less than an hour. Don't take to service center, easy job. Parts store will clear the engine code if you do not have a scan tool.

GM# 12602516
josh

Germantown, WI

#17 Oct 2, 2007
have a 1998 chevy scan code p1345 hard to start and stay running tune up less then 5000 miles i did I'm lost to check next
chris rough idle

Royal Oak, MI

#18 Nov 7, 2007
just changed the thermostat to fix the operating temperaure on my 02 TB LTZ. Now when idling, runs fine. Switch on the ac or heat and the engine bounces from 450rpm to 700 rpm and sometimes stalls out giving me a low oil pressure light. Any ideas?
haha

Grand Rapids, MI

#19 Nov 10, 2007
chris rough idle wrote:
just changed the thermostat to fix the operating temperaure on my 02 TB LTZ. Now when idling, runs fine. Switch on the ac or heat and the engine bounces from 450rpm to 700 rpm and sometimes stalls out giving me a low oil pressure light. Any ideas?
im lookin up shit for ur car wat a small world , mike gman
haha

Grand Rapids, MI

#20 Nov 10, 2007
wat a small world its mike gman looking up shit for ur car .... hmmm ill keep looking ttyl

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 4
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet TrailBlazer Discussions

Title Updated Last By Comments
06 trailblazer HELP 3 hr sandra1977 2
2004 Trailblazer grinding/growling noise when a... (Feb '12) 11 hr robb10 18
2003 Chevy Trailblazer will not start (Jul '09) 20 hr Cyrill 42
2004 Trailblazer won't rev over 3000 rpm (Apr '08) Mon robb10 8
Transmission in my '03 Trailblazer dead (Sep '06) Sun tina 81
Car shuts off when A/C on (Jul '07) Sep 25 lateefahmed 102
2002 Trailblazer Problems--LOTS !! (Aug '07) Sep 23 bob 36

Chevrolet TrailBlazer People Search

Addresses and phone numbers for FREE