Trailblazer just shut off!
Tru Chevy Girl

United States

#121 Feb 21, 2008
Purchased 2004 TB in November 2007, January 30th 2008 3 months after purchase, vehicle would not start, had lights and all, but would do nothing when turning the key.... Had it towed to dealership,they said it was ignition switch and battery, 330.00 worth.... now Feb 21st not even 1 month later, it has done the same thing again... its on its way to dealership yet again....told dealership if it is same thing, that I am not paying to have it fixed this time, as it sounds like defective parts to me...
Question: On TB's does your ignition start by barely turning the key? Is this a normal function?
Also, if this problem with the ignition is so promenient, why not a recall???...
I have owned Chevy's all my life and this is the first time we have had any problems at all...
George

Saucier, MS

#122 Feb 23, 2008
Ren wrote:
My '05 trailblazer cut off on me in the middle of the raod.TWICE. Now my gas light stays on AFTER I fill the tank up. I've recently run out of gas 3 times within a few months because I can't gauge how much gas is in the tank. A month ago my speedometer was reading 60 even though I was sitting idle. Ironically I saw on the news the same night that GM and Chevy SUV's were doing that but it wasnt a safety issue and there would be no recall. This was my dream truck but I am at my wits end on what to do. Any suggestions, especially about the fuel sending sensor. I'm a single female and getting stuck on major highways suck when it's @night.
I have the same problem, been to the dealer tons of times and they don't know what it is. Now I am out of warranty and have to come out of pocket.
iceman29

Saint Louis, MO

#123 Mar 10, 2008
I have a 2002 Chevy Trailblazer,,I recently had to change the driver side low beam light which re quired disconnecting the battery, Once I was done and drove the truck it wanted to shut off and gace me a"low oil pressure, just shut off"... anybody else have that issue??
bobby

Chicago, IL

#124 Mar 16, 2008
My wife's traiblazer will not release the key. The ignition switch turns almost to the end but not enought to shut everything down (car turns off) and release the key.

Do you have any suggestions as to the problem and estimate on cost to fix?
Thanks!
CHECK THIS THEN wrote:
Well..hi everyone..I am a former GM Tech and can tell all of you this..if you own a trailblazer..dont hang a load of keys on the ignition switch..one or 2 keys max..with the remote. Anything heavier..i guarantee the the "pins" inside the lock will wear out..and you have intermittent driving problems. if you bought a used trailblazer..theres a good chance that you will have this problem if the former owner had a bunch of keys hanging on the ignition.
Army Vet

United States

#125 Apr 17, 2008
I was having the same issue in my 2005 trailblazer, it would shut off on me while I was driving on the highway or paying at a toll booth. Most of the time it would start back up but this last time it didnt, good thing I was at the dealership. I let them know that I had read about the ignition switch going bad and sure enough that was the problem. It was replaced and now its running great again, knock on wood!
Brian6821

Concord, CA

#126 Apr 21, 2008
2006 CHEVY TRAILBLAZER EXT W/ 42K.
This just happened to me like 10 times within 15 minutes at a shopping mall here in PHOENIX, AZ. I was trying to find a parking spot and it just shuts down and powers right up again.
I've had the AC serviced and parts replaced about 8-10 times since new.
PIECE OF GARBAGE.
Loreto

United States

#127 May 20, 2008
Kevin wrote:
Has this happened to anyone?
Got an '02 T-blazer, wife was at a stop light, light turned green, she hit the gas to go, then the engine just shut off! The 'No oil pressure' light came on, no power steering, everything just powered down. She managed to pull into a driveway on the side and it restarted w/no problem and she drove home just fine.
Took it to dealer, they drove it around for about 40 miles and it didn't do it again, hooked it up to computer and said there was no 'code', whatever that means. So bottom line, they don't have a clue whats wrong with it. Fortunately they didn't charge me anything.
Anyone have an idea what this might be?
This happed to me on a 05 traiblazer on 3 occasions. Been stoped at a red light after drivig for a while and the vehicle just turns off. It turns back on with no problem and runs fine. The 1st two times i took it to the dealer they didn't find anything wrong with it. They just recommended cleaning the injectors. The 3rd time the "check engine light " stayed on so they were able to detect a code. They replace the #4 cylinder and coil(spark plug) but it still don't think thats it. I've had to pay $100 dollars for extended warranty deductable. Chevy is just giving us the run around, I think its a elecrical problem that they don't want to fix.
Kia

Medford, MA

#128 Jun 24, 2008
I havew an 04 Chevy Trailblazer with 50,000 miles on it. Mine shut off this pass weekend in the middle of an intersection and blocked traffic. All the dash lights were on, vehicle in drive and the radio was still playing. It wouldn't let me turn the ignition or take the key out. after a few seconds, it started back up without a problem. Then, yesterday, as I was sitting at a red light, it just shut off and a "check Gages" light popped up. Then it restarted for me again. Now the service Engine soon light is on. I only had this car for 2 1/2 months.
Erin

Tucson, AZ

#129 Jul 4, 2008
I have an 04 Trailblazer and it recently died on me at a red light. It started up soon after and I was able to get it home but am now afraid to drive it. The idle seems rough and when I am driving it at feels like it wants to die, like its not getting fuel. The check engine light came on so I took it to get codes ran, they said it has a small leak in the fuel system, "not a big deal" I was told. Fuel pump?
vjones

Dallas, TX

#130 Jul 16, 2008
I was driving my 2003 TB today and the low oil pressure light came on. It just stopped running shut down. It cranked back up. I drove it home. Should I be concern with this. This has never happen before.
Tony

St. John's, Canada

#131 Aug 13, 2008
Not the same rig but this may be of help!
The problem your wife had is very similar to what happened to me just a few days ago. After 2 days of searching we discovered a ground wire was corroded on the chassis. Sounds simple but a hell of a time looking for it. Hope this helps.
Kevin wrote:
Has this happened to anyone?
Got an '02 T-blazer, wife was at a stop light, light turned green, she hit the gas to go, then the engine just shut off! The 'No oil pressure' light came on, no power steering, everything just powered down. She managed to pull into a driveway on the side and it restarted w/no problem and she drove home just fine.
Took it to dealer, they drove it around for about 40 miles and it didn't do it again, hooked it up to computer and said there was no 'code', whatever that means. So bottom line, they don't have a clue whats wrong with it. Fortunately they didn't charge me anything.
Anyone have an idea what this might be?
gsn

Ridgewood, NY

#132 Aug 27, 2008
movehere wrote:
we have a 2002 chevy trailblazer. about 4-5 times now the car seems to just shut down. There is no power to the ingnition, no lights, no power locks, nothing, and the key won't come out of the ignition. It won't jumpstart, nothing. I think it may be something in the security system. It just wont do anything. If you disconnect the positive battery cable and then re connect everyting works just fine. Today my wife was driving and had stopped when the engine died and then the key would not come out of the ignition, no power ect all of the above symptoms again occured. A passerby tried to jumpstart to no avail, and while wiggleing the battery cables my wife said that all of a sudden the dash lights came back on and the car started again. Any ideas?
Get a new battery. They key will not come out of the ignition if the battery is dead.]
gsn

Ridgewood, NY

#133 Aug 27, 2008
Derrick wrote:
I have a LTZ Trailblazer 2002 with 140k miles and I had the same problem with my car running fine at times and sometimes when I come to a stop light or sign it will cut off. One thing that I found out when my service engine soon light came on that some faulty sensors was the cause of the problem in my case the Code was P0340 that is the Camshaft sensors.
Same thing happened to me but I only have 68K on mine. I just replaced the camshaft position sensor (P0340) and the camshaft position actuator (P1345) and it ran great for 2 hours. Then the "service engine soon" light came back on. Going back today to hook it back up to the computer.
JEN

Wilmington, DE

#134 Aug 28, 2008
THE FUEL SMELL YOU SMELL COULD BE COMING FROM THE FUEL TANK ITSELF. THERE IS A RECALL ON THAT. WHERE THE FUEL TANK HOSE HOOKS INTO THE FUEL TANK. I JUST FOUND OUT MY 03 EXT TB HAS A LEAK AND THE DEALER IS REPLACING IT AT NO COST TO ME. THAT MAY BE WHY YOURS IS TURNING OFF. IT SENSES THE GAS LEAK AND SHUTS OFF FOR SAFETY. MINE HAS NEVER SHUT OF (KNOCK ON WOOD) BUT DOES SOUND LIKE IT IS GOING TO AT TIMES.(WHEN I AM AT A STOP LIGHT AND GO, OR FROM THE STOP POSTION AND GO.) JUST THOOUGHT I WOULD LET YOU KNOW. MINE IS GETTING FIXED NEXT WEEK. I WILL KEEP YOU POSTED. MY SERVICE ENGINE LIGHT JUST CAME ON TODAY AND SEEMS THAT THE LEAK THAT RUNS DOWN MY GAS TANK HAS GOTTEN WORSE. WITH THE SEAL NOT BEING TIGHT BECAUSE OF THE LEAK IT COULD CAUSE THE ENGINE TO SHUT OFF.
Erin wrote:
I have an 04 Trailblazer and it recently died on me at a red light. It started up soon after and I was able to get it home but am now afraid to drive it. The idle seems rough and when I am driving it at feels like it wants to die, like its not getting fuel. The check engine light came on so I took it to get codes ran, they said it has a small leak in the fuel system, "not a big deal" I was told. Fuel pump?
05 trailblazer

Papillion, NE

#135 Aug 28, 2008
I have a 2005 Chevy trailblazer. I bought it about a montha go with 45000 miles. When I hit 70 the transmission makes a whining noise. Dealer said that is normal. But my brother has same model no problems. Anyone else experience the same thing.
yandy

Punta Gorda, FL

#136 Oct 30, 2008
well mine is fine expect when i turn the a/c on. the rpm start going up and down and sometimes it shut off i cant even use my a/c any more is crazy can anyone help!!!! and i run out of waranty
tim

Burlington, NJ

#137 Nov 9, 2008
Cheryl wrote:
I have an 04 Trailblazer,53,000 miles on it, every time the gas gap gets loose if I have ran over some bumps on the road, the check engine soon light comes on, am I the only person this has happened too????
i have a2004 trail blazer with the same problem i replaced mine 2x's the last one lasted about 6months since replacing mine the last time it seems to be working better (knock on wood)
tim

Burlington, NJ

#138 Nov 9, 2008
gsn wrote:
<quoted text>Get a new battery. They key will not come out of the ignition if the battery is dead.]
i have a 04 trailblazer i had the same problem i took it to the dealer they told me it would cost me 800.00 to fix they said it was the pass lock security system and it neede to be replaced it is located on the driver side under the back seat.so they replaced it well 2 days later the samething .to make a long story short they called gm gm told them there is a small wire at the ignition that shorts out and it needs to be replaced so they did replace it and ever since i have had no problems and i got all my money back
Will

Oshawa, Canada

#139 Nov 25, 2008
I have a problem with my 02 trailblazer as well the check engie light goes on and off all the time and if ive been driving long enough for the engine to heat up its hard to start again and when it doe start it idles rough any comments on this?
Glen

United States

#140 Dec 7, 2008
We have '05 Trailblazer and it has stalled a few times only when it is raining/damp outside. It does at a stop light and even happened when coasting at 40mph without my foot on the gas pedal. Anyone have any ideas on what might be the problem?

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet TrailBlazer Discussions

Title Updated Last By Comments
05 trailblazer shifter moves, car wont (Apr '13) 6 hr Matt 38
engine swap 4.2 2006 (Aug '11) Sat Cameron 4
Trailblazer - Reducted Engine Power (Aug '06) Mar 23 RTM 54
trailblazer 2004 electrical issue Mar 21 Weigand 1
Location of coolant sensor Chevy Trailblazer 2008 Mar 19 Fabian 2
2004 Trailblazer grinding/growling noise when a... (Feb '12) Mar 16 Vette 34
Tranny problems Mar 14 Kenny 1
More from around the web