2003 Suburban/Tahoe/Sierra Electrical...

Since: Jul 08

Location hidden

#41 Jan 19, 2012
I am having this problem right now I will hit a bump and it reduces engine power,,i already payed out 400 to have it fixed they said it was my throttle control,and it still does it.i habe a 2003 z71 suburban.it does it more when I hit the bump on the passenger side
Jason

Puyallup, WA

#42 Jan 24, 2012
I have an 03 Suburban. The dash cycles through different languages, my odometer doesn't show up nor does my how many miles I have to go before I run out of gas. Please help me jsndrury@gmail.com

Since: Apr 11

League City, TX

#43 Jan 25, 2012
Jason...GM recognized an issue with the dash and sent out a notice that you can have it fixed. But there is a time limit and a mileage limit on the warranty. Ours fell outside the range and we had to pay to have it replaced. It was an on going issue. It won't get better. There will be times it will work right then go out but come back. Call a dealership and find out about the warranty for the repair. We've had so many issues with our 2003 Suburban it's not real. Just had the fuel filter, fuel pump and rear end replaced. And that's at the bottom of the long list! Good luck!
jorge

Auburn, CA

#44 Feb 1, 2012
2003 tahoe battery dies every night what could it be ? new battery and starter have to jump it every day to drive any ideas
RanJan

AOL

#45 Feb 12, 2012
momtoboys4 wrote:
We have about every problem with our 2003 suburban that everyone has listed on any of these discussion boards. Right now it's in the shop because while we were driving it on the freeway it started to die and when the gas peddle was pressed no gas was going to the engine. It died, sat there a few minutes got it restarted enough to get off freeway. Continued to do it, pulled into parking lot in front of police station, walked across the street to car dealership and called wrecker. Walked back so wrecker could take it and someone had broke into the car and tried to steal it, damaged steering column. Before all of this the suburban has had instrument panel be totally out, speedometer peg out along with tachometer. Show wrong speed while driving and at a stop, have the suburban die while driving it and have to put it in neutral and restart while coasting on freeway, this has happened twice.Gas gauge doesn't register all the gas in tank so it will "run out of gas" at 20 gallons, so we have to keep it filled no less than at half a tank. Couldn't get the key to turn the ignition and then get stuck. Driver's seat will reposition the lumbar pieces to where you can't sit it in it. Driver seat heater goes off if you turn PS heater on and driver's seat heater won't stay on longer than a few minutes. AC actuator went berserk and would only blow air through the top defroster. Have to had to replace all the fuses for lights on radio/steering wheel/auxiliary chargers. U joints replaced within the second year of owning it. Weld broke on exhaust. So now we have been told the instrument panel/cluster is totally out and that's what caused it to die. They can't even get it to start now. We have been given the cost of $900-$1100 to replace it. It's been at the repair place for a month to get the damage repaired by the thief and because of GM knowing that there were issues with the instrument panel we are still being victimized.We just happen to call the dealership when GM decided to repair the problems with the speedometer but we were told we were out of the age/miles for them to do it. Go figure! Will re-post to say if the cluster was the issue for most of our problems. Still pisses me off that GM has known about all these issues for years but continued with the same design.
Had fuel sending unit in gas tank changed out a couple of years ago after problem with going down highway and engin just quits. After sending unit replacement, problem went away,
Josh Nisbet CA

El Dorado Hills, CA

#46 Feb 20, 2012
Just wanted to leave a quick comment that this fix post just saved a customer of ours over $1800. The Chevy dealer in our area (Placerville,California)Wanted to replace the entire wiring harness and most connectors pertaining to the vehicles computer. we looked at it for about an hour before consulting google. your post was the first. Reading through it, all the problems you had, we had. checked that wire and it was completely off of the block. repaired and retested. thanks so much both from us and our customer.
Phil

San Diego, CA

#47 Mar 9, 2012
I'm having problems with my instrument cluster on my 2003 Suburban. The gauges don't work, the ABS light stays on, the emergency brake light stays on, the air bag light stays on and the battery indicator light stays on. All of this is intermittent. I changed out the alternator and I checked for charging and it is charging good. Please help!!
momtoboys4

League City, TX

#48 Mar 12, 2012
Phil wrote:
I'm having problems with my instrument cluster on my 2003 Suburban. The gauges don't work, the ABS light stays on, the emergency brake light stays on, the air bag light stays on and the battery indicator light stays on. All of this is intermittent. I changed out the alternator and I checked for charging and it is charging good. Please help!!
GM recognized an issue with the dash and sent out a notice that you can have it fixed. But there is a time limit and a mileage limit on the warranty. Ours fell outside the range and we had to pay to have it replaced. It was an on going issue. It won't get better. There will be times it will work right, then go out, but come back. Call a dealership and find out about the warranty for the repair.
rachel casper wy

Big Timber, MT

#49 Mar 27, 2012
Jason wrote:
I have an 03 Suburban. The dash cycles through different languages, my odometer doesn't show up nor does my how many miles I have to go before I run out of gas. Please help me jsndrury@gmail.com
I have had all those issue, cluster, heated seats, windows but the biggest problem is my odometer reset itself to zero. Not a clue how many miles are on it. The only thing that works on that end is the oil life % and hours of the car running. Nothing else.....Did you get your issue fixed?
Tyler

United States

#50 Mar 28, 2012
My 2003 Tahoe's speedometer went out and i bought a GPS to tell me the speed so no problem with that. A year later my battery needed replaced, so i replaced it, the next day my gas gauge went crazy and started pointing straight down. My voltage meter is showing 19 and my passenger side window wont roll down anymore.. this all happened within two days after i replaced the battery, yet they didn't do this before.
Josh

Killeen, TX

#51 Apr 9, 2012
I have a 2003 Tahoe LT 4*4 with some annoying electrical issues! Every time I turn right the door chime goes of and often when I hit a bump the door chime will go off again. It is very annoying and driving me crazy!!! Anyone else having the same problem??? HELP PLEASE!!
Laki

Sacramento, CA

#52 Apr 17, 2012
Does anyone know why the horn on a 2003 Chevy Suburban would start honking? I haven't had a key fob for at least 3 years. The fuse is fine. I replaced the battery about 3 months ago and hadn't had any problems until today. I have left the car unlocked and that seems to work for now. Could it be a short. It doesn't have a car alarm.
chevy 2003z71

Conroe, TX

#53 May 25, 2012
I have 2003 z71 tahoe. cant figure out whats wrong with it. The speed odem,oil,temp,volts-all guages EXCEPT the RPM have quite working. The truck ran great then 1day started loosing power,guages went nuts,started reading"unknown driver,exit vehicle",window & door locks engaged,ABS,service 4wheel drive light came on. Turned off truck-reset battery cable & seemed ok-THEN went to crank and couldnt. Tested good battery,alternator.Tried again-cranked. Took to auto parts,he plugged in took under steering columb but said his tool didnt read anything. Now truck will start 1 time,run perfect BUT MUST disconnect neg side of battery cable after turning it off or it will NOT start again unless its set for several hrs(stranded!).Any idea's?
Edward

Winnfield, LA

#54 Jun 2, 2012
chevy 2003z71 wrote:
I have 2003 z71 tahoe. cant figure out whats wrong with it. The speed odem,oil,temp,volts-all guages EXCEPT the RPM have quite working. The truck ran great then 1day started loosing power,guages went nuts,started reading"unknown driver,exit vehicle",window & door locks engaged,ABS,service 4wheel drive light came on. Turned off truck-reset battery cable & seemed ok-THEN went to crank and couldnt. Tested good battery,alternator.Tried again-cranked. Took to auto parts,he plugged in took under steering columb but said his tool didnt read anything. Now truck will start 1 time,run perfect BUT MUST disconnect neg side of battery cable after turning it off or it will NOT start again unless its set for several hrs(stranded!).Any idea's?
Try having your security system reprogrammed. This is something you can do yourself if you have about 45 mins and a little patience.
Val

Baltimore, MD

#55 Jun 6, 2012
I got whole range of issues: Sunroof, cruise control, dash board lights, left turn signal (rear, front and the mirror) do not work. Everything else works fine. Any ideas??? Thank you.
Edgar

Dallas, TX

#56 Jun 8, 2012
Im having the same problem with my 2003 chevy suburban. My passengers door is dead my side mirror will not adjust, my door will not unlock. None of my doors will lock or unlock with my remote. and my a/c will not blow air in the forward position. Any idea what it can be guys?
Rynn

Queen Creek, AZ

#58 Jul 12, 2012
2004 Suburban Z71
Constantly replacing batteries every 5-12 months
Half the dash gauges work, some work one time then not the next
Drivers seat forward back switch works backwards
Engine will sometimes just die, twice at 70 mph on the freeway
Sometime will crank over and over and not start, 10 min later fires right up like nothing was ever wrong.

HELP WITH CHEVY
Momtoboys4

League City, TX

#59 Jul 12, 2012
Rynn wrote:
2004 Suburban Z71
Constantly replacing batteries every 5-12 months
Half the dash gauges work, some work one time then not the next
Drivers seat forward back switch works backwards
Engine will sometimes just die, twice at 70 mph on the freeway
Sometime will crank over and over and not start, 10 min later fires right up like nothing was ever wrong.
HELP WITH CHEVY
The part about your suburban dying while driving was happening to us multiple times. We would wait 5 minutes on the side of the road or sometimes in the middle of the freeway till it would start again. When it began happening more frequently within the same hour and then began making this horrible noise right before dying- we took it in. It was the fuel pump. It was replaced and we haven't had any more issues with it dying. Our gauges were going out and then went out for good and had the instrument panel replaced. This would have been under warranty had our mileage on the vehicle been what they wanted it to be, so it was out of pocket expense. Just had the second set of U joints replaced last week. First set was when the car was 1 1/2 yo. The driver seat working backwards is something that comes and goes and we will live with it.The same as getting into the car and it not remembering what the settings where for each driver and having to move the seat back just to get in. The seat heaters went on the blink many moons ago. We haven't had the issue with the battery like you are but we will not that when the battery is going bad, it sounds as if the starter might be going out. Took it into dealer for that issue in the past and they called and said it's all fixed got there and it was still doing it,let them hear what I was talking about it and they put a new battery in and all was fine. Now it's doing it again some years later but it really shouldn't be time to replace the battery.Hope some of this helps you. It's been very very frustrating to own this 03 Suburban. Our friends had bought one just months before us and their steering wheel caught fire while driving the car. At least that hasn't happened to us-yet!
ilima20

Honolulu, HI

#60 Jul 20, 2012
I am having that problem with my 2003 Chevy suburban. my dash lights would go off and on...can someone please help me.
Brian

Decatur, IL

#61 Jul 31, 2012
Going down road and the suburban qiuts running it is blowing the ecm fuse. could it be the relay?

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Suburban Discussions

Title Updated Last By Comments
2002 Suburban shuts off (Jun '07) 8 hr LukeG1579 92
News If Chevrolet Suburban Won't Start It Could Be S... (Jun '09) Feb 5 Terri 278
96 Suburban, 5.7l, 4x4 - Slow Battery Drain (Jan '07) Jan 30 Jim roy 64
transfer case engages but no front torque (Apr '06) Jan 29 LLB 70
multi-function switch electrical problem (Jun '06) Jan 28 Kevrob 213
Hard to start when Engine is Warm/Hot (Aug '07) Jan 20 screaminCmane 35
blower motor replacement on a 1999 suburban (Apr '13) Jan '18 Mcb 4
More from around the web