multi-function switch electrical problem
Nick

United States

#101 Feb 16, 2010
got a 94 chevy silverado that my low beams just stopped working figured they burnt out and ill get new ones next week and drive around with my highs. last night i flicked my switch from high to low beams now the lights dont turn on at all. Parkin lights work fine. When i try to flick the multifunction switch from high to low nothing happens i dont even hear the usual click. Anyone have any idea what the problem might be?
Karie

Redmond, OR

#102 Mar 1, 2010
John Smeltzer wrote:
I just corrected the same issue on my 1999 Chevrolet Suburban as well. Intermittent headlights on low beam was the issue. I found that my low beams were intermittent, my high beams seemed to work reliably and my driving lights were fine as well. It does appear that the Omron 7866 relay was either loose, had bad contacts or is failing. I pulled it out, cleaned the contacts lightly with a pocket knife (lightly is key), plugged the relay back into the circuit board making sure that it was seated well and viola .... I have low beams again and they appear to be reliable at the moment. I'm going to grab another relay just in case however. Thanks for posting the solution. Probably saved me the $600 plus messing around with the multi-function switch first!!
<quoted text>
I don't have a relay 7866 in the box
Karie

Redmond, OR

#103 Mar 1, 2010
I don't have a 7866 omar relay module in the fuse relay box under the hood.
jimmy guinn

Bethany, OK

#104 Mar 9, 2010
whe i turn my key over to the on position, my dash lights and guages sometimes do not work. when this happens the car runs very poor, doesnt want to take off, almost like the transmission is going out. however, when the guages and lights work the car runs fine. is this a problem somewhere in the ignition system? please help. thank you...Jimmy Guinn
jimmy guinn

Bethany, OK

#105 Mar 9, 2010
Also, I recently changed the stereo from factory to aftermarcket. Would this have any effect on the wireing harness somewhere causing this problem? if anyone has any ideas please email me at j-guinn@hotmail.com subject-suburban. Thank you.
dan

Corpus Christi, TX

#106 Apr 14, 2010
Nick wrote:
got a 94 chevy silverado that my low beams just stopped working figured they burnt out and ill get new ones next week and drive around with my highs. last night i flicked my switch from high to low beams now the lights dont turn on at all. Parkin lights work fine. When i try to flick the multifunction switch from high to low nothing happens i dont even hear the usual click. Anyone have any idea what the problem might be?
Don't know for sure, but sounds like the multifunction switch. When they go out, they can cause a variety of issues. I had similar problem on 98 suburban. Finally had dealer diagnostic run for $90 to pinpoint the problem to the multifunction switch. High dollar item if you buy new. Best to check the junk yards.
kristin

Crete, NE

#107 Jul 19, 2010
I have a 2000 grand prix and I just had this same thing happen, the brake lights went out but the third brake light in my back window still works. and it costs about 500 bucks to fix??? does anyone know how much a sensor or some kind of part would be to try to fix it myself??
mitch

Marrero, LA

#108 Jul 22, 2010
Art wrote:
I have a 1999 GMC 2500K. Just started to experience a similar but different light issue. Lights work in the running light position (no high beam) but no head lights in the headlight position. I will check the #7866 relay first before monkeying with the switch itself.
Thank you!!!!!
did you find the problem , i am having the same problem
John

Philadelphia, PA

#109 Aug 6, 2010
It's the circuit board that the bulb sits in... they cost about $20

Again the Circuit board ...go t othe auto shope and ask for a left or right board for back tail light and then take off light and you'll see how it fits
mickie

Springfield, IL

#110 Aug 17, 2010
My hazard lights on my 2003 chevy trailblazer have been coming on w/o me cutting them on. Sometime I can't cut them off. Help
Reggie Byrd

Sacramento, CA

#111 Sep 25, 2010
John Smeltzer wrote:
I just corrected the same issue on my 1999 Chevrolet Suburban as well. Intermittent headlights on low beam was the issue. I found that my low beams were intermittent, my high beams seemed to work reliably and my driving lights were fine as well. It does appear that the Omron 7866 relay was either loose, had bad contacts or is failing. I pulled it out, cleaned the contacts lightly with a pocket knife (lightly is key), plugged the relay back into the circuit board making sure that it was seated well and viola .... I have low beams again and they appear to be reliable at the moment. I'm going to grab another relay just in case however. Thanks for posting the solution. Probably saved me the $600 plus messing around with the multi-function switch first!!
<quoted text>
I have a 1999 Chevy Suburban K2500 my left turn signal was intermitten until i pull the Omron 7866 relay out and got a finger nail file and brushed up against the contacts then put a little dialetric compound on the contacts and now it's working fine. Since it worked I suggest to everybody that reads this to pull your relays and clean them even if your not experiencing these problems because you don't want to be caught at night all of a sudden your head lights go out.
Reggie Byrd

Sacramento, CA

#112 Sep 25, 2010
The Omron 7866 relay is located under the dashboard driver side, it actually says Omron 7866 on the relay, your left foot is probably pointing at it while your driving or one even better turn your left or right turn signals on go down under the dash board and it's next to the one that clicking.
Dave

United States

#113 Oct 19, 2010
I have a 98 chev suburban. tailights and dash lights not working.brake lights work. i replaced fuses and bulbs and switch module. no luck. I was told to check the ground, but im not familiar with where to even start. any help?
Ron

United States

#114 Nov 6, 2010
Doug, did you get this fixed? I have the same issue. rdlammers@ra.rockwell.com
Doug wrote:
I have a 1999 Suburban and just yesterday morning I went to turn my headlights on and nothing. The daytime headlights work just fine. All of the running lights, hazzard and turn signal lights work fine as well. I ended up going to work using the middle position on the switch so that I was using my daytime headlights along with the normal running lights. I have 65K miles and have not experienced this problem before. My first thought was that the switch was bad since both regular headlights were not operating. Checked with the parts guys at two Chevy dealers. They both thought the same thing and that there wasn't any relays that could be bad. So, based on their experience, I bought a new switch at a cost of $81.14. No go! I checked the wiring the best that I could and will have to end up at the dealer. I can only imagine this is going to cost some bucks to diagnose a wiring problem! I'm hoping it turns out to be something simple.
Other threads talk of intermittant on/off cycles related to the warning buzzer and interior lights. I have only had the warning buzzer cut in-and-out while the door is open and the keys are in the ignition. Not a big deal, but its really annoying until the door is closed.
Ceasar

Houston, TX

#115 Nov 17, 2010
I own a 99 suburban and there is a switch with long arm thats on the steering column. It connects along with the gear shift cable. What is this thing called and what dose it do?
popeye

Norman, OK

#116 Dec 8, 2010
i have a 93 chv sub when i turn the key off everything steal works how do i fix ths plz healp
Meghan

Clermont, FL

#117 Jan 19, 2011
I have a 1996 Suburban 1500 and my turn signals aren't working. I've replaced the flasher and my hazards work, but when I try to use a turn signal, it will make a buzzing noise and won't work. Suggestions?
Jay west valley city ut

Salt Lake City, UT

#118 Jan 21, 2011
George in Edmond OK
Edmond, OK 99 Chevy Surb. with pwr. door mirrors that ONLY move downward, no side to side or up. Same prob. on left & right side. Any suggestions?????
I HAD THE SAME ISSUE. IT'S IN THE MIRROR SWITCH,, I TOOK MINE OFF AND THERE WAS ALOT !! OF CORROSION ON THE PLUG END'S OF BOTH MINE, TOOK A SMALL FILING FILE/WIFES EMERY BOARD, AND CLEANED IT AND THEN SPRAYED SOME WD-40 ON EM,,, FIXED MY ISSUES. BOTH MIRRORS WORK GREAT NOW ... TIME CONSUMING BUT WELL WORTH SAVING $58 BUCKS FOR A NEW SWITCH... WHOLE SWITCH UNIT POPS OUT OF DOOR , TABS ON REAR OF SWITCH ASSEMBLY IN DOOR REST AND THEN SLIDES OUT FOR THE FRONT. U CAN UNPLUG THE SWITCH AND IT ALL POPS OUT , BEING CAREFUL NOT TO BREAK THE HOLD IN TAB'S .(SMALL) SCREWDRIVER AND PATIENTS WORK WELL...
Jay west valley city ut

Salt Lake City, UT

#119 Jan 21, 2011
Cesar ,, in Tx .. that probably would be an external trailer braking hand switch for trailers with electric brake,s thus allowing u to use the trailer to slow truck/trailer down and not burning out your trucks brakes... better trailer control.
Jay west valley city ut

Salt Lake City, UT

#120 Jan 21, 2011
popeye wrote:
i have a 93 chv sub when i turn the key off everything steal works how do i fix ths plz healp
replacing the ignition switch..... it's not hard to do , u just have to be VERY CAREFUL unplugging the airbag. IF YOU'VE NEVER DONE ALOT OF AUTO MECHANICAL WORK, take it to a repair shop....

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Suburban Discussions

Title Updated Last By Comments
2002 Suburban shuts off (Jun '07) 4 hr LukeG1579 92
News If Chevrolet Suburban Won't Start It Could Be S... (Jun '09) Feb 5 Terri 278
96 Suburban, 5.7l, 4x4 - Slow Battery Drain (Jan '07) Jan 30 Jim roy 64
transfer case engages but no front torque (Apr '06) Jan 29 LLB 70
Hard to start when Engine is Warm/Hot (Aug '07) Jan 20 screaminCmane 35
blower motor replacement on a 1999 suburban (Apr '13) Jan '18 Mcb 4
water inside vehicle..where is it coming from? (Aug '06) Jan '18 97HOE 115
More from around the web