electrical problem on 1992 Chevy silv...

electrical problem on 1992 Chevy silverado...

First Prev
of 8
Next Last
bartle00

Saint Paul, MN

#1 Jan 17, 2008
When it's cold old side and it's been sitting over night and I start it up; it will start, but all my lights are dimming and my battery gauge fluctuates. I have a CD player that shows my voltage for the battery and it can drop down as low as 10.3 volts and then goes back up and down until the truck warms up and then it is better, but not perfect. It is fine in temps at about 25 degrees and up, but when it get colder it gets really rough. Then while that is happening and I try to drive my headlights and tail lights dim down almost like they are not on.
-my dad is a mechanic and he says it's not the battery or an alternator. He thinks it is something behind the instrument panel. We think it is a short somewhere. Can you help us out with this?

Any help would be greatly appreciated!
greg h

Anoka, MN

#2 Feb 21, 2009
have exact same problem...new battery and alt did not help...cleaned every grnd I could find...having all accessories off doesn't help...ignition module??? coil??? ignition sw???relay??? I wonder how long it would take a pro to figure out...don't wanna go there but may have to..good luck
chris m

Green Bay, WI

#3 Mar 3, 2009
i had the same exact problem with my truck and it was a wire grounding out in the drivers side trim wire harness that goes to the tail lights just take the trim out and locate the harness and you should find the wire thats grounding out i know it sounds wierd thats what i thought but as soon as we fixed it runs perfect

Judged:

33

27

1

Reply »
Report Abuse Judge it!
Angel Rider

United States

#4 Mar 7, 2009
Have 1993 Chevrolet Silverado, 3500 series (dually). Radio question: Ordered the truck new in 1992, Had never had any sort of problem with radio until 12 years later. Had radio on when I parked my truck in driveway one evening. Next time I got in truck to leave the radio had no sound. The radios digital face is visible with station id and volume settings etc. but no sound and can't operate any of the controls. I have checked the two fuses in-line to the radio and both are good. I have disconnected/reconnected the power. The radio's display is still froze and no sound. This is factory OEM radio w/ casette and equilizer. Is there another fuse that may be behind dash or inside the radio? Or any idea of what may be my problem?
Barbara

Chico, CA

#5 May 2, 2009
92 silverado--no head lights---have all running lights and turn signals and brake lights---replaced 2 square fuse blox and light switch relay---nothing changed---what's left?

Judged:

133

49

1

Reply »
Report Abuse Judge it!
fern

Pharr, TX

#6 May 11, 2009
Angel Rider wrote:
Have 1993 Chevrolet Silverado, 3500 series (dually). Radio question: Ordered the truck new in 1992, Had never had any sort of problem with radio until 12 years later. Had radio on when I parked my truck in driveway one evening. Next time I got in truck to leave the radio had no sound. The radios digital face is visible with station id and volume settings etc. but no sound and can't operate any of the controls. I have checked the two fuses in-line to the radio and both are good. I have disconnected/reconnected the power. The radio's display is still froze and no sound. This is factory OEM radio w/ casette and equilizer. Is there another fuse that may be behind dash or inside the radio? Or any idea of what may be my problem?
i have the exact same problem, my truck is a 93' GMC sierra and the radio works randomly but rarely.the time is always frozen and i cant seem to find out what the problem is.
Short Nose

Norwood, MA

#7 Aug 8, 2009
I had a similar problem so I removed the controller,amp-rec and eq-cassette deck; bought the conversion kit and installed a new Sony radio--speakers still don't work!
calbo

United States

#8 Sep 28, 2009
i have 92 chevy and my lights,radio and ac worked when they wanted to,till a few days ago,now the radio or the light dont work at all,what can be the problem
Jason

Ogden, UT

#9 Dec 15, 2009
I have a 1993 silverado that just yesterday the radio started to flicker on and off and the voltage gague dropped to about 9.5 and the headlights will dim every time the blinker flashes. Sounds like alternator right??? When I test alternator/charging system it is putting out about 14v. Any thoughts
huffdaddy

Cincinnati, OH

#10 Feb 24, 2010
I have the same problem with my 92 chevy k2500 the radio will freeze up and no control will operate..then when it wants it will come on and I reset all the stations and the clock. Then after I shut the vehicle down in about two hours the thing freezes up again whats the fix???
andrew

Milwaukee, WI

#11 Mar 8, 2010
i have a 1992 chevy silverado k1500. when i turn the headlights none of the lights come on in the rear, when i hit the brakes the tailights come on and the liscence plate lights come on as well, when i hit the turn signels every light blinks, i replaced all the wireing and connectors under the bed(tripple checked them every wire is hooked up correct). i replaced the turn signel / hazzard switch in the steering colum. replaced the flasher relay, bypassed the brake peddel switch. nothing has changed. help!!!!!! im lost
dan

Seffner, FL

#12 Jun 5, 2010
i have a 1992 chevy 1500, and the blinkers work, brake lights work, but when i turn the head lights on no other lights work. i have put new bulbs in and fuses. i went and got a tester for the wires, and am trying it today, that is all i know left to try. besides changing all the wires. plz help with anything else i can try.
Cris

Cypress, TX

#14 Sep 30, 2010
andrew wrote:
i have a 1992 chevy silverado k1500. when i turn the headlights none of the lights come on in the rear, when i hit the brakes the tailights come on and the liscence plate lights come on as well, when i hit the turn signels every light blinks, i replaced all the wireing and connectors under the bed(tripple checked them every wire is hooked up correct). i replaced the turn signel / hazzard switch in the steering colum. replaced the flasher relay, bypassed the brake peddel switch. nothing has changed. help!!!!!! im lost
Did you ever get this fixed I finally inherited my dads old beat up 92 k1500 he's been laughing at me cause i've been trying to fix myself. I haven't gone as far as you have but I'd like to know if you have solved the issue or not?
Huey

United States

#15 Oct 12, 2010
how do you remove the radio and equalizer controls from 1993 silverado
1992 Chevy Silverado 1500

Oakland, CA

#16 Nov 24, 2010
I'm having the same problem as below. At first i thought i fried something in towing my boat. i fogot to disconect the lights when I lanched the boat. I have since replaced bulbs, didn't have a problem with the fuses, Brake lights work, blinkers work. When head lights are turned on tail light, brake lights and blikers do not work. I guess i could drive the truck only during the day. LOL

anyhelp is appreacited.

Reply
|Report Abuse
|Judge it!
|#12
Jun 5, 2010 i have a 1992 chevy 1500, and the blinkers work, brake lights work, but when i turn the head lights on no other lights work. i have put new bulbs in and fuses. i went and got a tester for the wires, and am trying it today, that is all i know left to try. besides changing all the wires. plz help with anything else i can try.
Kate

Berwick, PA

#17 Nov 24, 2010
Hey guys i had the same problem with the 1992 SILVERADO RADIO. I was on this site looking for help awhile ago and finally decided to try to do it myself. There's a thing called a CDM reciever (or something close to that) located under the dash under the radio control / heat control. It's a skinny metal box probably about 6"x6"x2" in size. I was almost postive this was the problem because the radio and cassette have lights and some response (still no sound). So i went to the local junkyard and pulled one out of a truck (was a little dusty so i blew it out with an airgun) I changed it in the parking lot and IT WORKED! Quick and easy. Okay so here's what you do. First unscrew that piece of plastic under the cig lighter and ashtray. Should only be 2 screws and it pops right off. You'll need to position yourself under the dash on the driver's side. Look for the skinny metal box i mentioned before it's held up by a mounting bracket. You need to unscrew the mounting bracket and pull down a LITTLE BIT not too hard!( it might take a little twisting and turning). Take out all the wires plugged into it and remove it. Plug all the wires into the new one in the correct places (obviously). And TEST BEFORE MOUNTING IT BACK IN!! It should work. If not you may want to check the fuse as well. If it doesn't work i'm assuming either the old and new CDM recievers were bad or you have a different problem than described. Obviously I'm not a mechanic but this worked for me hope it works for you because not having my radio drove me crazyy! lol.
anthony

Coshocton, OH

#18 Dec 5, 2010
i got the 92 1500 from a dealer for $1700 had for a bit then the lights started goofing around and not working right. this problem only happens when its wet outside. i read most of the posts on here with this problem and no one had a solution. because the problem only happens when its wet outside i think its an obvious ground/hot wire on metal issue somewhere. ill explain my problem a little bit. you turn the headlights on its fine. u hit the brake pedal the reverse lights come on and stay on, even goin 60 down the highway. the right side turn signal works when it feels like it, but the left one works always. the dash lights randomly come on even when the truck is switched off if you tap the brake pedal. i would be looking for a burnt/cracked wire or a ground with a hot wire running nearby that may have burnt/cracked insulation. its about 25 degrees farenheit right now so it can wait till summer to fix it. i have been examining the problem for 3 months trying to narrow it down with my brain before i tear the truck to peices trying to figure it out.
Adrian

Branson, MO

#19 Jan 10, 2011
on my 92 Silverado, my Motor check engine light flickers on at idle, but when driving its ok,what is the problem
jess

Delta, UT

#20 Jan 14, 2011
make sure your wires are grounded from the battery to the frame and wherever your ground is under your hood.
Adrian

Branson, MO

#21 Jan 15, 2011
jess wrote:
make sure your wires are grounded from the battery to the frame and wherever your ground is under your hood.
thanks, I will check , hopefully it wil solve the problem. I fiear that i might have a beearing problem, and no oil is getting to one of the bearings.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 8
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Silverado Discussions

Title Updated Last By Comments
1992 chevy truck radio not working (Feb '10) Thu Dave 73
Shaking Silverado (Jan '07) Jan 28 Goody 35
2002 chevy silverado will not start? (Dec '08) Jan 28 wandasue75 66
truck will not start Jan 24 claude 1
2002 chevy silverado truck wont stay running (Jul '07) Jan 16 jas4fan 217
K1500 headlight/running light problem Jan 11 mirizarr 1
News GM, Isuzu joint venture likely to bring jobs to... Dec '15 The Duke of Hazard 5
More from around the web