2010 Rough idle, no engine light or...

2010 Rough idle, no engine light or codes

First Prev
of 2
Next Last
Bubba

Falmouth, ME

#1 Aug 10, 2010
I am experiencing 3 problems with my 2010 Silverado 5.3 with the 6 speed tranny. For the most part, the chevy dealer is placing blame on the operating characteristics of the 6 speed trans.

1. On occasions the truck, after sitting overnight will idle rough for aprox 30 sec. to a minute after starting it up. Feels like a full missfire,. It also occasionally idles rough at stop lights and stop signs. The Check engine light does not come on and it leaves no codes. any ideas

2. When in the 4 cylinder mode I can feel a vibration through the steering wheel like it is only running on three cylinders untill it shifts to the 8 cylinder mode. Dealership blacing blame on the torque converters lock out feature

3. After comming to a full stop, I let my foot partially off the brake so as to slowly inch forward. This causes the vehicle to roll slowly forward with a bucking motion as if it had a clutch chatter.
I was told it could be the anti lock breaks. This was dissproved in a traffic jam where on a slight incline, I let my foot fully off the breaks as to roll forward, the truck rolled forward in a jerking motion like it was missfireing or like it had a clutch chatter.

Any ideas
Thanks
mario

San Antonio, TX

#2 Oct 19, 2010
i havethe same truck withthe same problems. dealer say that's the way those trucks run. i too would like someone to address the problem
Danny

United States

#3 Oct 24, 2010
Chevy has a tsb for this. What is going to happen eventually, is the truck will start tapping and after many visits to your buddy the "service manager" will finally put lifters in and you will be set.
Good luck!
Bubba

Rocky Hill, CT

#4 Oct 25, 2010
Danny wrote:
Chevy has a tsb for this. What is going to happen eventually, is the truck will start tapping and after many visits to your buddy the "service manager" will finally put lifters in and you will be set.
Good luck!
As of yet the dealer hasn't sent or requested anything from Chevy ..Even tho they did experiance two of the problems for them selfs..Kind of makes you wonder doesn't it ? Any chance of you having the tsb # or any referance regarding the issue ?
Thanks
Matt

Franklin, TN

#5 Feb 20, 2011
The new lifters will not solve any of the problmens you describe. I had my lifters replaced last month due to engine making ticking sound. I have the 5.3 on my 2010 also and my truck vibrates while in 4 cyl mode also.
Bob

Nashville, TN

#6 Mar 3, 2012
I have the same rough idle problem from time to time. It started at about 50,000 miles. Took my 2010 5.3L Silverado crew cab to the dealer to have it checked. They said there is a Service Bulletin saying it could be related to carbon build up in the throttle box. They cleaned the box, it seems to have improved a bit but is still running rough at idle from time to time.
Mark Schlabach

Cardington, OH

#7 Apr 7, 2012
Matt wrote:
The new lifters will not solve any of the problmens you describe. I had my lifters replaced last month due to engine making ticking sound. I have the 5.3 on my 2010 also and my truck vibrates while in 4 cyl mode also.
I have a 2010 Silverado that has had about everything changed on the engine due to knocking, vibrating, smoking etc. Day after I bought the truck, it had to be hauled back to the dealership and all 16 lifters were replaced. 6 mos. later I started getting a rough idle at stop lights and so forth...GM had the dealership change spark plugs because 2 of them were fouled (GM could not explain so they put a band-aid on it). A month later the spark plug blew clear out of the engine block...not sure what caused that. 6 mos. later the rough idle showed up again...once again GM said to replace 2 plugs that were once again fouled. At this point I was begging for another truck or at least a crate engine because my truck left me sit twice, but NO, instead GM kept instucting the dealership to keep replacing this and that. Just last month I had the rough idle come back, so they replaced all 16 lifters AGAIN, replaced all 8 pistons and also the AFM (active fuel management) Manifold. They said the rings were siezed on two of the pistons. Truck is running O.K. but really shakes from time to time when it is at an idle. I love my truck, but am at the end of my fuse!
Brad

United States

#8 Oct 15, 2012
I have the rough idle after sitting over nite too but I've noticed when its cold out here lately in the 30's is when it does it. I have a cai (cold air intake) and an exhaust, maybe I'll be calling up the dealer about this issue.
Brad

United States

#9 Oct 15, 2012
Forgot to say truck is just shy of 19,000 miles as well.
Bubba

South Portland, ME

#10 Oct 16, 2012
Well all of my issues were from the start right off the showrooom floor..there is 26,00 on the truck now and the lerching is still there but not as bad so I am believing the issue just may be with the lock out feature of the tourque converter..must just be the nature of the beast.

Since: Dec 12

United States

#11 Dec 14, 2012
I just received a letter in the mail today from Chevrolet. Before I read the letter, I thought that I was losing my mind because I kept feeling the truck running rough frome time to time. This is an excerpt form the letter:

"This letter is intended to make you aware that some 2010 model year Chevrolet Silverado LD vehicles, equipped with a V8 engine, may have a condition where the throttle position sensor may cause the engine to run rough and cause the malfunction indicator lamp and/or an Engine Reduced Power message to illuminate. If this occurs, it could result in reduced engine power."

The letter goes on to say that if you have paid for repairs for this condition, you are eligible for reimbursement. So it seems that there is a problem, they are just not making it very well known. There is even a form included with the letter for Customer Reimbursment. I would definitly ask your dealer about this.
Cobyjack

Mobile, AL

#12 Dec 24, 2012
I got the same letter. I have been complaining to GM about this issue since I got the truck and they do nothing about it.
mike

Saint Catharines, Canada

#13 Jan 17, 2014
(2010 silverado) I only have rough idle after sitting over night when its arnd freezing or cold an damp. Sometimes it will crank over for 5 - 6 seconds with the remote start and just quit with out even starting!!. The dealer is full of dummys and think im makin this shit up!. I have a k&n intake, cat back exh, bully dog prog, 6" lift with 35's. I'm a chevy guy through n through but i'm ready to drive this shit box into a pole!
ronnie

Springfield, TN

#14 Jan 23, 2014
2010 chevy silverado turned cold and the truck started powering down. Two weeks now and its undriveable. Ihope its just the cold as some have suggested because I have just put a pedal in and have a tps on order. I will be near 300 bucks after the tps.
me and my new truck

Port Richey, FL

#15 Jan 23, 2014
2014 gmc sierra rough idle. 5.3 ltr. 2nd time in the shop for 3 different recalls. both times i have complained about the truck idling rough at times and making clicking noises from under the hood. sometimes very loud. feels like a misfire and or running on 7 cylinders. dealer both times said nothing wrong. i had the mechanic sit with me when i was picking up the truck from service and had him watch the rpm gauge bounce up and down while in park. between 500 and 550 rpms. i explained to the tech that it idles rough all the time when parked in my drive way which is up hill. my previous yukon xl with the 5.3 i had for 10 years parked in the same spot never did. he hooked up a module tester thingy and said hit this red button when the rough idle happens, so i did. as soon as i parked in my driveway it ran again like crap. what does this affect mpg's, reliabilty, resale, performance etc... any thoughts????
mike

Saint Catharines, Canada

#16 Feb 10, 2014
mike wrote:
(2010 silverado) I only have rough idle after sitting over night when its arnd freezing or cold an damp. Sometimes it will crank over for 5 - 6 seconds with the remote start and just quit with out even starting!!. The dealer is full of dummys and think im makin this shit up!. I have a k&n intake, cat back exh, bully dog prog, 6" lift with 35's. I'm a chevy guy through n through but i'm ready to drive this shit box into a pole!
Dealer installed 2 new 0-2 sensors and reset fuel management. My truck starts perfect now even in -30's
mike

Saint Catharines, Canada

#17 Feb 10, 2014
ronnie wrote:
2010 chevy silverado turned cold and the truck started powering down. Two weeks now and its undriveable. Ihope its just the cold as some have suggested because I have just put a pedal in and have a tps on order. I will be near 300 bucks after the tps.
My work truck did that, had a broken abs sensor so it put the truck in low power mode. The transmission stayed in over drive so it had slow acceleration but was a easy fix
Elmer

Saint Albans, WV

#18 Feb 14, 2014
2010 4x4 crew cab. Door locks start going up and down, gauges go off and transmission goes to neutral while driving. This has happened to me 4 times now while driving the vehicle. No problems show up when checked at the dealer.
Piercey

Moncton, Canada

#19 Feb 18, 2014
I have a 2011 GMC Sierra 59000 km. Rough idle when cold, bad MPG 11-13, and lack of power. It's been into 3 different dealerships 11 times. Everyone tells me there is nothing wrong with my truck. I'm starting to look at my intake manifold gasket.

http://www.agcoauto.com/content/news/p2_artic...
Tim

Janesville, WI

#20 Feb 23, 2014
Bubba wrote:
I am experiencing 3 problems with my 2010 Silverado 5.3 with the 6 speed tranny. For the most part, the chevy dealer is placing blame on the operating characteristics of the 6 speed trans.
1. On occasions the truck, after sitting overnight will idle rough for aprox 30 sec. to a minute after starting it up. Feels like a full missfire,. It also occasionally idles rough at stop lights and stop signs. The Check engine light does not come on and it leaves no codes. any ideas
2. When in the 4 cylinder mode I can feel a vibration through the steering wheel like it is only running on three cylinders untill it shifts to the 8 cylinder mode. Dealership blacing blame on the torque converters lock out feature
3. After comming to a full stop, I let my foot partially off the brake so as to slowly inch forward. This causes the vehicle to roll slowly forward with a bucking motion as if it had a clutch chatter.
I was told it could be the anti lock breaks. This was dissproved in a traffic jam where on a slight incline, I let my foot fully off the breaks as to roll forward, the truck rolled forward in a jerking motion like it was missfireing or like it had a clutch chatter.
Any ideas
Thanks
Had a 2010 silverado with flex fuel 5.3 went out after work to start my truck and let it warm up a bit took 3 times to start and when it did it was a rough idle then RPMs went through the roof. No CELs or dummy lights. From it to the dealership and found out the fuel alcohol sensor was measuring that I was running E85 which I was not. So the computer did what thought was right and adjusted timing for E85. This is due to great programming in the ECM from the great state of CA which doesn't see cold weather. The fix: dealership forced the ECM to read correct levels. The real fix shoulda been a software update for the ECM. My real fix was trade in the 2010 and got a 2011. No more problems.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 2
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Silverado 1500 Discussions

Title Updated Last By Comments
2007 Sliverado Transmission Shifting issues (Jan '12) Sat Dustin 46
2003 Chevrolet Silverado - Reduced Engine Power (Nov '07) Fri Gmc413043 527
Transmission taking a long time to shift from f... Mar 23 Bull71 1
Heater AC electrical problem 1995 1500 Chevy (Nov '07) Mar 21 Ron 78
Cabin air filter Mar 18 Mario Perez 1
99 Silverado battery drain on radio fuse (Jan '12) Mar 18 Madmanmp 14
1997 Silverado 4x4 engine upgrade Mar 15 aterseraph 1
More from around the web