Comments
141 - 160 of 447 Comments Last updated Thursday Aug 14
MuNy

Safford, AZ

|
Report Abuse
|
Judge it!
|
#144
Jan 7, 2011
 
I have a 2003 Chevy 1500HD, with the reduced Engine power that happens maybe once a month. I have replaced the throttle positioning sensor, mass air flow sensor and no luck but the engine light turning off, but the problems still occurs. I have not dumped anymore money into it. when the the coder is plugged in it throw 5 different codes and i took care of 2 of the most expensive ones. Next ones were O2 sensors,running lean on bank 1,fuel pressure regulators. I am at a loss here, until I put a checked my fuel pressure and it is reading 52psi just with the ignition on, which is telling me that the fuel pump is only reading 52psi. I have not checked to see if it jumps up or down while someone slams on the gas. Does anyone know what the fuel pump should read without the truck started???? I stopped at Autozone and they looked up what the fuel pump should push and it said 85 AS THE LOW and 100 AS THE HIGH. I am not sure if this is legit. PLEASE HELP!!!
Tim

Belleville, IL

|
Report Abuse
|
Judge it!
|
#145
Jan 10, 2011
 
Did you replace the throttle plate? Mine did it about 15 times a day when it is cold.[20 degrees]
Zumo

Denham Springs, LA

|
Report Abuse
|
Judge it!
|
#146
Jan 11, 2011
 
Rich wrote:
I have a 2003 Chevy silverado HD. I am having idle problems. the truck runs great except for when I come to a stop. When I press the brakes to stop the truck wants to die out. Any suggestions?
I had this problem, check the APP sensor, accelerator positioning senson. Its only about $20
joel Phoenix Az

Phoenix, AZ

|
Report Abuse
|
Judge it!
|
#147
Jan 17, 2011
 
I have a 03 2500HD 4X4 with a 6.6. Ive had this truck for 3 years and never a problem. One day the change oil light came on shortly followed by "reduced engine power" now it wont go over 15mph. I have noticed over the past few months the idle has gotten down to about 500 rpm but ran fine. I'm a struggling Motorcycle Mechanic Institute student 1500 miles away from home and could really use some help. If i disconnect the battery the light goes off and it runs fine for a few days. any ideas???
rob39

AOL

|
Report Abuse
|
Judge it!
|
#148
Jan 24, 2011
 
I have a 2003 silverado and I have had this Reduced Engine Power since about a month after I bought it. It was used and three years old. My truck Starts every time and runs great most of the time. My truck will only give this fault as you are driving down the road. You can be going 30-65 miles and hour. Don't get caught in the fast lane in heavy traffic, because when the reduced engine power comes on, you have no accelleration. You have to coast until you can get over. This is the good part, all you have to do is cut the switch off and waite 10 seconds and it will start back up and run perfect. It may do it several times a day, or it may just do it once evry month. It has did it 11 times withen 65 miles. I have been told it could be Valve body, trottle sensor, wiring, low fluids,and even Low battery voltage ( even though you have an alternator that puts out appox. 14 volts. I have heard of dealerships that have gotten up to three thousand Dollars for repairs and changing parts and still not fix the problem. If we were driving Toyotas, the goverment would make them recall the products, but since its GM, they don't have to. It may sound crazy, but I have well documented these problems and have several witnesses that I loose power on the interstate and I have told my wife and Kids that if I wind up dead from going too slow on the interstate, then make sure to SUE GM.
my name is rick

Cleveland, OH

|
Report Abuse
|
Judge it!
|
#149
Jan 28, 2011
 
Kent wrote:
Had difficulty starting my truck yesterday throughout the day. Towards the end of the day, I had to hold down the gas before the truck would finally start. Received the message, "Reduced Engine Power" and it wouldn't allow me to accelerate over 15 mph (this was all accompanied by my check engine light). Attempted to start the truck again today, same problems (had to hold down the gas to start the truck), minus the "Reduced Engine Power" message. Turned the truck off and immediately restarted without a problem. Allowed it to sit for a while and I was back where I started (my check engine light did not come on today, however, I experienced the same problems from yesterday). It seems to be an electrical problem, as if the message is not getting through to the engine. Anyone else experiencing a similar problem? Any suggestions?
change your crank sensor i went threw the same problem i changed the tps the evap system the wireing harness to the tps the water pump the intake gasket clean the grounds changed the plugs wires had to the dealership twice after i changed the crank sensor it went to the reduce engine power twice and after that i had no problems
my name is rick

Cleveland, OH

|
Report Abuse
|
Judge it!
|
#150
Jan 28, 2011
 
change your crank sensor it fixed my problem make sure the wire plug is good and clean put electric greas on the plug
Gary

Chesapeake, VA

|
Report Abuse
|
Judge it!
|
#151
Feb 2, 2011
 
My 03 GMC 2500 with 6.0 auto- A major problem I found a year ago, after changing battery after battery, was the main ground cable bolt was loose at the block.
Now I am getting the reduced power message and it goes into limp mode. Must restart after 10 seconds to drive again. Anyone found the cause for this?
glkirkbuilders@cox.net
Gary

Chesapeake, VA

|
Report Abuse
|
Judge it!
|
#152
Feb 2, 2011
 
I have a 2003 silverado and I have had this Reduced Engine Power since about a month after I bought it. It was used and three years old. My truck Starts every time and runs great most of the time. My truck will only give this fault as you are driving down the road. You can be going 30-65 miles and hour. Don't get caught in the fast lane in heavy traffic, because when the reduced engi

Rob, did you ever find the cause?
Thanks,
Gary
bodga34

United States

|
Report Abuse
|
Judge it!
|
#153
Feb 2, 2011
 
what you will want to do is check the connector at the throttle body. usually the gray or the yellow like to come apart in the insulation. turn the truck on and wiggle the harness while running if the truck starts to stumble the reduce engine power light has come on and this is where your problem is at. go to dealer and purchase connector and replace one wire at a time so you dont confuse the two gray wires. if this is not your problem then it will be the tac module that sits on the drivers side firewall. you cant miss it. good luck.
chuck illinois

Brooklyn, NY

|
Report Abuse
|
Judge it!
|
#154
Feb 11, 2011
 
i battled the reduced engine power thing for 3 months finally replaced throttle body assembly and this was the fix.
Don

United States

|
Report Abuse
|
Judge it!
|
#155
Feb 15, 2011
 
I had the problem on my used Silverado 2500. My shop kept it for a week. After the facility manager almost got wiped out when the engine went to idle they changed the throttle body and it has been working fin for about a month.
rpm ferris

Montréal, Canada

|
Report Abuse
|
Judge it!
|
#156
Feb 18, 2011
 
Rich wrote:
I have a 2003 Chevy silverado HD. I am having idle problems. the truck runs great except for when I come to a stop. When I press the brakes to stop the truck wants to die out. Any suggestions?
hey man had same problem with my truck. take out little screen right by air box and spray with brake cleaner, there little sensors in the middle. air dry put er back in and u wil be good to go..
mad chevy owner

Tulsa, OK

|
Report Abuse
|
Judge it!
|
#157
Mar 14, 2011
 
I work at a company with a fleet of 1500 -2500 series Chevy trucks. I was a Ford man and switched as we are getting about 300,000 miles out of these Chevy's. Then came a transfer truck with about 70,000miles on it. It is an 06 2500 with the 6.0ltr engine. This truck has been to the dealership as much as it has been on the road. One Mechanic drove it home for three weeks. There is always multiple fault codes when it goes into REP and they go to town replacing everything under the hood. 5-10-2000 miles later in the fast lane and here you are again REP. I say RIP Chevy. It would be more help if the dealer backed the truck they sell!!!!!!!!!!
They want you to get that 60,000 mile flush and clean the injectors, but dealerships dont want to pay mechanics to find problems, they want you to sell services.(bread and butter for parts and labor) I worked as a mech in a dealership and got out of the business for that reason. Great dealership mechanics usually have to use these posts and others to do the research it takes to figure the wonders of engineering that the manufactures produce. Thanks for all the posts and GOOD LUCK.
james

Dearborn, MI

|
Report Abuse
|
Judge it!
|
#158
Mar 25, 2011
 
my prob is "reduced engine power" with the check engine light. A crazy thing that happened was when i shut my 03 silverado off, it keep running with ignition off and no keys. Would it still be the accelerator pedal positioner? I could really use some help. Thanks
james

Dearborn, MI

|
Report Abuse
|
Judge it!
|
#159
Mar 26, 2011
 
where is my tps on my 2003 silverado 5.3l LS 4x4. Thanks for any help.
BigMurph

United States

|
Report Abuse
|
Judge it!
|
#160
Apr 7, 2011
 
I have an 03 Silverado with the REP problem. Its been happening for over a year. I replaced the accelerator pedal position sensor and I went two months without the service engine soon light. Recently I went to the dealership and talked to the service representative. He said to clean the throttle body and if the code comes back, replace the throttle body. He said nine time out of ten, the problem is caused by the throttle body. Two weeks later the REP happened again. From what I have read on this blog, I am hesitant to replace the throttle body. I think I'm going to check the wiring some more.

James, your tps is part of your throttle body, so unfortunately the whole thing would need to be replaced. The throttle body is located on top and on the front of the engine. You will have to take the plastic cover off the top as well as the air intake.
Keith

Estevan, Canada

|
Report Abuse
|
Judge it!
|
#161
Apr 11, 2011
 
I have a friend and he has had the same problem. I told him to clean the throttle body, and gut his cats. He wont gut them, so I said then pop for a new throttle body. He went to a local parts place here, and got a genuine AC Delco new throttle body for 259.00. He says the best money he has spent on his truck. He said the local Dealer wanted over 1,000.00 for the exact same part. Gues thats why they call the dealers, "STEALERS"
Ernie R

Fort Defiance, AZ

|
Report Abuse
|
Judge it!
|
#162
Apr 20, 2011
 
I have the same prob with a 2003 Chevi HD 2500. It mainly happens when we use the heater. Any suggestions?
vicky

Brownsville, TX

|
Report Abuse
|
Judge it!
|
#163
Apr 20, 2011
 
our truck doesnt want to accelerate more than 15 miles and the check engine light turned on and the message on the dash says reduced engine power does anyone know what this means? By the way its a 2006 chevrolet silverado.

Tell me when this thread is updated: (Registration is not required)

Add to my Tracker Send me an email

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Other Recent Chevrolet Silverado 1500 Discussions

Title Updated Last By Comments
Whirring noise from engine (Jan '14) Aug 11 Hypoglycemic 2
2001 Chevy Silverado Transmission (Oct '07) Aug 10 Dale 122
2007 Sliverado Transmission Shifting issues (Jan '12) Jul 30 richard 10
Heater AC electrical problem 1995 1500 Chevy (Nov '07) Jul 27 johm 31
2000 Silverado no tach, speedometer, transmissi... (Jun '09) Jul '14 TimE 18
ignition 0 fuse 2000 silverado 1500 Jun '14 david 1
Brake lights stay on/95 chevy silverado (Jul '10) Jun '14 Bob 8

Search the Chevrolet Silverado 1500 Forum:

Buy a New Car


Zipcode:
•••
Enter and win $5000
•••
•••