scott

Edwardsville, IL

#63 Dec 29, 2009
2003 chevy silverado- check engine light goes on all the time.. it runs fine, yet I can't get it to pass MO emissions testing requirement(s).... Any ideas or suggestions?
scott

Edwardsville, IL

#64 Dec 29, 2009
also- gas gauge and rpm gauges work sporadically at best- is this a common issue?
Matthew Neisler

Pageland, SC

#65 Jan 1, 2010
My 2003 has same problem for a year, reduced engine power and check engine light is on.Two dealerships have tackeled the problem at my expence to the tune of over 3500 dollars.First the harness to the throttle body,worked for a little while.Then the accelerater pedal,and throttle body,still not fixed.Then the O2 sensors and the ECM.Still same problem.Does anyone have a freeking match !!!!
matt

United States

#66 Jan 4, 2010
Rick wrote:
<quoted text> The Dealership found the problem. Mice had chewed some of the insul.off about 8 wires under the fuse box on inner fender which they repaired. They also pulled all wires out of the connectors in the harness' related to throttle and recrimped each wire.Also reinstalled original tps.One of these,or all of them, worked.Took a full day ,but runs great.
How much did the dealership charge you Rick?
matt

United States

#67 Jan 4, 2010
how much did the dealership charge you rick?
kcarr

Fort Worth, TX

#68 Jan 8, 2010
scott wrote:
2003 chevy silverado- check engine light goes on all the time.. it runs fine, yet I can't get it to pass MO emissions testing requirement(s).... Any ideas or suggestions?
Thats generally an O2 Sensor. Cheap fix, but I think you will still have to reset the codes if the light doesnt go out after you replace it.
Drake

United States

#69 Jan 14, 2010
Thanks for the post i'll try that, my truck is running really rough when stopped or at idle. I was hoping it was not an expensive problem to fix.
smitty

San Antonio, TX

#70 Jan 20, 2010
i had "reduced engine power" light and only able to idle along. had to replace throttle body TPS and the wiring harness pigtail to the TPS. wiring bundle had rubbed thru insulation and shorted out.
tinaz71

Fort Smith, AR

#71 Jan 20, 2010
how did you fix the problems
Kent wrote:
Had difficulty starting my truck yesterday throughout the day. Towards the end of the day, I had to hold down the gas before the truck would finally start. Received the message, "Reduced Engine Power" and it wouldn't allow me to accelerate over 15 mph (this was all accompanied by my check engine light). Attempted to start the truck again today, same problems (had to hold down the gas to start the truck), minus the "Reduced Engine Power" message. Turned the truck off and immediately restarted without a problem. Allowed it to sit for a while and I was back where I started (my check engine light did not come on today, however, I experienced the same problems from yesterday). It seems to be an electrical problem, as if the message is not getting through to the engine. Anyone else experiencing a similar problem? Any suggestions?
tinaz71

Fort Smith, AR

#72 Jan 20, 2010
What did you have to end up doing ? desides getting rid of the truckm ?
Matthew Neisler wrote:
My 2003 has same problem for a year, reduced engine power and check engine light is on.Two dealerships have tackeled the problem at my expence to the tune of over 3500 dollars.First the harness to the throttle body,worked for a little while.Then the accelerater pedal,and throttle body,still not fixed.Then the O2 sensors and the ECM.Still same problem.Does anyone have a freeking match !!!!
rdd

Saint Paul, MN

#73 Jan 28, 2010
just replaced battery and altenator, still doing it, mechanic said the computer takes time to re idle itself? any thought on this?
Kim

United States

#74 Feb 2, 2010
Just spent 1000 dollars on a 2003 Chevy Silverado SS. One dealership so called fixed the "engine power reduced" problem, then two weeks later light came on again. Took it to another Chevy dealership and they said the other dealership wired the truck wrong and something dealing with the throttle. This dealersip so called fixed the problem. Well exactly a week later same problem. But I do have to take the truck back due to a catalytic converter is damaged. They had to order the part and luckily this is under warranty. Do anyone knows exactly what is causing this problem?
tony

Bowling Green, KY

#75 Feb 3, 2010
Kent wrote:
Had difficulty starting my truck yesterday throughout the day. Towards the end of the day, I had to hold down the gas before the truck would finally start. Received the message, "Reduced Engine Power" and it wouldn't allow me to accelerate over 15 mph (this was all accompanied by my check engine light). Attempted to start the truck again today, same problems (had to hold down the gas to start the truck), minus the "Reduced Engine Power" message. Turned the truck off and immediately restarted without a problem. Allowed it to sit for a while and I was back where I started (my check engine light did not come on today, however, I experienced the same problems from yesterday). It seems to be an electrical problem, as if the message is not getting through to the engine. Anyone else experiencing a similar problem? Any suggestions?
I am having the same problem. Was told it is a "gas pedal sensor". However, I keep pressing the gas pedal when it happens so I can get to where I am going. My mechanic cannot diagnose the problem unless my check engine light is on. So unless it happens near a mechanic, and I have no place to be, it will take some luck before I can get it fixed. Ironic, Toyota can't get their gas pedals to stop accelerating, and Chevy cant get theirs to accelerate.
tony

Bowling Green, KY

#76 Feb 3, 2010
I am having the same problem. Was told it is a "gas pedal sensor". However, I keep pressing the gas pedal when it happens so I can get to where I am going. My mechanic cannot diagnose the problem unless my check engine light is on. So unless it happens near a mechanic, and I have no place to be, it will take some luck before I can get it fixed. Ironic, Toyota can't get their gas pedals to stop accelerating, and Chevy cant get theirs to accelerate.
woo

Fort Macleod, Canada

#77 Feb 9, 2010
try chargeing your batt
Nancy

Reno, NV

#78 Feb 11, 2010
Rich wrote:
I have a 2003 Chevy silverado HD. I am having idle problems. the truck runs great except for when I come to a stop. When I press the brakes to stop the truck wants to die out. Any suggestions?
My son is having the same trouble and his lights dim a bit when slowing down. When he stops and turns his ignition off often the automatic doors won't unlock. It's like there isn't enough power when not accelorating. We have replaced the alternator and battery. He too has a 2003 HD. Did you ever find out what was causing it to stahl out?
Bass it up

United States

#79 Feb 13, 2010
Rich wrote:
I have a 2003 Chevy silverado HD. I am having idle problems. the truck runs great except for when I come to a stop. When I press the brakes to stop the truck wants to die out. Any suggestions?
I had the same problem. You need to get your fuel injection cleaned. I had replaced my battery, and when i did it wouln't idle but for a second and cut off. Took it to my mechanic and he told me that's what it was.
Steve Smith

Victor, MT

#80 Feb 27, 2010
Reduced engine power light comes on when 1 quart low on oil
shawn

Union City, CA

#81 Mar 2, 2010
Kent wrote:
Had difficulty starting my truck yesterday throughout the day. Towards the end of the day, I had to hold down the gas before the truck would finally start. Received the message, "Reduced Engine Power" and it wouldn't allow me to accelerate over 15 mph (this was all accompanied by my check engine light). Attempted to start the truck again today, same problems (had to hold down the gas to start the truck), minus the "Reduced Engine Power" message. Turned the truck off and immediately restarted without a problem. Allowed it to sit for a while and I was back where I started (my check engine light did not come on today, however, I experienced the same problems from yesterday). It seems to be an electrical problem, as if the message is not getting through to the engine. Anyone else experiencing a similar problem? Any suggestions?
Clean the throttle body - see utube video on how to clean it
kajunwolf

United States

#82 Mar 4, 2010
We live in the country about 20 miles from town. I drove into town to pick up a few groceries. I did my shopping and came out to my truck. When I started it I noticed the check engine light on and then had a message that read "reduced engine power". Truck would not go over 40mph. I made it home, barely. It would drop down to 15mph going up hills. I got on here looking up possible causes. The next morning I started checking different things. I checked the wiring, the connector on the firewall next to the steering column, the oil level, disconnected the neg. battery cable, checked the voltage which was ok. I was running low on gas so I got the gas can out and added some gas. When I undid the gas cap I noticed the cap was not tight. When I put the cap back on I tightened it untill it clicked. I reconnected the battery cable and started the truck. The check engine light went off and the reduced power message was gone. I drove the truck, had to take my daughter a couple of places and the truck did fine. I don't know if the gas cap not being tight was the cause but that is the only thing I did. I know my daughter did not tighten the cap on her jeep and the check engine light came on and although it did not loose power it ran real rough.Had a code scanner check done it it showed a low fuel vapor leak. Tightened the cap on it till it clicked and it started working fine. Check your gas cap and see if that cures it. I don't know if that was the cause but I have not had any more problems with either vehicle. Hope this helps.My truck is a 2003 1500 Silverado with a 4.8 engine

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Silverado 1500 Discussions

Title Updated Last By Comments
2001 Chevy Silverado Transmission (Oct '07) 58 min rob 132
2000 Silverado no tach, speedometer, transmissi... (Jun '09) May 1 Haleyraee 27
2008 Silverado Battery Goes Dead (Oct '09) Apr 29 john r 118
Heater AC electrical problem 1995 1500 Chevy (Nov '07) Apr 26 sperez 38
Backup Camera Install (May '07) Apr 23 liamalecn 29
Tires Apr 10 Mike 1
Suspension problem silverado 2013 Apr 8 Jee3jr 1
More from around the web