2003 Chevrolet Silverado - Reduced En...

2003 Chevrolet Silverado - Reduced Engine Power

First Prev
of 28
Next Last
Kent

Philadelphia, PA

#1 Nov 3, 2007
Had difficulty starting my truck yesterday throughout the day. Towards the end of the day, I had to hold down the gas before the truck would finally start. Received the message, "Reduced Engine Power" and it wouldn't allow me to accelerate over 15 mph (this was all accompanied by my check engine light). Attempted to start the truck again today, same problems (had to hold down the gas to start the truck), minus the "Reduced Engine Power" message. Turned the truck off and immediately restarted without a problem. Allowed it to sit for a while and I was back where I started (my check engine light did not come on today, however, I experienced the same problems from yesterday). It seems to be an electrical problem, as if the message is not getting through to the engine. Anyone else experiencing a similar problem? Any suggestions?
jake

Doylestown, PA

#2 Nov 17, 2007
ck ur engine coolant level

Judged:

45

22

1

Reply »
Report Abuse Judge it!
Scott

Schuylkill Haven, PA

#3 Nov 19, 2007
I have the same year truck and am having the very same problem -- coolant level is fine --- any other suggestions?
Scott

Schuylkill Haven, PA

#4 Nov 21, 2007
Just wanted to let you guys know that dealership found problem with my truck this am.
It was gas pedal --- accelerator position sensor --- app. older model trucks have cables and the newer ones have gone to electronic (computer parts)

Judged:

121

70

1

Reply »
Report Abuse Judge it!
kristy

Conroe, TX

#5 Oct 11, 2008
Scott wrote:
Just wanted to let you guys know that dealership found problem with my truck this am.
It was gas pedal --- accelerator position sensor --- app. older model trucks have cables and the newer ones have gone to electronic (computer parts)
Hello, my name is Kristy, and I was curious to see how you were able to fix the problem with this situation. My father has a 2500 HD Silverado 2003 model. He is experiencing the same thing with with his "reduce engine power" light coming on. If you would please help us out with this delima we are having. thank you so much!

Judged:

725

50

1

Reply »
Report Abuse Judge it!
kristy

Conroe, TX

#6 Oct 11, 2008
Hello, my name Is Kristy, and I am curious to see how you were able to resolve this problem with your truck. My father has a 2500 HD Silverado, 2003 model. He is experiencing the same thing with his "reduce engine power" light coming on. If you would, please help us out with this delima we are having. Thank you so much!!!
sick of it

Tiffin, OH

#7 Oct 14, 2008
been 3 years with my camaro, summers are fine but when it gets the slightetst cold out I try to start my car the reduced engine power fucking light comes on. It drives me insane i have to waste gas, to let it warm up, i ll fire it back up and its fine rest of the day???? its so frustrating i about burnt my car

Judged:

68

19

1

Reply »
Report Abuse Judge it!
sick of it

Tiffin, OH

#8 Oct 14, 2008
[email protected] if anybody has any suggestions, i heard Diagnostics, clamps for wires, anything I really need help its driving me nuts, my dad knows about cars, we even took it to the mechanic, its like my damn car is Christine
xlr8nxs

Overland Park, KS

#9 Oct 19, 2008
Kent wrote:
Had difficulty starting my truck yesterday throughout the day. Towards the end of the day, I had to hold down the gas before the truck would finally start. Received the message, "Reduced Engine Power" and it wouldn't allow me to accelerate over 15 mph (this was all accompanied by my check engine light). Attempted to start the truck again today, same problems (had to hold down the gas to start the truck), minus the "Reduced Engine Power" message. Turned the truck off and immediately restarted without a problem. Allowed it to sit for a while and I was back where I started (my check engine light did not come on today, however, I experienced the same problems from yesterday). It seems to be an electrical problem, as if the message is not getting through to the engine. Anyone else experiencing a similar problem? Any suggestions?
Just Friday my 2004 Silverado 1500 had the check engine light come on. The next day I decided to check fluids, etc. when I was checking some of the electrical plugs, the one on the left of the module located in the upper drivers side of the firewall inside the engine compartment was not fully plugged in. when it connected the engine speed dropped slightly and I looked at the dash to see the check engine light was still on and the message center read, "reduced engine power". Only after disconnecting the battery and disconnecting and re-connecting the plug in connector, then re-connecting the battery would the check engine light go out. Tried it on my dad's 2006 Silverado and had the same results. The power has to be disconnected before plugging the plug back in to get rid of the check engine light. Hope this helps.
kyle

Mcallen, TX

#10 Oct 20, 2008
so i needed to get an oil change roughly 10k miles ago, and now my truck has been slow to crank up lately and then today the reduced engine power warning came on. is this from the oil or the battery or both?
helen

Saint Paul, MN

#11 Nov 25, 2008
truck says low engine power what doe sthis mean
chicadee2

Princeton, WV

#12 Dec 10, 2008
Scott wrote:
Just wanted to let you guys know that dealership found problem with my truck this am.
It was gas pedal --- accelerator position sensor --- app. older model trucks have cables and the newer ones have gone to electronic (computer parts)
did youre truck not give any codes at all and did youre climate controls kill the engine and did youre gauges work
jordan

West Palm Beach, FL

#13 Dec 14, 2008
have same prob reduce engine power can some one help me please 2006 1500 i am stuck and low funds write now dose any one n o what to do
Rich

Florence, AZ

#14 Dec 18, 2008
I have a 2003 Chevy silverado HD. I am having idle problems. the truck runs great except for when I come to a stop. When I press the brakes to stop the truck wants to die out. Any suggestions?
Rick

AOL

#15 Dec 22, 2008
I have an 03 HD and am having the reduced engine power problem. My mech. said to replace gas pedal throttle pos. sensor, i did and no luck. Next he put his diagnostic comp on it and it said to replace throttle-body TPS (expensive!) No luck. I was letting it warm up to op. temp before leaving, and that seemed to work,for a while. But now it will do it 3 and 4 times a trip. Also sometimes its sluggish and has a little hesitation at 50 to 60 mph. Kind of hard to plow snow w/ this POS!
mikec

Utica, KY

#16 Jan 9, 2009
I have a battrey drain. when it started I could pull my sirus power out of aux power & turn off the radio and it would start ok. now I can't start it after shuting it off for a couple hours. also the drivers side door speaker & door alarm go in&out together.(mostly out I almost never heard them) but I did not miss the alarm so I let it go and didnt think much of it until all this started happning. I have pulled fuses for the radio,radio amp,blower,aux outlet,lighter,sun roof,info,stud#2,aux power2. I have only jump started it. do I need to recharge the battery before I can expect any results. any help would be greatly appreciated. I do construction and am currenly unemployed and this devil truck is the only way I can make money. and I'm so sick of jump starting it.
brian

United States

#17 Jan 16, 2009
kristy wrote:
Hello, my name Is Kristy, and I am curious to see how you were able to resolve this problem with your truck. My father has a 2500 HD Silverado, 2003 model. He is experiencing the same thing with his "reduce engine power" light coming on. If you would, please help us out with this delima we are having. Thank you so much!!!
i had the same problem with the same type truck and it ended up being the THROTTLE BODY being replaced, works fine now.
Rick

AOL

#18 Jan 28, 2009
Rick wrote:
I have an 03 HD and am having the reduced engine power problem. My mech. said to replace gas pedal throttle pos. sensor, i did and no luck. Next he put his diagnostic comp on it and it said to replace throttle-body TPS (expensive!) No luck. I was letting it warm up to op. temp before leaving, and that seemed to work,for a while. But now it will do it 3 and 4 times a trip. Also sometimes its sluggish and has a little hesitation at 50 to 60 mph. Kind of hard to plow snow w/ this POS!
The Dealership found the problem. Mice had chewed some of the insul.off about 8 wires under the fuse box on inner fender which they repaired. They also pulled all wires out of the connectors in the harness' related to throttle and recrimped each wire.Also reinstalled original tps.One of these,or all of them, worked.Took a full day ,but runs great.
Frank Ontario Canada

Port Elgin, Canada

#19 Jan 31, 2009
I have a 2003 silverado HD with an 8.1 L I have a problem with it going to reduce engine power I put an OBD reader on and it comes up with a code of either 120 which tells me it is the throttle pedal position sensor or 2135 which tells me it is the throttle body position sensor a- b corelation I replaced the throttle body with new one because you cant find a used one which was an expesive little touch. No luck I then replaced the accelerator pedal with a used one and this didn't work either. When a person gets to witts end I'm not sure which way you go. I would sure be gratefull and welcome any advice anyone has on this topic I'm quite sure I am not the only one who's had this problem Thanks in advance for any advice Frank
throttle body

Matthews, NC

#20 Feb 5, 2009
i had same problem reduced engine problem, tps code on computer. took to dealer ship they cleaned the throttle body, reprogramed. truck works great now with even better gas milage.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 28
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Silverado 1500 Discussions

Title Updated Last By Comments
Interior Fan quit working on speed 1 and 2 (Nov '07) Dec 13 Jason 37
redline edition Dec 9 TWA 1
2010 Rough idle, no engine light or codes (Aug '10) Dec 4 electrickid 44
Vibration when braking but not caused by rotors Nov 28 Marco 1
2006 Silverado 1500 4.8Ltr V-8 - Radiator cooli... Nov '17 tbcrane0274 1
2007 Sliverado Transmission Shifting issues (Jan '12) Oct '17 John Duwel 56
94 Cheyenne 1500 4.3 liter Oct '17 Chrism 1
More from around the web