2000 S10 Fuel Problems
First Prev
of 8
Next Last
John

Davis, WV

#1 Nov 15, 2008
Ok my 2000 s10 has no fuel pressure...so i changed the fuel filter,then checked the relay,then changed the pump and still nothing. So i have read the the hayes repair manual about if the oil pressure switch is bad it will shut off power to the fuel pump...my only probelm is i have no idea where the oil pressure switch is...any one have any idea where it is located....its a 2000 s10 with a 4.3l. also someone has told me about a safety switch that cuts the power to the fuel pump if the truck is in a accident....any ideas if this is true and if so where would it be located....thanks for any help.
rick

Hartsville, SC

#2 Jan 11, 2009
fuel pump not working on my 2000 s10 replaced pump, filter,& relay nothing. help please
rick

Hartsville, SC

#3 Jan 11, 2009
check your chassis grounds
koa

United States

#4 Jan 12, 2009
the oil pressure sensor is located near the distributor it is a longated tube shaped device near or next to the distributor but i beleive the problem might be a fuse i have a 2001 p/u and the problem was the ECM fuse blew it is located under the hood it was a blue-15- for me look into it before you buy the oil pressure switch. oh and there isnt a fuel inertia shutoff switch
Jeremy

Saint Helens, OR

#5 Feb 2, 2009
I have a 2000 Jimmy with no pressure, done all the same things, but I can here my pump. Anyone know why no pressure?
Shawn

Wichita, KS

#6 Feb 3, 2009
jeremy, it could be a weak pump or gummed up lines
Dean

Goshen, CA

#7 Mar 18, 2009
2000 S10 with low start up fuel pressure. Cranks but wont start without spraying quick start???

Im thinking fuel pressure regulator. What is more common, Fuel pump/pressure regulator assembly or fuel pressure reulator in the engine compartment?

Dont want to pull the top of the engine apart but dont want to waste money on the fuel pump assembly.

Thanks in advance
steve

Willingboro, NJ

#8 Jun 15, 2009
where is a fuel pressure relay on a 2000 s10 . I put in a new pump and there is no power to it . not even for a second so I don't think it is the oil pressure
swampy54

Saint Augustine, FL

#9 Jul 18, 2010
i have a 2000 s10 4.3 130 000 miles the engine stalls when going at slow speeds but starts up fine i was thinking fuel pump but also thought it would do the same thing at high speeds if thats the case it has to be electric right ? any help or pointers
Towfieee

Vancouver, WA

#10 Feb 4, 2011
Chassis Ground <====== if you removed the bed to get to fuel tank

I ran into the same problem and solved it. To replace the fuel pump I had to remove the bed since the fuel tank is under it. I had to disconnect the tail light wires including the ground wires. One side had 1 grounding wire and the other had 2 grounding wires. After a month of messing around with fuses and sensors I found out that one of the (Two ground wires) next to the left tail light was actually the (Fuel pump ground wire). So if you don't know which one I am talking about, make sure you connect ALL the tail light wires and plugs before cranking up the engine. This was my luck with the s10 2001 and good luck to you :)
2000 chevy S10 4 cyc 22

Orland Park, IL

#11 Mar 15, 2011
Trying to get the check engine light off I change the fuel pump the knock sensor fuel pump sensor and I still get the P0325 code comes up the car seems like there not much gas going to the engine. the other thing said low fuel pressure. can anyone help
Thanks
Bob

Judged:

21

14

1

Reply »
Report Abuse Judge it!
marinesdad1

Wooster, OH

#12 Mar 26, 2011
i have a 2000 chevy s-10 and the fuel gauge will show full one time and the next it will show empty any ideas if this may be the ground wire or a relay
2000 chevy S10 4 cyc 22

Orland Park, IL

#13 Mar 26, 2011
it sound like the fuel pump flot is stuck witch is in the gas tank made need new pump I bought my from ebay new works great and only paid $65.00 for it autozone whats $350 hope this helps

Thanks
Bob
northamerica

Honeoye Falls, NY

#14 Mar 26, 2011
have 200 s10 2.2 hard starting only when it sits once started it will start right up when it sits for a while i have to charge fuel pump a bunch of times and it will start. put new fuel pump and complete tune up and fuel filter on it still same problem.any ideas.thanks
Topher

United States

#15 Apr 6, 2011
Towfieee wrote:
Chassis Ground <====== if you removed the bed to get to fuel tank
I ran into the same problem and solved it. To replace the fuel pump I had to remove the bed since the fuel tank is under it. I had to disconnect the tail light wires including the ground wires. One side had 1 grounding wire and the other had 2 grounding wires. After a month of messing around with fuses and sensors I found out that one of the (Two ground wires) next to the left tail light was actually the (Fuel pump ground wire). So if you don't know which one I am talking about, make sure you connect ALL the tail light wires and plugs before cranking up the engine. This was my luck with the s10 2001 and good luck to you :)
Really glad I found your post as this was my exact problem and the second I hooked up the ground- everything worked!
patty

AOL

#16 Apr 27, 2011
hi i took my grandson to preschool and was comming back home truck ran fine takeing him there and when i got to the road we live on it died and would not start back need help he also put a onother fuel pump in it and still wont start and it dont kick on please need help

Judged:

16

10

1

Reply »
Report Abuse Judge it!
patty

Pineville, KY

#17 Apr 27, 2011
fuel pump wont kick on gas gauge wont move after 12$ in gas took bed off to get to fuel pump replaced fuel pump hooked up ground on driver side rear still nothing switched fuel pump relay with ac relay still nothing please help bed is still off my truck
cody

Wooster, OH

#18 Apr 30, 2011
I have a 200 s-10 had the fuel pump out they did not change the seal on it it now leaks when i fill it up is it safe to drive till i can change it
Manuel

Ribera, NM

#19 May 1, 2011
Jeremy wrote:
I have a 2000 Jimmy with no pressure, done all the same things, but I can here my pump. Anyone know why no pressure?
where are the fuel relays on a 2001 chevy s-10
Manuel

Ribera, NM

#20 May 1, 2011
where are the fuel relays on a 2001 chevy s-10

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 8
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet S-10 Discussions

Title Updated Last By Comments
S10 running problems 14 hr Joe SFord 1
98 S10 Wont Start HELP!!! (Feb '09) Aug 17 circuttracer 111
plug firment issue 2001 chevy s10 4.3 Aug 17 circuttracer 1
Wont start, dead sometimes Aug 17 dustyriver 1
1992 2.2l 5-speed no crank but will run Aug 17 bennettboy 1
correct spark plug gap settings for 1999 s10 4 ... (May '09) Aug 13 Mark 3
running out of options Aug 4 Jeff Reams 1
More from around the web