1990 s10 4x4 4.3 tbi fuel too rich; s...

1990 s10 4x4 4.3 tbi fuel too rich; stalls; rough idle

Posted in the Chevrolet S-10 Forum

TIM

Regina, Canada

#1 Dec 28, 2009
Anyone help?
Almost 300K km original powertrain and all electronics, except of course rotor, plugs, wires,
Smells rich-running (gas) outside anywhere !
I did see the EGR Valve problem posts but not sure there yet.
Key giveaway is that after stalling, even if warm (not a weather issue), must wait 10-20 minutes before it will restart, because even tho it's turning over, it just won't start before it's time!
Was told that TBI= primitive and that there's some kind of worn(out?) seals inside the throat where gasfuel leaks past injectors into intake manifold, and injectors can't meter this, so get a choking rich ratio?
Gastank fuel pump also original.
Can anyone give me details??
THX.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet S-10 Discussions

Title Updated Last By Comments
'82 s10 engine sputtering at startup/low RPMs/a... 9 hr SakeJams 1
headache Sat spencertracy211 1
2000 S10 Fuel Problems (Nov '08) Fri tonifernandez 151
4.3 - 5.3LS swap Fri DrakeD 1
running lights and brake lights blown after hoo... Sep 23 teeatpbi 1
balance shaft 4.3 engine Sep 21 thx569 1
2004 blazer Sep 20 cvt89 3
More from around the web