2001zr2 s10 4.3 runs but quits instai...

2001zr2 s10 4.3 runs but quits instaintly

Posted in the Chevrolet S-10 Forum

Neil

United States

#1 Sep 8, 2012
pump sounds good, newer plugs, wires,fuel,air filters fuses good. runs for a few secounds then quits.
John

Norcross, GA

#2 Oct 5, 2013
Yea, I'm having the same problem on my 98 Sonoma,changed cap & rotor, cam sensor cleaned all grounds,still won't start let me know if you
find problem.
lscialabba

El Cajon, CA

#3 Sep 22, 2014
98 chevy S-10, my truck did the same thing, it would start then immediately die. Took it to several repair shops with no luck then to dealer still no luck, finally went to a website and discovered it was due to the security system. Only fix was to purchase a module that would bypass the security sysem upon starting. Once it was installed, I never had the problem again

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet S-10 Discussions

Title Updated Last By Comments
2000 S10 Fuel Problems (Nov '08) 21 hr flip 146
98 s10 wont start Jun 17 Mkrause 1
1989 Chevy S10 pickup extended cab 4.3 wont start Jun 17 Justsusie27 1
s-10 2003 Jun 14 Vinny 1
99 s10 key won't turn ignition (Jun '08) Jun 14 Adrian 14
94 Chevy s10 won't start Jun 12 Dvpool 1
1997 S10 starter removal (Mar '07) Jun 9 joel 23
More from around the web