Comments
121 - 140 of 550 Comments Last updated Yesterday
Ian poteet

North Vernon, IN

|
Report Abuse
|
Judge it!
|
#122
Oct 19, 2011
 
Ok people I need help bad my truck has been giving me so many problems its misses while cold or it could be a lack of fuel I cant tell ive replaced everthing pretty much and went to 9 diff mechanics no one can help me.1992 chevy 1500 4.3 vortec Alright when I first start it in the morning it will sputter or miss I can flip my key on and off real quick and it usally smooths it out takes a few times now after it warms up it wont sputter or miss unless I lay on the throttle and it wont go no where and it will have a studdering sound. Now ive replace the tps,map sensor,o2 sensore, temp sending unite for the computer and gauge,iac valve,even a new throttle body gasket,plugs wires cap and rotor,fuel filter, oil change and filter. Even ran 2 bottles of sea foam through it also replaced and checked all my vacume line and also checked the egr. Now I cant get my fuel pressure check because I dont have the valve on my throttle body and no one has a T pressure tester plz if any one can help me plz email me at ramseykid91@yahoo.com with chevy as the title ill keep checking up on here thx for ur alls time
Ian poteet

North Vernon, IN

|
Report Abuse
|
Judge it!
|
#123
Oct 19, 2011
 
Also got it timed solved a bogging down issue I was having and it idles fine sometimes surges while its cold
cole

Marquette, MI

|
Report Abuse
|
Judge it!
|
#124
Oct 19, 2011
 
i have a 1996 silverado w a 5.7 vortec it has a hard time strating up in the moring, sometimes it will die imeaditly or it will run about 2,000 rpm then steadly make its way down to 500 rpm n slightly spit and sputter. it drives great when i mat it form a dead stop, i have just put a new cap roader, stributer, plugs, wires fuel pump and fuel filter on it. when i drive down the road at some times usualy 1500 rpm at 65 it will suddinly miss and die down then pick back up like nothing happend. anyone got any problems like that they know about?
cole

Marquette, MI

|
Report Abuse
|
Judge it!
|
#125
Oct 19, 2011
 
i have a 96 silverado with a 5.7 new cap roader plugs wires and distrubuter, it has a hard time starting up i have to put it in neutrial to start up somewhat fine, it sputters when im at 1700 rpms at 65 going donw the highway anyone have any ideas for whats goin wrong
Freddie

Porterville, CA

|
Report Abuse
|
Judge it!
|
#126
Oct 21, 2011
 
I found my problem the fuel pump strainer was clogged so I went to orileys and bought a new strainer $10 solved my problem
Ian poteet

North Vernon, IN

|
Report Abuse
|
Judge it!
|
#127
Oct 22, 2011
 
So the strainer u think is just dirty
Freddie

Porterville, CA

|
Report Abuse
|
Judge it!
|
#128
Oct 22, 2011
 
Yeah that was my problem but it could a number of different things that can cause it I'm not sure if you can clean the strainer or not but if not they are only $10 for a regular one and 15 for a high temp one
Ian poteet

Crestwood, KY

|
Report Abuse
|
Judge it!
|
#129
Oct 22, 2011
 
Yea imma try that and the fuel regulator thx for,the help
Joe m

Hiram, GA

|
Report Abuse
|
Judge it!
|
#130
Oct 23, 2011
 
Need a little help. My 1994 chevy silverado starts up just fine, idle is good and runs well until it warms up good. Once it warms up it starts sputtering and popping while I am driving down the road. I can then pull Over and it will idle smoothly, maybe a bit low, but smooth. Any ideas?
DAryl

United States

|
Report Abuse
|
Judge it!
|
#131
Nov 5, 2011
 
I have a 94z71 350 it has no problem idling. Its when driving it seems to have bad gas spitting and sputtering but always goes back to perfect idle can anyone help
bowhunter354atgm ail

Ringgold, GA

|
Report Abuse
|
Judge it!
|
#132
Nov 6, 2011
 
terry wrote:
i have a 1994 chevy silverado 4x4 3/4 ton with 5.7L.the truck is not running right it idles around 4oo when in gear and sometimes it acts like it is not getting any gas and almost dies then it picks back up in idle to 800rpms then it will drop back to 400rpms.it is sometimes sluggish when taking off.it usually almost dies when you let off gas when slowing down to stop.can anybody help me figure this out.would appreciate any help.
did you or anyone ever find out what caused this having same problem and have changed iac,temp sensor ,pcm still surges at idle when cold rev it a couple of time then idles fine but has no acceleration if anyone can help with this problem would be very thankful
bowhunter354atgm ail

Ringgold, GA

|
Report Abuse
|
Judge it!
|
#133
Nov 6, 2011
 
and my truck is a 92 c1500 350
Mike

United States

|
Report Abuse
|
Judge it!
|
#134
Nov 10, 2011
 
I have a 92 suburban that is idleing funny and not getting the power on take off. I have changed plugs wires cap rotor and coil. Is their a sensor or something that could be causing it?
Remy

Houston, TX

|
Report Abuse
|
Judge it!
|
#135
Nov 13, 2011
 
Got a '94 K1500 4.3 V6 with 5spd. Has 90k miles, all original. Recent tune up, new fuel filter, air filter, plugs, wires, cap, rotor. Truck starts up, runs fine, and idles smooth. It usually drives just great down the highway, but lately it has been surging and bucking while driving on the highway. Sometimes I'll put the hammer down, and nothing happens. It's gulping more fuel than normal. Sometimes the "SES" light comes on, sometimes it doesn't. The code is a 44 (o2 sensor). I've cleaned all electrical connectors, grounds, plugs, checked for vacuum leaks, etc. I have a new o2 sensor but haven't installed it because the old one is pretty well stuck on the exhaust. I'm going to go to a friends muffler shop to replace the catalytic converter and install the new o2 sensor with a new bung on the Y-pipe. If this doesn't fix the cruise-speed bucking/low power issue, what should I look for next?
Ghern

United States

|
Report Abuse
|
Judge it!
|
#136
Nov 14, 2011
 
About to buy a 92 z-71 2500. Current owner says it idles fine and drives good, but when you step on it, she bogs a little. He says it only just started to do it. Talking to a buddy of mine, he says the throttle body needs to be adjusted... Anyone have an expert opinion?
wes

United States

|
Report Abuse
|
Judge it!
|
#137
Nov 17, 2011
 
i have a 94 chevy 1500 ext.cab 4x4 runs great but low oil pressure. When im runnin 2000 rpm or better shes at 40. But when im stoped or coasting she drops to bout 15 and the check guages light comes on. Think its the oil pump but wanna kno for sure before i do anything
Solution for 94 silverado

Gary, IN

|
Report Abuse
|
Judge it!
|
#138
Nov 17, 2011
 
hey guys, i am new in this and my english is not very good but i will give it a try. i have a 94 chevy with a 5.7 TBI and i had the same problem with my truck backfiring, not power vibration and it seems that happen when the truck was worm. i try everything that you could think. CTS, TPS, Plugs, wire plugs, Oxigen Sensor and all the other things you guys had try and it didnt work. well one day i was checking aroung the engine with the engine running and i moved the wire that goes to the CTS and the engine shut off! I try to stated again and it didnt, so i went and moved some of the cables on the top of the intake and i found that the ground cable in top of the intake was loose so i tighted and walaa! it fixed the problem! no more backfiring, power is back and not more vibration! I hope it help some of you guys and let me know if it does.
alejandro

United States

|
Report Abuse
|
Judge it!
|
#139
Nov 20, 2011
 
I have a 94 silverado 5.7 350 TBI engine and original transmission i want a new engine that is feul injected...what engine will work with same transmission??
David

United States

|
Report Abuse
|
Judge it!
|
#140
Nov 23, 2011
 
Anyone can tell me what's the size of the gear has my silverado 94 ext cab,1500 4x2, 5.7 tbi original
David

United States

|
Report Abuse
|
Judge it!
|
#141
Nov 23, 2011
 
Alguien puede decirme q diferencial tiene mi troca chevy 1500 cabina y media,q paso tienen original por favor,agradecere la respuesta

Tell me when this thread is updated: (Registration is not required)

Add to my Tracker Send me an email

Type in your comments below
Name
(appears on your post)
Comments
Characters left: 4000
Type the numbers you see in the image on the right:

Please note by clicking on "Post Comment" you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

9 Users are viewing the Chevrolet Pickup Truck Forum right now

Search the Chevrolet Pickup Truck Forum:
Title Updated Last By Comments
92 Chevy 5.7 loses power and sputters Jul 20 LDSpears 1
fuel pump Jul 12 danaman 1
Chevy s 10 2002 v 6 Jun '14 Grace McMaster 2
1996 Chevy 1500 May '14 Chris 1
1993 chevy 2500 4x4 fuel gage problems May '14 tattoo rick 2
1994 Chevy Pickup 5.7L idles fine but sputters ... (Feb '13) Apr '14 Anthony 2
1994 chevy 1500 z71 5.7L (Mar '13) Apr '14 Sergio 8
•••

Buy a New Car


Zipcode:
•••
Enter and win $5000
•••
•••