2000 Impala stalling issue
First Prev
of 6
Next Last
Terry - Long Island

Brooklyn, NY

#1 Oct 7, 2008
Hi, my 2000 Impala intermittently stalls while driving. I have had it to the shop and nothing shows on the computer. It only happens every few days and usually the car starts back up within a minute. Does anyone have a possibility what this could be? It's driving me nuts. Thanks for any help in advance.
Matt

Folsom, CA

#2 Nov 17, 2008
Im actually having the same problem right now. Cars in the shop with a really good chevy mechanic so I'll let you know the results.
JQuack

Delavan, WI

#3 Jan 16, 2009
I have a 2000 LS that does the same thing. Sometimes starts right away, sometimes takes 3 maybe 4 tries. Mine even dies when driving under normal comditions, but never over 35 mph. Really becomes dangerous when your wife is turning a corner and the car dies. That means no power steering!! Please inform me of any updates you might have heard of. I have heard everything from Crank Positioning Sensor, to fuel pump relay. I can't afford to put $1000's without results.
eli

El Paso, TX

#4 Jan 25, 2009
it can be the crankshaft sencer. It is located behind the balancer. It was a pain to fix. My wife and kids were in the car on the highway and it stopped running. This is bad do not drive the car until this is fixed.
Im-pal

Calgary, Canada

#5 Feb 7, 2009
I agree its crank position sensor fault.
jennifer

Miamisburg, OH

#6 Feb 8, 2009
Engine Performance problem
2000 Chevy Impala 6 cyl Front Wheel Drive Automatic

My Impala is acting like it's not getting enough gas even with a full tank, when I start the car it spit and sputers, I need to pump the gas peddle then hold the idle high to keep it running, then it will act fine for a few but after i start to drive it will act as tho i'm running out of gas , even the gas gauge will read as empty.. what can be wrong with this thing ??? We have replaced the gas filter and put a gas anitfreeze in the gas. would it act like this if the fuel pump was going bad??
Im-pal

Calgary, Canada

#7 Feb 11, 2009
catalytic converter probably plugged. Its easy for shop to check. They are expensive ~$750. Or eliminate it and live with the resulting engine SES light and hope you don't get caught without it.
Pod at impala

Saint Paul, MN

#8 May 25, 2009
Our 2000Impala has been acting up(stalling after warm) seams possible fuel pump crapping out(its not already replaced it) or crank sensor. Took it to the dealer sometime back, he put it on a scan tool but no codes, but he told me something interesting, if this happens again try cooling off the the crank sensor with water, well guess what! It stalled out in front of my garage so I did as he said, and started right up. Could be an intermittently faulty sensor but which one? as the 2000 Impala has two.

Since: May 09

milwaukee

#9 May 25, 2009
Pod at impala wrote:
if this happens again try cooling off the the crank sensor with water, well guess what! It stalled out in front of my garage so I did as he said, and started right up. Could be an intermittently faulty sensor but which one? as the 2000 Impala has two.
you just answered your own question. if you took out the crank sensor and put it back in after you cooled it off replace the crank sensor.
Pod at impala

Saint Paul, MN

#10 May 26, 2009
The sensor was still in the car when I sprayed it. The manual says that there is two sensors, but the partsstore says there is only one, hmmm I better re-check the manual. Most likely it is behind harmonic balancer, they(automakers) can never make things to easy, can they? No wonder GM is in trouble.

Since: May 09

milwaukee

#11 May 26, 2009
yeah the manual says two but there is only one. get a new crank sensor and see if it still happens. after what you eplained im pretty sure thats the prob.
Sco

Sunol, CA

#12 Jun 10, 2009
Terry - Long Island wrote:
Hi, my 2000 Impala intermittently stalls while driving. I have had it to the shop and nothing shows on the computer. It only happens every few days and usually the car starts back up within a minute. Does anyone have a possibility what this could be? It's driving me nuts. Thanks for any help in advance.
I am having the same problem could you please email me at [email protected] with your solution. thanks, sco
Sco

Sunol, CA

#13 Jun 10, 2009
I am having the same problem with a 2000 chevy impala and I have already changed out the crank sensor with a new one. can you email me with your findings thanks. [email protected]
Terrence

Bryan, TX

#14 Jun 11, 2009
Terry - Long Island wrote:
Hi, my 2000 Impala intermittently stalls while driving. I have had it to the shop and nothing shows on the computer. It only happens every few days and usually the car starts back up within a minute. Does anyone have a possibility what this could be? It's driving me nuts. Thanks for any help in advance.
Same thing was happening to me. Replace the mass air flow sensor and that should fix it.
Daniel

Rockford, IL

#15 Dec 5, 2009
I have a solution to the impala stalling problems.
My 2000 3.8L V6 impala would stall randomly and seemingly for no reason. I couldnt figure what the problem was. And with that problem, it was rough to start it after I had drove it around, unless it sat for 4 to 5 hours or I was first starting it in the morning. It was a very dangerous situation when I would be traveling down the road and the car just stalled out, especially on turns.
So I read through hundreds of these posts, and tried different approaches to find the problem.

One day, while messing around with some stuff, I had taken tha vacuum line off of the the FUEL PRESSURE REGUALTOR, and FPR was literally squirting gas out of the side where it connects to the vaccum line. This obviously isnt right. Once gas gets down into the vacuum line and travels to engine, it will stall out the engine if you arent accelarating because it cannot burn off the excess gas being dumped into it. This also explains the hard starting issues. If there is too much gas, the engine will have trouble trying to start.
I replaced this part and the car is running like brand new. No problems starting ever, and the car hasnt stalled in 3 months....
Trust me, this is the problem, and its only a $40 part to replace.
army mechanic

Moscow, Russia

#16 Jan 1, 2010
jennifer from ohio that would be your timing
army mechanic

Moscow, Russia

#17 Jan 1, 2010
i got a 06 impala with the 3.9 v6 police crusier every once in a while it just wont start like ill drive it to town 10 miles or so fine no problem get back in side the car and it wont start dont even turn over just dash lights im in afganastan so i cant reall checlk it my self thinkin starter or the neutral saftey switch please help
David

Zephyrhills, FL

#18 Feb 1, 2010
Replaced the crank sensor, mass airflow, and catalytic converter and still haveing the stalling problem. I'll try the FPR. thanks
William

New Bern, NC

#19 Mar 7, 2010
Ive got a 2000 impala with the 3.8 it cranks fine when cold and when the engine goes to idle down from the cold start it spits and sputters and almost cuts off then the engine idles back up and ur good too go sometimes it will cut of if it does it but only does it cold or if it sat for a few min no lights and carried it to 2 different mechanics and they cant fig it out someone told me its the mass air sensor but i hate to buy that thing and that not be it any help pls email me at [email protected] thanks
janelle

Brooklyn, NY

#20 Jun 28, 2010
i have a 2001 chevy impala 3.4 after it gets warm it stalls when you go over a bump or stop it usually starts right back up though.does anyone have any ideas.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 6
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Impala Discussions

Title Updated Last By Comments
2011 impala vibratation (Oct '11) 12 hr joeynloi 36
News Chevy Impala Owners File Class Action Lawsuit A... (Jul '11) 13 hr T00thfa1ry 52
chevrolet impala abs/traction control lamp on p... (Apr '08) Fri Eddie 196
No chime, no radio volume but radio does work I... (Sep '08) Jul 27 Gatorboots74 123
2000 Chevy Impala - turn signal issue (Oct '08) Jul 26 Impalaprobs 31
miles per gallon meter Jul 26 Mike B 1
impala dash lights stopped working (Nov '09) Jul 26 ray 120
fan speed 1 and 2 not working but 3 & 4 speed w... (Aug '07) Jun '16 Gizmo 44
More from around the web