service vehicle soon light is on

service vehicle soon light is on

Posted in the Chevrolet Impala Forum

Clv

Kokomo, IN

#1 Jul 2, 2007
service vehicle soon light is on.
2000 IMPALA LS. around 60000 miles.
fuses checked out ok. disconnected battery and reconnected.
changed thermostat and mass air flow sensor recently b/c of potentially over heating.
Clv

Kokomo, IN

#2 Jul 2, 2007
autozone and another guy checked with a code checker and no codes were returned.
Heat1up

Gainesville, VA

#3 Aug 30, 2009
I have 2 2002 Impala and my service vehicle soon light stays on as well. There is no codes for this and the dealer will charge an arm to reset the warning lights
Technician R

Buckeye Lake, OH

#4 Aug 30, 2009
Heat1up wrote:
I have 2 2002 Impala and my service vehicle soon light stays on as well. There is no codes for this and the dealer will charge an arm to reset the warning lights
The trouble code probably cannot be read by a standard inexpensive code reader. Some trouble codes will set the Check Engine Light but can only be read by an expensive aftermarket scanner or the GM Tech 2 factory scan tool.
big iz

Whittier, CA

#5 Feb 5, 2012
You hold the odameter for 15 seconds then you turn the ignition on but don't start it,while holding the button down wait about 20 seconds LT should work
DoubleG

Las Vegas, NV

#6 Jun 18, 2012
My daughter's 2000 Impala (3.4L) developed the same issue recently. No codes came up when scan tool was hooked up.

Two things:

I've read talk of it being a fault within the lighting circuit, but no light issues exist that I know of.

However, the owner's manual says: "SERVICE VEHICLE SOON - This message will come on if you have engine problems. These problems may not be obvious and may not affect vehicle performance or durability..."

A co-worker emissions tech says he recalls seeing this happen twice, with no codes. He ended up selecting 'erase codes' anyways, and it fixed the problem. Going to do the same on hers and see if I too have success.
impalavictim

Kannapolis, NC

#7 Sep 21, 2012
DoubleG wrote:
My daughter's 2000 Impala (3.4L) developed the same issue recently. No codes came up when scan tool was hooked up.
Two things:
I've read talk of it being a fault within the lighting circuit, but no light issues exist that I know of.
However, the owner's manual says: "SERVICE VEHICLE SOON - This message will come on if you have engine problems. These problems may not be obvious and may not affect vehicle performance or durability..."
A co-worker emissions tech says he recalls seeing this happen twice, with no codes. He ended up selecting 'erase codes' anyways, and it fixed the problem. Going to do the same on hers and see if I too have success.
Am 2nd owner of 2000 Impala, which now has 160k mi. Former owner had maint performed at Chevy Dealer.
after assuming ownership elect problems popped up everywhere. When had high idle problem, took to local dealer, who replaced TPS and charged me $400. Did not fix problem, which was intermittent broken connection in wire leading to TPS. Soldered and heat shrink tubing solved problem. Recently took Imp to independent GM trained tech who hooked up car to Tech 2 tool and huge diagnostic thing-said fuell starvation was problem-raised on floor lift. Said it looked as if fuel filter had NEVER been changed-had tons of rust and corrosion on it. Took him 20 mins to bust it loose. Car now runs better than in did when I bought it in 2009, but tech did not get the SVS light to go off, although the SRS light now stays off. Thanks for the suggestion to try a Scan Tool to turn off the light-have already tried many other things.
JohnsonStunts

United States

#8 Jun 24, 2013
Replace the dimmer switch.
Barrettoautopart s

New York, NY

#9 Thursday Jan 12
big iz wrote:
You hold the odameter for 15 seconds then you turn the ignition on but don't start it,while holding the button down wait about 20 seconds LT should work
Thank you worked perfect, after 2 years of the service vehicle soon light it is off. Thank you

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Impala Discussions

Title Updated Last By Comments
Impala not starting (Nov '06) Fri carsonCA 193
No chime, no radio volume but radio does work I... (Sep '08) Jan 19 marcus 129
2004 3.8 Impala overheating (Nov '11) Jan 16 brittany333 16
2016 impalla shut off while running Jan 16 biggboy101 1
2000 Chevrolet Impala 3.4 sputtering during acc... Jan 15 Rickmick 1
2004 chevy impala heater blowing cold air. (Jan '10) Jan 13 Shamera 34
2000 impala traction control (Oct '06) Jan 13 RCinNM 468
More from around the web