Speedometer not working
First Prev
of 5
Next Last
naturalgurl98

Labadieville, LA

#1 Mar 9, 2007
Is anyone having this issue. I have a 2005 chevy impala.. For past two weeks my speedometer is out of wack. I was on the interstate doing 70mph but I kept saying this does not feel like 70 more like 50. The problem stopped for a couple of days but yesterday.. It took another turn. I was doing 35mph but hte reading showed 0mph. I am trying to find the best economical solution for this. I read on a couple other sites (dodge forum) and they stated with the car off hold the trip/reset button, then turn the car to on (but not starting it) hold it down and the everythign resets. does anyone know that to be true? has any one experienced, and what was the solution
Thanks

Judged:

91

15

1

Reply »
Report Abuse Judge it!
JEM

Englewood, CO

#2 Mar 18, 2007
Quite afew people are experiencing the same problem and there is no recall.
naturalgurl98

Labadieville, LA

#3 Apr 16, 2007
what is the cause?
Virgil AZ

Wills Point, TX

#4 Apr 22, 2007
I had the same problem with my 2004 Impala. I unhooked the battery cable and it reset to zero. That fixed it for a couple odf months, it is now on the blink again.
root

Richmond, VA

#5 May 21, 2007
i had the same problem on my 2004 ss , the dealership replaced the whole cluster
oz Pa

Bloomsburg, PA

#6 May 28, 2007
My friend has a wrecked chevy impala police cruiser , can I swap the speedometer in my 03 chevy impala ? Is it a simple as unpluging the old unit , and swapping it ?
Rock

Loretto, MI

#7 Sep 9, 2007
I have a 2004 Impala, 108000 miles and the speedometer has started to act up as well. The only common point that I have found so far is that it only does it after the dash lights have been on at full brightness for several hours.
Dee Dee

Phoenix, AZ

#8 Oct 1, 2007
When the dealership replaced the whole cluster, did that fix your problem with the speedometer?
Jim R

Rustburg, VA

#9 Oct 16, 2007
2004 Impala. Returning from a trip via interstate.Speedometer began to drop to 25 mph. I know that the traffic was moving at 80 +. Pulled off and shut down. Began to work again. Started to repeat 50-60 miles later. Shut off again. Working again for now. 40,000 miles. I amn no mechanic but I would guess it is a sensor failing. My company uses Impalas in our fleet. I know one of our sales people had to have the cluster replaced. A 2004 also.

Also had to replace the horn set at 30,000. Failed again after 36,000. Dealer said out of warranty.

Gaskets on passenger side began to leak at 32,000. 3 trips back I think they fixed it. If it ever rains again I can verify it.
MIMI

United States

#11 Apr 25, 2008
I WAS ON I-75 AND DOING 70 ON CRUISE CONTROL ALL OF A SUDDEN THE NEEDLE WAS GOING OUT OF WACK. WE PULLED OVER SHUT OFF THE CAR AND TURNED IT BACK ON APARENTLY IT WAS FIXED. TWO WEEKS LATER IT WAS GOING AGAIN.NOW IT JUST STAYS AT ZERO.
Technician R

Mansfield, OH

#12 Apr 26, 2008
Go to the following website for more information concerning your speedometer issue:
http://www.nhtsa.dot.gov/ . Search the complaint database for your make and model year. Then narrow your choice by choosing ELECTRICAL SYSTEM: INSTRUMENT PANEL. This information should be helpful for you to decide what to do about your problem.
elaine

AOL

#13 Nov 12, 2008
i am also having trouble with the speedometer. My husband changed the speed sensor on the transmission, thought that worked but it started to act wierd again. Speedometer showing 30mph while going 60, just "flopping" back and forth, any other ideas?
Jimi-MD

Springfield, VA

#14 Dec 1, 2008
2005 Impala - After a week at the beach (not driving my car) I come home and my speedometer starts acting up. Read 85 mph when the car was stopped and in park. Dealer is trying to screw me on the warranty. Says it'll be about 600 bucks to replace
Nikesha NJ

Barnegat, NJ

#15 Dec 6, 2008
I am having the same problem my 2004 impala speedometer, it has been acting up for about 2 weeks now. I can not afford to pay $500. to $600. to get it fixed I am sooooo upset. My car is no longer covered under warranty and with my luck if it was still under warranty my speedometer would probably be working just fine. Somebody anybody please help me.
brandon dorsett

Rexburg, ID

#16 Dec 7, 2008
oz Pa wrote:
My friend has a wrecked chevy impala police cruiser , can I swap the speedometer in my 03 chevy impala ? Is it a simple as unpluging the old unit , and swapping it ?
does your friend want to sell transmission out of his wrecked impala
chevyp2p

Mountain View, CA

#17 Jul 28, 2009
I had the same problem in my car. I found a website where I had my cluster rebuild for $140. That's a lot cheaper than the $750 that the dealer wanted to replace the speedometer.
Here is the address incase you wanna check it out:
www.speedometergaugerepair.com
Dale

Elyria, OH

#19 Mar 2, 2010
I have a 2005 Chevy Imapala and today the speedometer on my car started to act weird. It says I am doing 85 when the car is sitting still and running.
MissouriMatt

Rutledge, MO

#20 Apr 6, 2010
ok so the speedometer is being a piece so whats up impala i've changed the senor and mine is still doing the same so what up people any other suggestions
Rooney

Rochester, MN

#21 Apr 9, 2010
naturalgurl98 wrote:
Is anyone having this issue. I have a 2005 chevy impala.. For past two weeks my speedometer is out of wack. I was on the interstate doing 70mph but I kept saying this does not feel like 70 more like 50. The problem stopped for a couple of days but yesterday.. It took another turn. I was doing 35mph but hte reading showed 0mph. I am trying to find the best economical solution for this. I read on a couple other sites (dodge forum) and they stated with the car off hold the trip/reset button, then turn the car to on (but not starting it) hold it down and the everythign resets. does anyone know that to be true? has any one experienced, and what was the solution
Thanks
Don't look to GMC to help you with this problem. We have a 2004 Chevrolet Impala and had the same problem, as do 100's of other people according to the Internet. Yet, Chevy won't own up to it. We went round and round. We spoke to district representatives, even the high paid (little deserved) executives at GMC, but no soap. At least Toyota is accepting responsibility. We finally had the problem fixed to the tune of over $500...now we have another problem developing. This is our last GMC vehicle.
dave g

Toledo, OH

#22 May 20, 2010
I got a 2004 chevy 3/4 ton HD silverado that seems to do the same thing but only when it rained. The seepdometer would go wacky but a day or two later (with no rain) it would go back to normal, you could be doing about 35 MPH and it would read 120MPH.This went on for about 6 months now it's on 0 MPH and will not move at all.Sounds like GM is putting the screws to many on this issue.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 5
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Impala Discussions

Title Updated Last By Comments
chevrolet impala abs/traction control lamp on p... (Apr '08) 19 hr John 195
2000 Chevy Impala - turn signal issue (Oct '08) 20 hr Impalaprobs 31
miles per gallon meter 22 hr Mike B 1
impala dash lights stopped working (Nov '09) Tue ray 120
2011 impala vibratation (Oct '11) Tue Khaled 34
2013 Impala Mon Mindy 1
2005 Impala Headlights Not Working (Nov '08) Mon Sharon 12
More from around the web