2001 impala low coolant light

2001 impala low coolant light

Posted in the Chevrolet Impala Forum

OHIOMIKE

Port Clinton, OH

#1 Jun 17, 2009
I have a 2001 Impala with 78,000 mi. The low coolant light comes on and stays lit. However, Coolant levels are OK in both the radiator and overflow tank, and temp gauge is at about halfway. It seems to come on after about 15 mins. of driving when car reaches normal operating temp. and it stays lit until car is shut off. Is this a problem with the coolant sensor or an electrical glitch? Also, I replaced the coolant sensor about a year ago. Has anyone else experienced this problem, and if so, how do you fix it?

Since: May 09

milwaukee

#2 Jun 18, 2009
sounds like the coolant sensor to me. take the coolant sensor out and clean it and the electrical contacts.
Big Jim

United States

#3 Feb 4, 2010
Where is the coolant sensor located? Is it easy to get at?

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Impala Discussions

Title Updated Last By Comments
News Chevy Impala Owners File Class Action Lawsuit A... (Jul '11) Sat patsy Mosley 50
Heavy power steering Impala 2006 Apr 29 ziadkhairalla1 1
2001 Impala not starting (Aug '06) Apr 25 pearlygirl 178
Dash lights go off when sensor turns on head li... (Oct '06) Apr 25 Wild Bill D 61
2002 chevy impala Apr 25 Ricky 1
2002 Impala Problems (May '07) Apr 25 Javi 441
impala 2002 Apr 24 gerardo 1
More from around the web