2002 Impala LS leaks rain water

2002 Impala LS leaks rain water

Posted in the Chevrolet Impala Forum

First Prev
of 6
Next Last
Keith in PA

Noblesville, IN

#1 Oct 4, 2006
Whenever it rains somewhat hard out my 2002 Impala LS leaks water onto the front passenger side floor. I'm talking a big puddle if the rain keeps up pretty heavy. I am thinking it might be a problem with the windshield seal but I am unsure. Any help would be great!

Judged:

18

13

1

Reply »
Report Abuse Judge it!
Jason

East Lansing, MI

#2 Oct 6, 2006
that would be my guess. if not look under the hood and see if there is anything out of place up by the fire wall.
Angie

United States

#3 Oct 13, 2006
Mine does this too and has rusted out my blower motor for my heat
Kent

Evansville, WI

#4 Oct 21, 2006
same problem!

Has anyone found a fix???
Carl

United States

#5 Oct 24, 2006
Kent wrote:
same problem!
Has anyone found a fix???
This sounds like the same problem I had with my 1998 Olds Intrique. My problem was two fold: 1) the sealing strip at the base of the windshield had fallen off, and water running down the windshield would fall directly into the interior fresh air intake. 2) The factory installed interior air filter was missing allowing water to flow directly onto and through the fan motor and into the passinger floorboard. No problems since.
ColbyS

Avilla, IN

#6 Oct 27, 2006
ya. i have a '03 impala. Passenger side is getting big puddles of water. so the window is problem the cause huh?
Kent

Evansville, WI

#7 Oct 29, 2006
Carl wrote:
<quoted text>This sounds like the same problem I had with my 1998 Olds Intrique. My problem was two fold: 1) the sealing strip at the base of the windshield had fallen off, and water running down the windshield would fall directly into the interior fresh air intake. 2) The factory installed interior air filter was missing allowing water to flow directly onto and through the fan motor and into the passinger floorboard. No problems since.
Thanks Carl

I took the black piece of plastic off. 1 plastic screw and 2 pull connectors,(just below passenger side wiper). I could see the problem right away with the sealing strip... I used clear sealing caulk on the sealing strip to make sure it wont come off easily again...
Found the Problem

Noblesville, IN

#8 Oct 30, 2006
Carl and Kent you are right on. I also took the plastic cover off by the base of the windshield and found the weather strip had fallen off. I used clear silicon and glued it back in place. It had become slightly warped and need the adhesion. It rained for 2 days afterwards and there have not been any more leaks in my car. Thanks!
chris

Alexandria, VA

#9 Dec 27, 2006
Two quick questions. First the easy one. What are the wheel size options for the 01 impala? Now the hard question. I am losing acceleration ... quickly. I tried the fuel injector cleaner but that has done nothing. If I floor it, the engine will surge like I'm getting power, but nothing happens. It's like I have to accelerate very slowly or else I lose power. What's happening?
PS I too have the same problem with the puddle on the floor, except it's my driver side, not passenger. I'll try the stripping. Thanks.
Mike

Canada

#10 Mar 26, 2007
The problem with the leak into the passenger side is because when the factory put on the weather stripping underneith the whipers and black cowling they didn't glue it on. I went to a glass shop and it took them 25 minutes to fix. they took off the the whiper arms, the black cowling and sure enough the weather stripping had fallen off. They glued it on using a 3M adheisive and after they did that they changed my Cabin Air filter for me. It stunk because it had absorbed all of the rain water. It burnt out my blower motor and that was how i origonally found the problem.
Joe

Cumberland, RI

#11 Apr 8, 2007
the question about your acceleration; i had the same problem and it was my catalytic converter; it was clogged :)
Doug

Charlottesville, VA

#12 Apr 9, 2007
Mine must be leaking the same way. The funny thing is the water all seems to be collecting in the ductwork. When I step on the gas and begin to move forward, I hear water in the fan assembly. I wish I knew how to get it out. It's a 2004 SS Limited.
Melissa

Houston, TX

#13 Apr 20, 2007
I have a 2000 Chevy Impala and my has been leaking for a few years. i thought it was because my car was in a front end accident. Guess not! It also rusted out my blower motor and now it has water in it and will not work--if I bang on it with a butter knife it will start to blow! Do I need to replace it (probably so huh?) Also none of my windows will go down. The driver window controls have been replaced and when I try to put the window down it makes a buzzing noise, I think its a wiring problem--ANY SUGGESTIONS on how to fix the windows?

Thanks
Melissa

Houston, TX

#14 Apr 23, 2007
Thanks to ya'll I figured out how to fix the leak in the windsheild--and yes just as ya'll said it was the weather stripping. I noticed my interior air filter was nasty and clogged so I bought a new one and the air blows alot better (when I can get it to work that is)

Thanks again
Bob STL

Collinsville, IL

#15 Apr 23, 2007
My 2002 Impala electronics is acting up. It restarts the time on the radio when I start it or turn it off. Also the interior lights flicker when on and the headlights have flickered before. Any ideas, I was thinking the BCM might be bad.

Thank you
melissa

Houston, TX

#16 Apr 25, 2007
Doug wrote:
Mine must be leaking the same way. The funny thing is the water all seems to be collecting in the ductwork. When I step on the gas and begin to move forward, I hear water in the fan assembly. I wish I knew how to get it out. It's a 2004 SS Limited.
I was told to use a vaccum hose and hook it up behind the blower motor hose (take the hose off the blower motor) You can also take off the cowling and then the air cabin filter and see a fan-maybe there is water in it.
Jason

United States

#17 May 1, 2007
My 2004 impala had water leak in by cabin air filter a week later my radio has no audio is that a different problem or are they related
FixItMan

United States

#18 May 1, 2007
Keith in PA wrote:
Whenever it rains somewhat hard out my 2002 Impala LS leaks water onto the front passenger side floor. I'm talking a big puddle if the rain keeps up pretty heavy. I am thinking it might be a problem with the windshield seal but I am unsure. Any help would be great!
Mine leaked water on the passenger floor from the heater box. I removed the cover near the windshield wiper area under the hood and found some leaves and debris clogging a drain. The water was going into the fresh air intake and leaking into the heater fan and onto the inside floor.
Jedhowe

Knoxville, IA

#19 May 7, 2007
chris wrote:
Two quick questions. First the easy one. What are the wheel size options for the 01 impala? Now the hard question. I am losing acceleration ... quickly. I tried the fuel injector cleaner but that has done nothing. If I floor it, the engine will surge like I'm getting power, but nothing happens. It's like I have to accelerate very slowly or else I lose power. What's happening?
PS I too have the same problem with the puddle on the floor, except it's my driver side, not passenger. I'll try the stripping. Thanks.
I worked in a transmission shop and we would get the 3800 and 3400 motors with a clogged cat, try that first.
MMC

Houston, TX

#20 May 8, 2007
Jedhowe wrote:
<quoted text>
I worked in a transmission shop and we would get the 3800 and 3400 motors with a clogged cat, try that first.
FUEL INJECTOR WAS RECALLED!!!!!
THE DEALER REPLACED MINE IN A 2000 IMPALA A FEW YEARS AGO!!!!!

PS CLOGGED CAT? WHAT IS THAT?

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 6
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Impala Discussions

Title Updated Last By Comments
2006 Chevy Impala AC Compressor Issue (Aug '08) 4 hr Tobby 20
chevrolet impala abs/traction control lamp on p... (Apr '08) Sun Dropthis 194
2002 Impala Problems (May '07) Sat MsPeachez 447
05 turns but won't start Sat Needtorun57 1
Passlock Security system... (Jan '07) Jun 22 Kingcobra 492
2003 Impala AC problem. Compressor working but ... Jun 22 KeVIN sykes 1
2003 impala misfiring (Apr '07) Jun 19 Flustered 1 41
More from around the web