Patrick

Scottsdale, AZ

#1 Apr 20, 2010
i need a simple to read fuse diagram. something with pictures that are labeled with what they go to. my wifes ls has so many electrical problems with it my face is about to explode from frustration.

also does anyone know if you can buy vacuum line connectors... the little rubber things that hold the vacuum lines where they need too be some are cracked. which in turn makes them sometimes fall off then the car starts making silly noises which we all know funny noises in your car are a bad thing.

but back to the initial issue. fuse diagrams is what i need. a link to a site a pdf file dont care what format it is in as long as it is understandable.

but yeah these are the problems... the 12v power outlet that usually has a cigarette lighter in it. no longer works my wifes father made it stop working but trying to inflate a flat tire with a cheap electrical tire pump. umm the thing nearest the rear view mirror(it tells you which direction your going or average miles per gallon. that no longer turns on have no idea why. the a/c is all sorts of weird. sometimes it will work but only with heat. then it wont work at all. and you cant change the settings on it(maybe a fuse i dont know. most likely shitty wiring).

mainly what im trying to say is that i dont approve of the craftsmanship chevy had going on for awhile their terrible quality control. but anywho on to the next issue that i dont understand.

her LS will not accelerate properly sometimes well most the time. the transmission fluid was changed around 90k miles now the car is at 102k miles.

it feels like the transmission itself is not engaging. you can rev the engine but the acceleration is very slow. double pumping it sometimes works. it will do this when changing gears. instead of a smooth transfer between gears it is a long drawn out process(again not all the time, but most the time). again the engine will begin to change gears and try to accelerate but it will just coast till it is double pumped or we usually let off the gas entirely and then re-engage the gas and about a second or two after that it will begin to accelerate normally.

any help would be great. i just dont want to pay a 100 bucks for a diagnostic.

thanks

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Impala Discussions

Title Updated Last By Comments
2014 front popping noise (Mar '14) Tue Neal 2
carfax reports (Jan '10) Mon Brenda 6
impala 2014 water leaks (Jan '14) Mon 2014 Impala Kentucky 36
Passlock Security system... (Jan '07) Mar 29 tommyg 453
2001 Impala Temp gauge stopped working HELP ME! (Nov '10) Mar 29 laire 16
fan speed 1 and 2 not working but 3 & 4 speed w... (Aug '07) Mar 29 tony 34
Chevy impala wipers not working (Dec '06) Mar 29 grampy0729 310
chevrolet impala abs/traction control lamp on p... (Apr '08) Mar 15 Joe L 154
More from around the web