Equinox air conditioner
John

North Vernon, IN

#21 Jul 23, 2008
I have a 2008 Equinox that was also blowing cold and then cool air. The fan needed to stay on high and the temp set at the coldest to cool the rear seat passangers. I had an appointment today at the dealership where I purchased my Equinox. The tech pulled up a bulletin(08-01-38-003) that was dated June 23, 2008. It states that the (ECM) engine control module needs to have the software updated. Apparently the original software would turn the compressor in the "off" cycle for too long allowing the air to get cool instead of cold. The updated software shortens the "off" cycle and thus keeps the air cold at all times. I must say the ride home in ninety degree temps was much nicer. The air actually blows so much colder, I needed to turn the temp up as it was getting too cold. The bulletin says it's for the 2008 Chevy Equinox and the 2008 Pontiac Torrent but it may possible be something that could fix earlier models. Anyone with this similar problem might want to give their dealer the bulletin number and see if that will help get your A/C blowing cold again. I wonder if the original software was intended to keep the compressor off longer to increase fuel milage.(HMMM?) I guess I will find out! ;)
Sarah

El Segundo, CA

#22 Jul 23, 2008
Hi John and everyone ... I have already had my ECM reprogrammed... THREE TIMES to no avail (along with replacing the air controller, a valve, etc.). I have a 2007. GM needs to get their act together.
John wrote:
I have a 2008 Equinox that was also blowing cold and then cool air. The fan needed to stay on high and the temp set at the coldest to cool the rear seat passangers. I had an appointment today at the dealership where I purchased my Equinox. The tech pulled up a bulletin(08-01-38-003) that was dated June 23, 2008. It states that the (ECM) engine control module needs to have the software updated. Apparently the original software would turn the compressor in the "off" cycle for too long allowing the air to get cool instead of cold. The updated software shortens the "off" cycle and thus keeps the air cold at all times. I must say the ride home in ninety degree temps was much nicer. The air actually blows so much colder, I needed to turn the temp up as it was getting too cold. The bulletin says it's for the 2008 Chevy Equinox and the 2008 Pontiac Torrent but it may possible be something that could fix earlier models. Anyone with this similar problem might want to give their dealer the bulletin number and see if that will help get your A/C blowing cold again. I wonder if the original software was intended to keep the compressor off longer to increase fuel milage.(HMMM?) I guess I will find out! ;)

Since: Jul 08

Wichita Falls

#23 Jul 23, 2008
Since I dont have warranty anymore, my hands are basically tied at this point. I'm going to keep checking back here to see if anyone else gets a solution.. My dad thinks if we replace the compressor it will fix the problem--but I'm scared of being out another $550... Keep me posted on anything new..
Kristen

Oklahoma City, OK

#24 Jul 23, 2008
I just brought my car to a Chevy dealership last week with the same AC problems. They said I needed to replace the expansion valve and the compressor. I have an extended warranty and the only part that was covered was the compressor. I couldn't afford to replace the expansion valve so i told them only to replace the compressor and I would take care of the EV later. The dealer warned me the system would be the same if I didn't replace both parts. I got my car back last night and the AC is working amazingly. None of the warm air problems. They didn't mention anything about updating software, so I'm not sure if that works.
John

North Vernon, IN

#25 Jul 25, 2008
You were problably lucky that the dealership replaced the compressor and didn't charge you. The bulletin specifically tells the dealerships, "DO NOT REPLACE THE COMPRESSOR,ECM OR ANY OTHER A/C SYSTEM COMPONENTS." Apparently GM will not reimburse the dealerships for those parts if they change them. So far 2 days after having the computer software updated, my a/c is still blowing very cold.
Kristen wrote:
I just brought my car to a Chevy dealership last week with the same AC problems. They said I needed to replace the expansion valve and the compressor. I have an extended warranty and the only part that was covered was the compressor. I couldn't afford to replace the expansion valve so i told them only to replace the compressor and I would take care of the EV later. The dealer warned me the system would be the same if I didn't replace both parts. I got my car back last night and the AC is working amazingly. None of the warm air problems. They didn't mention anything about updating software, so I'm not sure if that works.
Sarah

El Segundo, CA

#26 Jul 30, 2008
If any of you have called GM about this issue, could you please provide me with your case numbers? I'm still battling this issue. Thank you!
Kristin

Foxworth, MS

#27 Jul 30, 2008
Sarah wrote:
If any of you have called GM about this issue, could you please provide me with your case numbers? I'm still battling this issue. Thank you!
My case number is 71-645987347

I filed a complaint with the Better Business Bureau and GM's legal department got involved. GM said the air conditioner is working the way it was designed to work and they see no problem with it and it is not a safety hazard. I told them that I have a 4 month old that is riding around in a car whose a/c does not work correctly and it is 100+ degrees outside. It is a safety hazard and if something happens to my child I am holding GM/Chevy personally responsible.
I talked to my service manager today at my dealership and told him what GM told me and he said that the main engineer who designs Equinox's called him Monday and asked him questions about the a/c problems so he said it is a step in the right direction and obviously people are starting to call in and complain or report this problem with GM. He cannot promise me GM will come up with a solution soon or even decide to fix the problem but he is waiting on a call back from the engineering dept and he will keep me posted.
Sarah

El Segundo, CA

#28 Jul 30, 2008
Thanks for this Kristin. Mine is 71-644222755. I have gotten a lawyer involved. Yes, I understand that nothing is showing up on their computer when they hook it up, but if they were to ACTUALLY RIDE IN THE VEHICLE and experience what we're experiencing, they would see. I have met with regional managers from GM, directors, etc. to no avail. They have simply referred me to the BBB.
Kristin wrote:
<quoted text>
My case number is 71-645987347
I filed a complaint with the Better Business Bureau and GM's legal department got involved. GM said the air conditioner is working the way it was designed to work and they see no problem with it and it is not a safety hazard. I told them that I have a 4 month old that is riding around in a car whose a/c does not work correctly and it is 100+ degrees outside. It is a safety hazard and if something happens to my child I am holding GM/Chevy personally responsible.
I talked to my service manager today at my dealership and told him what GM told me and he said that the main engineer who designs Equinox's called him Monday and asked him questions about the a/c problems so he said it is a step in the right direction and obviously people are starting to call in and complain or report this problem with GM. He cannot promise me GM will come up with a solution soon or even decide to fix the problem but he is waiting on a call back from the engineering dept and he will keep me posted.
big john

Fort Dodge, IA

#29 Jul 30, 2008
Phyllis Hale Hubert wrote:
my 2008 Equinox a/c goes from cold air to cool air back and forth and does not cool the car ,also if you put a/c controll above 2 clicks it is so loud you can not hear any thing but the roar of it. The first time I took it to the dealer,they said it was low on charge , they evacuated the system and recharged it ,said it was fine . Still same problem .returned to dealer ,they replaced an ambient air sensor ,said it was ok . Still same problem.
I took my service person for a ride he affirmed the problem ,now he tells me this is the way all Chevys are made. I am 64 years old ,I have driven many cars in my life ,I know this is NOT how any car a/c should perform. Any comments would be appreciated.
My a/c has been having the same issues, I took it to a dealer and they wanted too much money and so I started looking at the car and asking questions. It seems that in the past cars were over heating when at red lights and there were sensors and a thermostat installed so that when the car is stopped and gets hotter the a/c will shut down so not to over heat the a/c unit. So when you take off, air starts to flow over the radiator cooling down the engine letting the a/c work. After further looking tonight and changing out the themostat I see that the thermostart is about a 1/2 inch from the exhaust pipe. I reason that being this close is a design flaw and is making the a/c not work because the thermostat is always reading hot because it is riding piggy back on the exhaust pipe. I reason it is a no win situation and think the only remedy is a reimbursment from chevy is some form. Maybe everyone who has been living with this can be compensated for a poor design on chevy's part. Hope this helps, I believe it is true.
2006 Equinox

United States

#30 Aug 1, 2008
I have a 2006 Equinox. IN the past two weeks I have experienced when my a/c will start out cold and then run warm. I turn it off and it goes cold and then goes back warm. Also, I've had where the blower is on level one. After about 10-15 minutes, white smoke (not burning smoke) starts to come out of the vents. I've taken the car into the dealership twice with in this week. I get called and I am told, "Oh I am sorry we can not determine the problem." I am so frustrated at this time. I mean how can a vehicle that is two years old have this a/c problem that can't be determined. WHAT A BUNCH OF CRAP!
Lindsey

Baton Rouge, LA

#31 Aug 4, 2008
I also have a 2006 Chevy Equinox and I am having the same problem. The blower gets so loud and hardly any air is coming out. Today along with the white "air" some white specks came out too. I am barely out of my 36,000 mile warranty!! What is the deal?!?!?!?
Tony

Unionville, MO

#32 Aug 5, 2008
I have a 2005 Chevy Equinox with the same problem. About 6 months ago, I was at a fast food drive-thru and it started making a loud knocking sound, followed by a cloud of white vapor rising up from beneath the hood. I turned it off and re-started it; everything seemed to be fine. Two months ago, the defroster started malfunctioning while I sat in the car with it still running, waiting for a friend to come out of a store. Since then, the ac hasn't worked well or consistently. I had it recharged about 5 weeks ago. While the mechanic was recharging it, the car made that same loud knocking sound--so the mechanic immediately released freon, afraid he had over-filled it. He then claimed the ac was cooling to 46 degrees. So I took it home. Two weeks later, however, I had to take it back because it wasn't cooling at all. The mechanic evacuated the system and recharged it. He said if that didn't work, it would need the expansion valve replaced. The ac worked fine for a week, so I thought it was fixed. But no. Two days ago, just after the car was started and the ac was on, white fog blew out of the ac vents, followed by hot air. So much for it being fixed.

I'll consult a dealership about the ECM software update. Maybe that will fix it. I'm glad I didn't get the expansion valve replaced--sounds like that repair hasn't been successful.

My gut feeling is that it relates to the thermostat, but if that's the case, the blog about this issue being a design flaw (due to the proximity of the thermostat to the exhaust valve) could hold some water.
Norman

Ashburn, VA

#33 Aug 5, 2008
Lindsey wrote:
I also have a 2006 Chevy Equinox and I am having the same problem. The blower gets so loud and hardly any air is coming out. Today along with the white "air" some white specks came out too. I am barely out of my 36,000 mile warranty!! What is the deal?!?!?!?
I have a 2006 Equinox and have problems with the A/C it blows hot air then if you shut it off and on again it blows cold, Ive had it in at least 14 times and they still don't know how to fix it they'v change the computer , the senser, the controls, the valve in the dash that switches it from hot to cold, now I have 36,ooo miles and they say its too late for lemon law and that they won't do anything till they can solve what is going on , and they they will only deal with my inconvenience nothing else when its fixed, don't seem they give a crap, it blows so hot of air you can't stand it, if you've heard of someone who found the problem with the a/c let me know at [email protected] , hope you have better luck than I have
Hill

Salt Lake City, UT

#34 Aug 6, 2008
Hill wrote:
I have a 2005 Equinox that was blowing warm air off and on with the AC on. Took it to the dealer and they said its one of two things the expansion valve or the compressor. They put in an expansion valve first but it did not change, so they replaced the compressor. Just got it back today and so far its working great.
3 Hours labor $300.
Valve kit $167.
Compressor $460.
TOTAL $930.
Still cheaper than a new car, Sales tax, dealer fees, so on...
1 Month update still working great.
mexico_mike

Puerto Vallarta, Mexico

#35 Aug 10, 2008
Priscilla wrote:
I bought an 08 Equinox in December; didn't need AC during the winter; around April I started noticing the temp change when I accelerated or stopped; brought it to the dealership two weeks ago; at first they said it had too much freon, so they evacuated the system and refilled it to proper level; still had same issue; brought back on Monday; service rep felt the temp change but techs could not duplicate; they gave it back two days later without any repair and no advice; decided to google the issue and found this website and two others; I called the service mgr today; he said the techs couldn't figure out what was wrong; I asked if it could be design flaw, engineering issue, or problem with sensor or circuit; he said he had nothing in his system about this type of problem; I then told him what I found by googling and how this seems to have been an issue since 2005; at that moment he "discovered" that an internal memo went out about 2 days ago(!); the problem is a computer anomaly; it's the engine control module that is causing the problem, and the way to fix it is to have the software updated; brought it in, took 15 minutes for svc dept to reload software and, so far, it seems to be working correctly; they didn't give me an invoice, however, because they're waiting to see if the issue is resolved over the weekend; thought this info might help others in this situation
we have a 05 Nox with the same problem! did the
software reload fix the problem for you ???
Norman

Chesapeake, OH

#36 Aug 10, 2008
Took my Equinox in again saturday to show service department it was blowing hot air again they were closing and told me to bring it in when it does it again,how many times does a person have to take in back and forth before GM Does something, I think Im going to call them every day till I get someone to give me someone who can fix it or give me my money back, they said they didn't know of a problem till I showed them all the posts people have put on this site. Maybe going on TV would help.
Equinox Concerned

El Segundo, CA

#37 Aug 20, 2008
Does anyone have any updates? Any resolutions?
Victoria

Terry, MS

#38 Aug 21, 2008
I bought a 2008 Equinox in March (brand new) I am having the same problem. But, I having other issues; have took it back 4 times; they can't find anything. It went back to shop 4 days ago and it is still there; they say they is going to find out something. But, I will call the 800 number in the morning. Ask for ref # and post it back on this site. Also, I just submitted my case to lemoncars.com . Waiting on review. Everybody need to call!!!!!
Terry Green

Frankfort, KY

#39 Sep 3, 2008
I have the same problem but, i have cool air sometimes or none at all. Two months ago I replace the battery. My Equinox is 2006. I had a honda for years and never had this many problems. I bought mine vehicle new at Jeff Sachs in Frankfort Ky 40601. But, they close last month so, I need to see if this is under my warranty or a recall.
Jim

Brockville, Canada

#40 Sep 5, 2008
I have a 2006 Equinox with the same problem. The dealer did some sort of software update at no charge but claimed to have never heard of the problem before. It made no difference. I am glad to have found this site so I know I am not imagining this problem.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Equinox Discussions

Title Updated Last By Comments
radio won't turn off! (Mar '14) 13 hr Radio 2
sound goes off when receiving and calling, usin... 21 hr 77truck 1
2016 equinox using coolant on the v6 @80.000 mi... Jun 22 mario57 1
EQuinox Jun 21 Dean Gammon Sr 2
Chevy Equinox - PCM Root of Problems (May '08) Jun 18 tinygemini85 153
2010 equinox bad ecm & recent recall item (Feb '10) Jun 18 nomorechevy 10
Engine Misfire/Sputter (Jan '11) Jun 18 EmBal25 118
More from around the web