Eric

Tremont, PA

#102 Feb 25, 2013
I am having the same issue with my 2006, does anyone know the PN for the replacement EGR valve and piping?
Josh

Duluth, GA

#103 Feb 25, 2013
My wife has an 05 Chevy equinox and has had all the same exact problems everyone else has had but my question is this she has to get an oil change every month but just today the motor was knocking really bad then it decrease in speed and just shut off wtf??? So we put oil in thinking it would start back up but every time I crank it the starter juice up it don't turn over...and everything resets!!! So I'm asking could the motor have locked up? Or would the car automatically shut its self off before something like this happens?? Plz help
Kirk

United States

#104 Feb 28, 2013
2007 EQUINOX wrote:
Loosing power at 40mph. anyone know what might cause this. no engine lights. had gas cap replaced and this helped for a little bit but back to the problem again.
I had similar issue on my 08 equinox it's was a malfunction spark plug under recall. Chevy dealership fixed the problem no charge. Try that.
Pride 06

Knox, IN

#105 Mar 1, 2013
Have a 06 Torrent and just had the exact same problem. The old EGR tube broke and the check engine light did not come on, which it should have. GM obviously knew this, hence the reason for the "kit". Autozone sells for just a bit under $300. Its only a few bolts and some fairly simple wiring.

There should be a recall on this. Contacted GM and they don't seem to care at Customer Care. For a 32k dollar car its my last one too. Where is a lawyer around when you need it. Someone help us!
Love my Equinox

Brookville, PA

#106 Mar 24, 2013
I have a 2006 Chevy equinox and I am now having problems. Does any one know what makes your vehicle "chug" when on an incline. Is it my catlysist or do I need new plugs?
Jeremy

Pilot Grove, MO

#107 Apr 1, 2013
I have a 05 Equinox at 84,XXX miles. Last week it started ticking like a lifter. Changed the oil. Dirty, but not to bad. Been to every shop in town. No recalls due on this car. Been told everything from bad valve spring to lifter or pushrods to spun bearing. Local Ford dealer is the one who told me bearing. Chevy dealer wants $300 just to diagnose the problem. I don't want to spend anything I don't have to. Just want to keep it on the road. Anyone else have this sound and get it fixed?
arien

Jersey City, NJ

#108 May 5, 2013
Ok, today my truck would start but cute right off, a guy told me its my fuel pump, and its going bad I have about 98k miles on it the cost of a fuel pump is 400 bucks is there a cheaper route....
arien

Jersey City, NJ

#109 May 5, 2013
By the way its a 05 Chevy equinox
Jimmy

Edmonton, Canada

#110 May 24, 2013
I have a 2006 PONTIAC TORRENT that the engine shuts off randomly without warning and would not even crank over for up to 5 min but everything else worked. this car did this many many times, dealer found it was the PCM and they replaced and reprogrammed it all under the Emissions warranty that covers it for 8yrs and 130,000 km in Canada but I had to ask for it they never offered. was going to be $700
tatar4211

Albany, GA

#111 Sep 24, 2013
I have a 2006 Equinox LT and purchased it 7 months ago from a lot. I had 95000 miles when bought and now has 102500 and is in the transmission shop. The transmission goes out, 3600 to rebuild.The problem causing it was that the transmission cooler leaked into the transmission, tearing up all the parts in there. When I purchased the car I had an agreement with the lot to fix some things on my agreement to purchase. They replaced the heater core, water pump, EGR kit(entire kit), both O2 sensors and the catalytic converter, and these were not cheap fixes either. Anyone know of any recalls on the 2006 on transmission cooler failure or leaking into the transmission. I cannot find any recalls on the 2006 at all.
tom

Port Clinton, OH

#112 Sep 28, 2013
I have a 2006 equinox and I've changed the starter,plugs,battery,coil pack and the car turns over but won't start and I've put gas in it and the gas light is still on any solutions?
Jim

Saint John, IN

#113 Nov 5, 2013
I bought a used 07 Chevy equinox and it wont pass emissions. I have had the cat and both o2 sensors replaced and it still wont pass. It keeps saying that the EGR monitor is incomplete even after driving like we always do for over 300 miles. Does any one know what I need to do? The dealer says it good to go after hitting me for $1,500 and it still wont pass....
Peter

Toronto, Canada

#114 Dec 15, 2013
I have a 2007 chev equinox with just 130, 000 km on it, transmission skips or chugs in 3rd going up a hill or under load.
I recently used it to pull a unloaded trailer in the I selection drive mode as the manual says. Does anyone know my problem
And possible repairs with costs?
Robbie

Hamilton, Canada

#115 Dec 31, 2013
What a load of nonsense!
SHER wrote:
<quoted text>
AT 100,000 MILES I WAS BARELY BREAKING IN MY NEW HONDA 3 YEARS AGO. MY HONDA HAD 160,000a 2005 AND RAN LIKE BRAND NEW SINCE THE DAY I GOT IT. I NEVER HAD FUEL PUMP ISSUES OR PCM ISSUES WITH HONDA. JUST YOUR NOMAL MAINTENANCE: TIRES, BRAKES, OIL CHANGES.
i CANT BELIEVE HOW DIFFERENT STANDARDS ARE FOR AMERICAN CARS OPPOSED TO IMPORTS.
I WAS RAISED TO BELIEVE THAT AMERICAN CARS BASICALLY LAST YOU 100,000 AND AT 100,000 THEY ARE READY TO HAVE ALL THEIR GUTS REPLACED OR JUNKED. tHEY SURELY WERE NOT WORTH MUCH AT THAT POINT.
IF ALL VEHICLES ARE THE SAME HOW COME ON AVERAGE SOMEONE CAN GET 200-300,000 OUT OF A ONDA OR TOYOTA WITH NO ISSUES BUT FORDS, CHEVY'S ETC ARE NUTORIOUS FOR ISSUES WITH EVERYTHING AT 100,000? HMM.. i CANT WAIT TO GO BACK TO HONDA.. REPLACIGN MY FUEL PUMP ON THE BROKEN EQUINOX i WAS SOLD BACK IN MAY. THEY HAD TO LIE TO SELL IT TO ME, THAT IS PRETTY BAD. i AM HOPING REPLACING THE FUEL PUMP ENDS MY NO START ISSUES AND DYING..I HAVE ALREADY REPLACED THE BATTERY, AIR INTAKE HOSES ON THE ENGINE, NEW TIRES, BRAKES, ROTARS AND NOW A TRANSMISSION FLUSH, AND FUEL PUMP. I HOPE TO GOD IT ISN'T THE PCM. I CANT AFFORD MY PAYMENTS IF I NEED ANYMORE REPAIRS. I THIK ALL 05-06 MODELS ARE LEMONS. THE FIRST THEY MADE SO THEY HAD TO WORK OUT ALL THE KINKS..
BY THE WAY, STILL TO THIS DAY, I HAVE NEVER SEEN A HONDA BROKEN DOWN ON THE SIDE OF THE ROAD...... JUST A OBSERVATION ADN TRUST ME, I HAVE LOOKED.. I HAD A CIVIC FOR 6 YEARS.
suv momma

United States

#116 Feb 14, 2014
I bought my 05 ls awd brand new and have had no problems with it. It has been the most reliable vehicle i have ever owned and would defintely get another one. Every vehicle has problems and people definitely get frustrated and come to sites like these and blow off steam about them.
chuck

Saint Clairsville, OH

#117 Feb 16, 2014
I have 2007 equinox it has 71000 miles on it the other day my wife was driving it when the gauges started goin crazy the door locks started goin on and off the service engine soon light came on also the traction control and the stibillatrack light service soon came on the power sterring is also messing up from time to time when driving it the car runs just fine down tje road has anyone else had this problem if so what did you do to fix it
jim

Saint Louis, MO

#118 Mar 1, 2014
I have a 2006 Equinox that has been ok and the other day the oil light went on and 5 minutes later I was going up my hill and it started clicking
and was hard to get up the hill. After checking the oil it was very low. I put 3 quarts in and it still sounds the same. I have not driven it. Any suggestions?
Amy

Peoria, AZ

#119 Mar 14, 2014
Dawn T wrote:
I am so tired of all the problems with my 2005 equinox/ I purchased the car used in 2008 and it seemed to run fine with a few misfires upon starting randomly. other thyan that the car ran excellent. In 2009, I went through a car wash and all of a sudden water started pouring into the cabin area and all kinds of bells and whistles went off. I had to have the car towed only to be told that the car needed to "dry out". After a few days I noticed that water had somehow got into the headlamps and will not "dry up" It is still there to this day and all the dealership can offer is for me to replace the entire front end which would cost more than Im willing to pay. Ive had so many repairs done to this car that Im done. Today it rained hard and the car just stopped. The engine had reduced power and once again I had water inside the vehicle and had to sit until it was "dry" enough to drive right. I was thinking about purchasing a new equinox but now Im not convinced I want another one given what Ive experienced and what I have read on this site.
.

I had the same thing happen to mine, and I had purchased my vehicle new at the dealership. I am very disappointed and will not be purchasing another vehicle from chevy
Artie

Bayonne, NJ

#120 Mar 15, 2014
I've been hearing grinding in rear of vehicle. I changed pass rear hub bearing and still getting same grinding. Grinding sound happens only when driving. Does anyone have any ideas on what this could be? I have a chevy equinox 2006.
Thanks
sharon

Detroit, MI

#121 Mar 20, 2014
hello do any one no of a recall on 2006 break problem I have replaced both caliber On both sides twice and both break lines I don't no what's going on the tires and the front feel like they are locked and my seats also were Staind By Water

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Equinox Discussions

Title Updated Last By Comments
2007 Chevy Equinox (Dec '06) Tue PaulJ 400
Turn Signal Question (Apr '10) Dec 13 Tony 02 8
Equinox having trouble starting (Aug '07) Dec 12 esco_mlo 200
2005 chevy equinox problems (Feb '10) Dec 12 GMAN 45
Equinox Central.com --- Owners have posted lot... (Oct '06) Dec 11 Jenny 501
05 Equinox trouble (Sep '06) Dec 10 dissatisfied 220
Water Noise In Dash/Heater Core (2006 Equinox) (Apr '12) Dec 5 dds hamilton ohio 23
More from around the web