06 Equinox - Check Engine Light - Car running too lean, Bank 1

Posted in the Chevrolet Equinox Forum

Kevin

North Haven, CT

#1 Feb 17, 2010
I have a check engine light on. It reads "car running too lean, Bank 1." The car is running fine and it doesnt appear to affect my gas mileage. The light goes on and off as it pleases. Does anyone know what this means?
Bill

United States

#2 Feb 25, 2010
I have the same problem! My mechanic spent endless hours trying to diagnose and fix. He thought it was bad gas or sediment so he replaced the gas tank. He told me to use Gum-out. He told me to use high-octane fuel. He replaced gaskets, a mass airflow sensor, and an air intake vent. It was fine for several months and now the light is back.
Chris

Albuquerque, NM

#3 Feb 27, 2010
Kevin wrote:
I have a check engine light on. It reads "car running too lean, Bank 1." The car is running fine and it doesnt appear to affect my gas mileage. The light goes on and off as it pleases. Does anyone know what this means?
Had the same code. Found the back valve cover vent tube to the air intake was disconnected (very hard ro see). once properly connected I haven't seen the error code again.
tater

United States

#4 Mar 25, 2011
I read the reply about finding a loose or leaking hose for the running lean bank 1 code and found a hose WAS Disconnected reattatched the hose and ran car for a few minutes light has went out thanks for info..............
Judy

Yacolt, WA

#5 Feb 22, 2012
I've had this problem also along with many other major problems. Nox is a nothing but crap. If this is what I'm thinking this is... I'm sorry I don't know the technical terms of it. When I went to have my air filter changed the idiots didn't connect the part/hose back correctly which causes it to come off when you start it up. I spent a year taking it to Chevrolet dealerships and other mech's and they kept trying to super glue it together. Wasn't till I took it to a backyard mechanic that it was fixed. I now change my own air filter to make sure the hose/parts are put back correctly. Sorry if I'm way off on this. But this hose being disconnected cause the vehicle to run like crap.... had to have my top engine injectors cleaned and check engine light constantly on. Sad part is that was nothing compared to all the other problems the equinox has.
ryan c crest

Findlay, OH

#6 Jul 30, 2012
just to let you know the vent tube fixed my 06 chevy thanks

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Equinox Discussions

Title Updated Last By Comments
2005 chevy equinox Nov 23 toyhauler 4
2007 chevy equinox, gas smell Nov 21 ninerboy 1
2006 Chevy Equinox heater blows cool air? (May '08) Nov 21 EquninoxUnhappy 710
Engine Misfire/Sputter (Jan '11) Nov 21 steflynn 91
All-wheel Drive problem in '06 Nox? (Jan '09) Nov 21 free 11
2007 Chevy Equinox (Dec '06) Nov 20 Cas 399
Water Noise In Dash/Heater Core (2006 Equinox) (Apr '12) Nov 18 06 equinox POS 20

Chevrolet Equinox People Search

Addresses and phone numbers for FREE