First Prev
of 2
Next Last
Debbie

Houston, TX

#1 Jan 14, 2010
Has anyone had this problem? My air works, then vapors come from the vents and the air is not cold anymore. When I turn the AC off for about 10 minutes, then turn it back on-it works-for a while. Sometimes the blower won't blow at high levels and recently the heater was on, even though it was on AC. I have taken it to my local Chevy Dealership and they claim it has no"codes" on their diagnostic machine, freon is good-of course they can never get it to fail. They want me to drive around until it fails and bring it in. Now that I've found this forum it seems A LOT of people have AC problems and Chevy knows about it. Any ideas??? They act like I'm crazy when I tell them about it.
Andres

Edinburg, TX

#2 Mar 10, 2010
Yes same problem almost exactly...not sure what it is...
Fran- Langley-BC

Canada

#3 Jul 8, 2010
AC was blowing hot air. Now having a heatwave my husband had to do something for me !!!! Took dash apart nothing to show there. Lifted hood, and there at the firewall , passenger side is a little flap. Lift flap and inside you will find a filter, a proper filter ! Take it out and give it a good blow with air compressor. Ours was full of every dead bug and insect known to man. Replaced filter and Hey Ho my AC now blows cold air instead of hot air. Problem solved. Have to mention, the Chevy.Dealer we phoned for advice did not have the number or the filter in the Equinox manual or computer. He even argued that our Equinox 2006 doesn't even have a filter there ! Well, good news all you with hot air coming from AC = check under the hood, it is amazing what you will find ! Good luck, and hope this helps someone.
Mark Houston Tx

Houston, TX

#4 Jul 5, 2011
I'm haveing problems with my AC also I have 2011 Equinox witj auto air it locks up and won't cool, I took it in and they said nothing wrong with it they took it apart still nothing wrong, but i guess they didnt listen when i said it was the auto air, has anyone else had this problem?
jim bham al

Vance, AL

#5 Aug 3, 2011
I have a 2006 Equinox and ac compressor cuts on and off about every 3-5 seconds but have checked freon and it is NOT low.Tried adding a can but after running for about 3-4 minutes it blew it out the bottom. Has anyone had this problem?
tjohnsontx

Fort Worth, TX

#6 Aug 14, 2011
jim bham al wrote:
I have a 2006 Equinox and ac compressor cuts on and off about every 3-5 seconds but have checked freon and it is NOT low.Tried adding a can but after running for about 3-4 minutes it blew it out the bottom. Has anyone had this problem?
EXACT same problem I am currently having!!! EXACT! Did you get it figured out? If not, has anyone had this issue? I am pretty sure I will have to replace the compressor, but not sure. Help! 06 Equinox
scott

United States

#7 Jul 5, 2012
tjohnsontx wrote:
<quoted text>
EXACT same problem I am currently having!!! EXACT! Did you get it figured out? If not, has anyone had this issue? I am pretty sure I will have to replace the compressor, but not sure. Help! 06 Equinox
I was having the same problem. I took it to chevy they said it was over charged by two lbs! The can gauges he said werent accurate really. They put it at the proper charge and everything is working properly now. Good luck!!
Vanessa

Harlingen, TX

#8 Jul 6, 2012
It could be the AC fan and the electrical line that kicks starts the AC. There are two fans and one of my went out. I notice at first I there was a white fog coming out of the vent with wate particles. My AC wasn't blowing out cold air after about 10 min. when on. I would have to turn it off for a while then turn it back on. Now I have to pay about $750, for the fans and the pig tails (electrial lines) to be fixed. Good luck. I asked the mechanic if this was regular wear and tear, but he said these kind of issues are common with the chevy equinox.
Cindy

Toccoa, GA

#9 Jul 14, 2012
Debbie wrote:
Has anyone had this problem? My air works, then vapors come from the vents and the air is not cold anymore. When I turn the AC off for about 10 minutes, then turn it back on-it works-for a while. Sometimes the blower won't blow at high levels and recently the heater was on, even though it was on AC. I have taken it to my local Chevy Dealership and they claim it has no"codes" on their diagnostic machine, freon is good-of course they can never get it to fail. They want me to drive around until it fails and bring it in. Now that I've found this forum it seems A LOT of people have AC problems and Chevy knows about it. Any ideas??? They act like I'm crazy when I tell them about it.
Debbie, Mine story is exactly the same as yours. I have the same problem. Wish I knew what would fix it.
Amanda

Sumrall, MS

#10 Jul 23, 2012
I too have had this same problem. Got a letter in the mail from the chevrolet company stating that some 2006's have a problem with a specific part... I brought mine in to the local chevy dealership, and all I was told is that "it seemed to be working fine." No, it isn't working fine when ice crystals blow out of the vents after minutes of the air being on, and then it barely blows until you turn it off for a while! They kept my letter and sent me on my way. No answers and still with a faulty air conditioner!
Matt

United States

#11 Jul 25, 2012
I have documented everyone's concerns regarding the air conditioner issues. I would be happy to look into this further if you would like. Please reply to gmcustsvc@yahoo.com and include the your name, VIN, issue, date & location of service appointment, and/or the preferred dealership you would like to work with. I hope everyone's concerns are resolved quickly.

Matt

GM Customer Service
Travis H

Round Rock, TX

#12 Dec 29, 2012
I have had the exact same issues. I have been taking my car to the dealership for several years and I get the same response from the mechanic, either nothing can be found or low on freon. Took it to Firestone over the summer and they said the fan had to be replaced. After paying a little over a grand it worked for a little while and started doing the same thing. Of course Firestone says they can't find anything wrong with it and they claim it blows out temps of 32 degrees. I beg to differ. I have a new born and a wife that were sweltering on our trip to Florida immediately after they had supposedly fixed the issue. Now, winter is here. I have no problem getting cool air and the heater doesn't work. Unfortunately I'm not in the financial position to take it to another shop nor do I have the time and patience to deal with this as it has been ongoing issue. This has definitely been an eye opener on buying a new car...Not Chevy! I like there cars but customer care and denial in flaws of products seem to be an issue.
Chris

Killeen, TX

#13 Mar 11, 2013
Fran- Langley-BC wrote:
AC was blowing hot air. Now having a heatwave my husband had to do something for me !!!! Took dash apart nothing to show there. Lifted hood, and there at the firewall , passenger side is a little flap. Lift flap and inside you will find a filter, a proper filter ! Take it out and give it a good blow with air compressor. Ours was full of every dead bug and insect known to man. Replaced filter and Hey Ho my AC now blows cold air instead of hot air. Problem solved. Have to mention, the Chevy.Dealer we phoned for advice did not have the number or the filter in the Equinox manual or computer. He even argued that our Equinox 2006 doesn't even have a filter there ! Well, good news all you with hot air coming from AC = check under the hood, it is amazing what you will find ! Good luck, and hope this helps someone.
Can you post a pic of the location or email one to ex0dus_begins@yahoo.com. I cannot find this flap.
Chris

Killeen, TX

#14 Mar 11, 2013
NVM, found the flap. Its a cover piece located between the wiendshield and hood. See video
. Do this and blow it out before you do any further AC troubleshooting.
Cassie

Aiken, SC

#15 May 8, 2013
No that doesnt fix it. It only works as a bandaid. We have tried this and it doesnt work. I have videos of it blowing ice chips and white mist out of the vents. GM dealership said we dont know what it is and you have to leave it for a few days to a week for us to tell whats wrong with it. Why do they need my car for a whole week? Secondly there are so many complaints about this until it isnt funny. This needs to be recalled.
C_Haynes

Sugar Land, TX

#16 Jun 21, 2013
I also have this problem. I have been doing a search on Google and it seems to be very common problem for the 06 Chevy Equinox. I agree that this should be a recall issue.
C Haynes

Sugar Land, TX

#17 Jul 1, 2013
C_Haynes wrote:
I also have this problem. I have been doing a search on Google and it seems to be very common problem for the 06 Chevy Equinox. I agree that this should be a recall issue.
After two weeks of talking with Chevrolet/GM on this, I received no help. A word of advice to those people who have this problem with the 06 Equinox: if your car has more than 120,000 miles, you are on your own.
Hendo

Evansville, IN

#18 Sep 4, 2013
I have the same problem. I haven't gone to GM on this one, but my auto guy says its likely in the control unit. I'm going to replace console control unit (the 3 dials for fan control, temp and upper/lower baffling). I found it on RockAuto.com for about $180. Hopefully, that does the trick.
Dan

Palmyra, VA

#19 Mar 2, 2014
I have had the exact same problem with my 2006 Equinox. Suddenly you start to get "steam" coming out of the A/C ducts after the AC has been on for a while. Then very little air blowing from vents. I imagined that there was ice buildup from humidity freezing inside somewhere. My fix is to turn off the compressor by turning it off manually (snowflake button not illuminated). Then turn temp knob to full hot. When air flow returned to normal, heat off, compressor back on and AC is OK for a while. Now its winter and I have NO HEAT at all. I am reading that it may be an actuator switch or a broken air mixing door. If its the door, the whole dashboard will have to be removed to correct it. It is definitely time to abandon ship. The car has otherwise been OK, but who needs to deal with this nonsense?
Larry

Austin, TX

#20 Jun 1, 2014
In my 2012 Equinox there is just a little of cold air blowing out, and on the floor vents it blows out a lot. Can any one help me figure out what is wrong. I have looked at some more answers, but not sure. One says it might be the bell housing, are the vent control arm. I don't know I am no air conditioner man.

Looking for more answers, so I can get it fixed. It has never been a problem before.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 2
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Equinox Discussions

Title Updated Last By Comments
2007 Equinox ignition key not releasing like it... (Aug '10) Mon rick 101
Water Noise In Dash/Heater Core (2006 Equinox) (Apr '12) Mon daughtryfan114 17
2005 chevy equinox problems (Feb '10) Sep 9 James 44
interested- class-action for key ignition issue... Sep 8 Lkelly 3
2010 equinox Sep 8 dave 1
Chevy Equinox - PCM Root of Problems (May '08) Sep 6 Jim 130
Engine Misfire/Sputter (Jan '11) Sep 5 Mrsplachta 87

Buy a New Car


Zipcode:
•••
Enter and win $5000
•••

Chevrolet Equinox People Search

Addresses and phone numbers for FREE

•••