05 Equinox trouble
Kim

Snohomish, WA

#21 Jul 19, 2007
I have 75,000 miles on 05 eq. I have major gear noise from front end. Curious to know if anyone else has same problem!
sam in nh

Las Vegas, NV

#22 Jul 19, 2007
David wrote:
My 2005 Equinox has a knocking noise underneath the front end particularly when I go over pumps.... no one can seem to find the problem
is caused by brake pads
Shannon in MA

Branford, CT

#23 Jul 19, 2007
My 05 Equiquinox, I have had to replace the rotors and pads 3 times in addition to having a new brake system becuase the anti lock brakes were not working correctly, rebuild the engine, replace the water pump, have the electrical system locked me out and I couldn't unlock the car or windows, oh and it makes the loud noise under near as well as loud squeeling when I turn the wheels into parking spaces, turning around.
Jay Northford CT

AOL

#24 Jul 21, 2007
I have an 05 equinox, bought it in 04 and since the day I brought it home it smelled like burning rubber.. I checked the tires and couldn't find anything.Well after 49,500 miles later the right rear tire blew out,,, from excessive wear the left rear tire looked exactly the same... The place where I had tires put on told me they couldn't do an alinement, because the whole rearend of the truck was built wrong and is actually unsafe to drive...I will be contacting the dealer where I bought it from... and a lawyer... SO EVERYONE PLEASE CHECK THE WEAR ON YOUR TIRES,, ON THE INSIDE OF THE REAR TIRES...
jonny

United States

#25 Jul 26, 2007
Shellie from GA wrote:
I bought my Chevy Equinox on Nov 26, 2005, not even a complete two years have passed and I have to get my engine rebuilt. The dealer says its going to cost me $5,000.
sounds like you should be eligible for some assistance on the rebuild given the age of the vehicle. The $5 K sounds high; worth shopping around on that.
Chris-Ont

Crown Point, IN

#26 Aug 2, 2007
Jackie wrote:
<quoted text>
I am really fed up with this car. I love it, but have had so many little (and big) things wrong with it, that its almost not worth the trouble!
At 5,000 miles, the main computer died. What happens is while you are driving, the car just completely shuts off. No power steering. Nothing.
I had to replace the rotors at 10,000 miles.
The connections to the battery had to be replaced as the power would intermittently disconnect, and then reconnect (25,000 miles).
Now, at just over 30,000 miles, I have a major water leak which is coming from the spare tire compartment. Currently, there is over 4 inches of standing water in the compartment. This has run over into my interior. With any luck, I'll be able to get the dealer to replace the soaked carpet. If not, I'm afraid it will start to smell.
I can tell you the leak is coming from the gromets at the back door hatch mine had the same problem and yes it stinks real bad. they took all the back out,replaced wires cleaned it up and siliconed the gromets. It has been 2 months and the smell is still there but not as bad I hope it goes away. As I am typing this letter to you my viechle is in the shop getting the body control module replaced.Also check above the doors on the body where it splits mine and many others that I have seen the paint chips there.Well good luck hope the post helps.
Rob

United States

#27 Aug 7, 2007
June wrote:
I bought an 06 and the key wont turn over so now i have to play with it to go anywhere, the dealer is not helping,
Look at the key. If it is worn, switch to a new one. This happened on my 2005 Equinox. Dealer would not help either...apparently it is MY fault that the ignition wears the key down.
Rob - Kalamazoo MI

United States

#28 Aug 7, 2007
Jay Northford CT wrote:
I have an 05 equinox, bought it in 04 and since the day I brought it home it smelled like burning rubber.. I checked the tires and couldn't find anything.Well after 49,500 miles later the right rear tire blew out,,, from excessive wear the left rear tire looked exactly the same... The place where I had tires put on told me they couldn't do an alinement, because the whole rearend of the truck was built wrong and is actually unsafe to drive...I will be contacting the dealer where I bought it from... and a lawyer... SO EVERYONE PLEASE CHECK THE WEAR ON YOUR TIRES,, ON THE INSIDE OF THE REAR TIRES...
2005 Equinox LT AWD with only 22,000 miles. Tires are down to about 3/32 tread! Rotated at 10k & 18k.
Dealer says supposed to rotate every 6k, not sure GM will help. Ridiculous!
Pop

Ambler, PA

#29 Aug 10, 2007
Nathan Pearce wrote:
Can anybody tell me where the battery location is or is it a dry cell, I am having so many problems with getting it started when the temp outside is in the very low negitives like minus seven
The battery is located on the driver side, under the cover with the three terminals on it. In front of the main fuse box. I believe there are three phillips screws that hold it down.
JOYCE SUMMERVILLE

United States

#30 Aug 11, 2007
I HAVE A 2005 EQUINOX.. MY TAIL LAMPS AND DASH LIGHTS ARE OUT AND WE CAN'T FIND OUT WHY.. WE REPLACED A BLOWN FUSE, BUT THEY ARE STILL OUT..IS THERE A PART WE ARE NOT LOOKING AT?? OUR MANUAL DOES NOT TELL ANYTHING OF VALUE..THANKS
JOYCE SUMMERVILLE

United States

#31 Aug 11, 2007
WHERE ARE THE TAIL LIGHT FUSES OR RELAY LOCATED ???
Jim Miller

Rochester, NY

#32 Aug 16, 2007
Rob - Kalamazoo MI wrote:
<quoted text>
2005 Equinox LT AWD with only 22,000 miles. Tires are down to about 3/32 tread! Rotated at 10k & 18k.
Dealer says supposed to rotate every 6k, not sure GM will help. Ridiculous!
I had the tires replaced at 17000 miles due to excessive wear. Was told by the dealer that this is a characteristic of the vehicle. I called the 800 number in the owners manual and complained. GM paid for a new set of tires. I now have 43000 miles and they are wore out again. I rotate every 8000 miles and paid for a wheel alignment when I got the second set. This car is junk. I'm also on my third set of front brakes. I've always gotten at least 45000 miles on a set of brakes.
ROD

Valdosta, GA

#33 Aug 17, 2007
I have a 2005 Equinox LT AWD. Had to replace tires after 20k do to poor wet performance. Bought new Kumho tires from tires-easy.com alot safer tire for my family. Had to replace front brake disk and pads with performance parts after 39K. Rotors were starting to warp
vicki

Philadelphia, PA

#34 Aug 21, 2007
asw wrote:
<quoted text>
I have the same problem except the sound comes from the rear. Have you had any luck finding out the problem?
Dealer just called and they are replacing the rear clutch wheel on mine - it make the same banging noise
Bmine6988

Parkville, MD

#35 Aug 24, 2007
Has anyone noticed black/silver spots coming up on leather seats?
steve

United States

#36 Aug 25, 2007
I have a similar problem - the first time they replaced the pedal assembly, the second the power train control module and the third the pedal assembly again. Mine is an 06, although it was purchased new in April of 07.
angie wrote:
I've had my '06 Equinox since November and it has been in the shop 8 times. After about the fourth time they started replacing the computer. I am now on computer #4. What happens is all of a sudden my sensor lights come on and the traction control actually comes on. I have to pull over and turn the car off for the traction control to turn off. I have contacted corporate and they don't really seem too concerned. The next call they will be getting is from my lawyer. This is completley ridiculous for a new car. I also hear a knocking noise randomly.
dan

Miami, FL

#37 Aug 29, 2007
Does anyone know how to change the battery in the 2005 chevy Equinox?
Ron Smit

AOL

#38 Aug 31, 2007
Jim Miller wrote:
<quoted text>
I had the tires replaced at 17000 miles due to excessive wear. Was told by the dealer that this is a characteristic of the vehicle. I called the 800 number in the owners manual and complained. GM paid for a new set of tires. I now have 43000 miles and they are wore out again. I rotate every 8000 miles and paid for a wheel alignment when I got the second set. This car is junk. I'm also on my third set of front brakes. I've always gotten at least 45000 miles on a set of brakes.
I had the tires (Bridgestone) on my Equinox 2004 AWD changed at 95.000km-stil not worn out, 2mm
Working Class in Boca

United States

#39 Sep 5, 2007
I HAVE A 2005 EQUINOX: I HAVE 106750 MILES ON IT AND I HAVE NOT HAD ANY MAJOR PROBLEMS. AS ONE CAN SEE I DRIVE ALL OVER SOUTH FLORIDA.

THE ONLY PROBLEMS THAT I HAVE HAD ARE:
1. THE DRIVER DOOR CREAKS WHEN I OPEN IT AND THE DEALERSHIP TELLS ME THAT IS NORMAL.
2. WHEN IT IS RAINING PRETTY HARD, WHEN I STEP ON THE EXCELLIRATOR, IT MAKES A RUMBLING NOISE AND THAT I THINK IS CAUSED BY WATER GETTING INTO THE MANIFOLD.
Smitty

Bismarck, ND

#40 Sep 14, 2007
Rob wrote:
<quoted text>
Look at the key. If it is worn, switch to a new one. This happened on my 2005 Equinox. Dealer would not help either...apparently it is MY fault that the ignition wears the key down.
I just had the same problem with my 05 Equinox. You could actually pull the key out of the ignition when the vehicle was started. My dealer just recut the keys for free but didn't really have an explanation as to why the ignition is wearing the keys so bad.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Equinox Discussions

Title Updated Last By Comments
2007 Equinox ignition key not releasing like it... (Aug '10) 2 hr Angie 122
2006 Equinox AC Problem (Jan '10) Jul 19 Rafaeyari 29
2016 equinox using coolant on the v6 @80.000 mi... Jul 16 Lunchbox 2
automatic door lock problems (Mar '10) Jul 16 Kathy 21
shuts off wwhen driving (Mar '11) Jul 15 Hate my Equinox 8
Equinox air conditioner (Apr '08) Jul 15 Sean Johnson 290
Equinox having trouble starting (Aug '07) Jul 9 Juan rivas 217
More from around the web