fixxxer

Grand Rapids, MI

#421 May 4, 2013
Bought my 2006 in november and it was a good car up until the first hot day here in michigan. Overheating to the red line. $1500 in repairs yesterday and its back in the shop today. I think the head gasket is shot. Not even going to bother after all of the complaints ive seen. Going to get it running as good as i can and go trade it in for a newer car and pay the difference. I also had the crackedd windshiled last month. I cannot believe gm didnt recall this vehicle.
fixxxer

Grand Rapids, MI

#422 May 4, 2013
sandra wrote:
could anyone please tell me where the a/c evaporator is on my 2005 chevy equinox. I can hear water sloshing under my dash and I was told it might me my a/c drain is stopped up
I wondered what that noise was on mine. Thought it was the radiator overflow.
vivian

Perris, CA

#423 May 24, 2013
I am having lots of problems with my equinox 2005, engine blew, water build up in headlights, lose of power in first gear, use lots of gas. I think they need to recall these cars.
tiny

Lafayette, LA

#424 May 29, 2013
vivian wrote:
I am having lots of problems with my equinox 2005, engine blew, water build up in headlights, lose of power in first gear, use lots of gas. I think they need to recall these cars.
i'm having the same trouble with the water in the headlights as well as the car burning alot of gas i fill it up and 3 days later i need more.
Ruth

Columbus, IN

#425 Jun 3, 2013
Have an 05. Replaced the bearing ring that holds up the drive shaft. It was completely gone. What's up with that? Just left the dealer. I need new struts.$286. Car only has 33,500 miles on it. Bought the car new. Just replaced tires last year. Not bad. I really like the car, but, is it going to start falling apart with so few miles on it? Only other thing I've had to do is put it ac Freon last fall. Don't think it helped much. One 89 degree day and didn't seem to cool car down. Air is cool, but not cold like it should be.
tasha

Baltimore, MD

#426 Jun 26, 2013
tim h wrote:
Sae smoke coming from steering column and high beams came on when using left turn signal. Pulled over and turned of signal and smoke stopped. Never recurred. Now high beams ramdomly come on even when car is off causing battery to drain. Any ideas? All works fine if we take the high beam fuse out but then can't drive car at night.
I'm having the same problem with mine now, I have a 2005 chevy equinox and the high beam won't go off or I have to play with it to go off even when I turn the engine off and now my battery is dead. Any solutions?
Carlos

San Rafael, CA

#427 Jul 19, 2013
I bought a brand new 2013 equinox in April and three months and 2,000 miles later I started noticing the interior color of the driverside door losing it's color (black). Presumably because it's the most used door, but 2,000 miles? Has anyone experienced the same problem?
Victoria

Reynoldsburg, OH

#428 Jul 31, 2013
I have a 2013 chevy equinox which I purchased in january. Since purchase I have recurring issue with what seems like it locks up in the back while driving. There seems to be some correlation with that and the front end collision monitor light as it goes off when the back end feels as if it is locking up.
( I am not around anyone when this happens). I have taken the vehicle to the dealership and they are not able to recreate the problem. I have contacted GM with no success for assistance. I am paying for a vehicle that is potentially dangerous to drive and GM refuses to understand that there is a problem with driving it. Nothing shows up on diagnostics. At first I thought it was something I was doing while driving, but my husband has experienced the same problem when driving it.. Has anyone experienced the same issues? if so, have you figured out what to do about it? i am seriously concerned about driving it.
tina

Dayton, OH

#429 Aug 1, 2013
I have a 05 equinox mine just started acting weird.
I have a bad smell and sounds like water running through the vents. Ii just had the coolant flushed. I smell burning antifreeze what can I do any answers.
tina

United States

#430 Aug 4, 2013
tina wrote:
I have a 05 equinox mine just started acting weird.
I have a bad smell and sounds like water running through the vents. Ii just had the coolant flushed. I smell burning antifreeze what can I do any answers.
does anyone know where to file a claim against gm.
Brooks

Montross, VA

#431 Aug 9, 2013
I've had my Nox for almost five years first it had a rattle I took it back to the shop, they said it was something in the stearing , they said "we fixed it " next day still rattling,then the struts now the head gaskets and the dam thing wont start !! I love my equinox but I cant deal with car problems !!! chevy we are not happy with this mess right now !!!!
Brooks

Montross, VA

#432 Aug 9, 2013
tina wrote:
<quoted text> does anyone know where to file a claim against gm.
Idont know tina, but mine started with the running water sounds then it ran hot now the head gaskets are blown.
Terr

Bridgeport, CT

#433 Aug 21, 2013
I have a nox too have all the problem junk junk
JannaInDE

New York, NY

#434 Sep 1, 2013
Omg!!! I have a 05 equinox and share every problem I see posted here! Leaking drainline from sunroof, comes right into my driver and passenger carpets! Very hard knocking noise like my roof is gonna cave in, over bumps! Exhaust smell coming through my vents! Air doesn't run cold unless doing over 40!! TC light came on, lost all acceleration, car wouldn't move, wouldn't start. STUPID CHEVY EQUINOX
JannaInDE

New York, NY

#435 Sep 1, 2013
As well as water in lights!!!!!
JMP

Lawndale, NC

#436 Sep 2, 2013
sandra wrote:
could anyone please tell me where the a/c evaporator is on my 2005 chevy equinox. I can hear water sloshing under my dash and I was told it might me my a/c drain is stopped up
Have you ever found out where this is located??
angela

United States

#437 Sep 4, 2013
Had problems with the abs and raction conrol light coming on. brake peddle gets hard when applied and sounds like grinding. Replaced struts, brakes, rotors and all abs sensors. Finally found a mechanic that knows Equinox and found out it was the abs sensor wiring harness after spending $2005.00. Anyone that lives in the DFW area needs to go see Nick Madalone at Meineke in Haltom City. He knows his Chevs and Fords!!!! Well worth the drive!!!
PROBLEM FIXED
Ray

Farmville, VA

#438 Sep 11, 2013
Victoria wrote:
I have a 2013 chevy equinox which I purchased in january. Since purchase I have recurring issue with what seems like it locks up in the back while driving. There seems to be some correlation with that and the front end collision monitor light as it goes off when the back end feels as if it is locking up.
( I am not around anyone when this happens). I have taken the vehicle to the dealership and they are not able to recreate the problem. I have contacted GM with no success for assistance. I am paying for a vehicle that is potentially dangerous to drive and GM refuses to understand that there is a problem with driving it. Nothing shows up on diagnostics. At first I thought it was something I was doing while driving, but my husband has experienced the same problem when driving it.. Has anyone experienced the same issues? if so, have you figured out what to do about it? i am seriously concerned about driving it.
I am seriously considering buying the 2013 equinox. Has anything been resolved?
Cheryll

Kimberley, Canada

#439 Sep 15, 2013
I have a 2006 Equinox which I bought new in 2006. I only have had one problem and wonder if anyone has had the same trouble. The battery goes dead if left parked for about 5 - 7 days. When I was working full time I never had trouble because it never sat that long !! Now that I am retired it is a real problem. I have had it to the dealer three times and paid a lot of money for them to tell me that my radio is drawing on the battery even when the ignition is off. Their solution -- replace the radio for $800.00 +. I cannot afford that so I took to fuse out and that has solved the draw BUT now I have no interior lights when the door is opened and some of the warning beeps do not work and of course I have no radio or CD player so this is not a good solution. Has anyone else had this problem?
warden

Houston, TX

#440 Sep 24, 2013
art k wrote:
05 equinox that won,t shut off unless you disconnect battery. i'm just trying to rid of this thing i know head gasket is gone but it still runs/drives. when i hook battery back up engine fan runs non stop' all warning lights on dash come on stay/blink and car will try to start its self all while I am holding the key.
PLEASE HELP!!! I just want to trade it in
had same problem. check your cooling system its trying to cool off. mine turned out to be a rusted raidiator

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Equinox Discussions

Title Updated Last By Comments
2005 chevy equinox problems (Feb '10) May 20 Tina 60
Equinox air conditioner (Apr '08) May 18 jake 280
Equinox having trouble starting (Aug '07) May 18 jeff 205
Engine Misfire/Sputter (Jan '11) May 15 crystal 103
Water Noise In Dash/Heater Core (2006 Equinox) (Apr '12) May 14 ali 37
Peeling Paint on 05 Equinox (Apr '11) May 12 Viper 55
2007 Equinox ignition key not releasing like it... (Aug '10) May 11 Deb Parker 114
More from around the web