2005 Equinox squeaking/creaking when turning

Posted in the Chevrolet Equinox Forum

First Prev
of 3
Next Last
Alia

Puyallup, WA

#1 Mar 15, 2010
Just bought this 05 Equinox a few weeks ago and have had some problems with a squeaking or creaking sound when turning (coming from the front end). It did not do it when we test drove it and it doesn't do it all the time. It does do it most of the time though. It is not when I am braking. Doesn't matter which way I turn. The turn does not have to be sharp (it has done it on the freeway on slight curves in the road) and it doesn't matter what speed I am going. It also makes this noise if I go over a bump in the road that is not even such as if one tire goes over the bump and the other does not. Anything where they are not on the same level.

I would say the sound is more of a creaking than a squeaking, but really it could be described as either. The only thing I can compare it to is to say that is sounds exactly like old bed springs.

I did take it to Les Schwab and they said it was my calipers and tried to sell me a whole new brake job. I took it back to the dealer and they said there is nothing wrong with my brakes at all. I know Les Schwab is just trying to sell me crap and the dealer just doesn't want to fix anything so not even really sure if my brakes are ok or not. Don't know if calipers would even make that noise. And btw it rides really nice so I don't think my shocks are shot. Maybe there is something wrong with the strut turn plates. Any ideas are greatly appreciated.
Chet Moore-OH

Defiance, OH

#2 Apr 25, 2010
We also purchased a 2005 a couple of months ago. We are having the same noises that are coming from the front end, sounds exactly like your problem in WA. Help!!
sway bar link

Cincinnati, OH

#3 Jun 11, 2010
Chet Moore-OH wrote:
We also purchased a 2005 a couple of months ago. We are having the same noises that are coming from the front end, sounds exactly like your problem in WA. Help!!
Grease gun with a pin adapter on tip.Stick rubber boot and inject some grease.
sway bar link

Cincinnati, OH

#4 Jun 11, 2010
Chet Moore-OH wrote:
We also purchased a 2005 a couple of months ago. We are having the same noises that are coming from the front end, sounds exactly like your problem in WA. Help!!
P.S.- I had the same prob. with my 05 nox.I got the pin adapter from autozone $5.00 It looks like a needle epoxied onto a zerk fitting.Just stick into the boot a needle in the arm and give it three pumps of grease.
sway bar link

Cincinnati, OH

#5 Jun 11, 2010
sway bar link wrote:
<quoted text>
Grease gun with a pin adapter on tip.Stick rubber boot and inject some grease.
Gee -I am a moron.I forgot to put it is the sway bar link most likely.
Front Stabilizer Links

New Baltimore, MI

#6 Jul 13, 2010
I wanted to add an answer and some additional information to this thread for others that may be having the same issue. My '05 Equinox had this problem turning right and left. At low speeds while turning there would be a creaking noise. In my case, the stabilizer bar links (also called sway bar links) were both bad - the original boots for the joints were split so adding grease as suggested here wouldn't have worked. The only choice was to replace both sides. This is an extremely simple fix that will take you about an hour with normal hand tools and about half if you have an impact wrench. First, purchase new stabilizer bar links. I got mine at Advance Auto Parts - you should note that the Moog parts shown online at Advance do not come with the grease fittings shown. I would have gone to Autozone and paid less if I had known this. I did want the new links with zerks. Cost for both links was about $65.
Jack up the front end and support it so that you can still turn the wheels lock to lock. Remove the wheels. For the passenger side, turn the wheels all the way left so that you have a better angle on the nuts. You'll see the links attached at the sway bar and the strut. On the end of the link bolt, you'll see a socket for an allen wrench - ignore it. On the back side of the mount on both ends of the link just in front of the boots, there are flats for an 18mm end wrench. Use those to hold the link shaft when loosening the nuts. For my Moog replacements, those flats are 17mm. Again, if you have an impact wrench, the nuts will float right off. Remove the p-side link and match it to the new - the links are specific to each side. Hold the flats with your wrench and twist the lock nuts on. The nuts are a special lock nut that cuts into the threads as they're tightened so this will take some time and elbow grease to work them tight (unless you've got an impact wrench - just go buy an air compressor and an impact wrench, you know you want them).
Driver's side is same as passengers. Don't forget to use a torque wrench when retightening your wheel lugs - if you over tighten (about 100 ft/lbs) your brake disks will warp. Learned that the hard way.

Hope this helps others doing google and bing searches on this problem.
Strut mounts

White Lake, MI

#7 Aug 15, 2010
I'm not sure if this is helpful. I have had to have both strut mounts replaced for my 2005 equinox. It cost around $250 at the chevy dealership. Once replaced, it DID make a world of difference. I didn't hear the noise any more. I am currently having the problem again and think that strut mounts may be a possibility. But I'm going to take it to another mechanic just to be sure.
Lisa

Wheaton, IL

#8 Aug 19, 2010
I'm having the same problem. Except now it sounds like my wheels jiggle when I hit a bump. I went to the Chevy Dealer and they said that I need: My front struts and strut mounts, and stab links replaced along with an alignment total price $1475. RIDICULOUS. Went to a local place told them what was wrong quoted $750. Not sure if all items really need to be fixed. My alignment doesn't feel off at all.
Kim

Orlando, FL

#9 Feb 4, 2011
I have a 2008 sport model that was doing this same thing. I took it to a GMC dealer and after 4 visits and many parts replaced it's not making that noise anymore! Strut mounts replaced, swey bars tightened, and finally a GM engineer had to get involved! I think they changed out everything in the front end. Thank god for warranties.
Drjay

Idaho Falls, ID

#10 Jun 11, 2011
sway bar link wrote:
<quoted text>
Grease gun with a pin adapter on tip.Stick rubber boot and inject some grease.
Having this problem and need to fix. Where is the rubber boot located? Can you give more info please?
Peter

Plymouth, MN

#11 Aug 18, 2011
Alia wrote:
Just bought this 05 Equinox a few weeks ago and have had some problems with a squeaking or creaking sound when turning (coming from the front end). It did not do it when we test drove it and it doesn't do it all the time. It does do it most of the time though. It is not when I am braking. Doesn't matter which way I turn. The turn does not have to be sharp (it has done it on the freeway on slight curves in the road) and it doesn't matter what speed I am going. It also makes this noise if I go over a bump in the road that is not even such as if one tire goes over the bump and the other does not. Anything where they are not on the same level.
I would say the sound is more of a creaking than a squeaking, but really it could be described as either. The only thing I can compare it to is to say that is sounds exactly like old bed springs.
I did take it to Les Schwab and they said it was my calipers and tried to sell me a whole new brake job. I took it back to the dealer and they said there is nothing wrong with my brakes at all. I know Les Schwab is just trying to sell me crap and the dealer just doesn't want to fix anything so not even really sure if my brakes are ok or not. Don't know if calipers would even make that noise. And btw it rides really nice so I don't think my shocks are shot. Maybe there is something wrong with the strut turn plates. Any ideas are greatly appreciated.
I, too have an 05 Equinox with the crunchy crackling sound coming from the front end and it was the calipers which hold the brake pads and not the brakes, with the car up on the lift, I was shown how the bolts had worn down and simply grabbing the caliper in my hand I was able to wiggle it on its mounting which should have been solid.$300 later no noise.
Peter

Plymouth, MN

#12 Aug 18, 2011
I, too have an 05 Equinox with the crunchy crackling sound coming from the front end and it was the calipers which hold the brake pads and not the brakes, with the car up on the lift, I was shown how the bolts had worn down and simply grabbing the caliper in my hand I was able to wiggle it on its mounting which should have been solid.$300 later no noise.
lou

Brampton, Canada

#13 Aug 27, 2011
where can i buy quick struts for a 2005 equinox
delosrec

United States

#14 Nov 8, 2011
Hello Yawl,

I have read most of posts and I dont see my particular problem.

I have 05 Equinox LT and I hear squeaking noice coming from the front end but only when I am making a right turn. It does not occur when I am making a left turn. Any ideas?
Ryan

Canada

#15 Nov 15, 2011
delosrec wrote:
Hello Yawl,
I have read most of posts and I dont see my particular problem.
I have 05 Equinox LT and I hear squeaking noice coming from the front end but only when I am making a right turn. It does not occur when I am making a left turn. Any ideas?
It is most likely your stabilizer link. IT's a short bar made of metal that bolts to your strut and down to your lower suspension. I just replaced one on mine that made the exact same sound. It is very easy to change and the part is about $50. You just have to figure out which side - can be hard to tell. Almost worth it to change both unles you know for sure.
Danny

Buffalo, NY

#16 Nov 21, 2011
lou wrote:
where can i buy quick struts for a 2005 equinox
are there any ? I have been trying to find some and nothing
Cassy

United States

#17 Jan 3, 2012
OMG well this is my first car ive had it for two yrs now and its making that squeaking sound and im scared cuz at the moment im traveling idk what to do im havin the same problem as you all are?? how wierd
Same old guy

Elizabethtown, KY

#18 Feb 18, 2012
Alia wrote:
Just bought this 05 Equinox a few weeks ago and have had some problems with a squeaking or creaking sound when turning (coming from the front end). It did not do it when we test drove it and it doesn't do it all the time. It does do it most of the time though. It is not when I am braking. Doesn't matter which way I turn. The turn does not have to be sharp (it has done it on the freeway on slight curves in the road) and it doesn't matter what speed I am going. It also makes this noise if I go over a bump in the road that is not even such as if one tire goes over the bump and the other does not. Anything where they are not on the same level.
I would say the sound is more of a creaking than a squeaking, but really it could be described as either. The only thing I can compare it to is to say that is sounds exactly like old bed springs.
I did take it to Les Schwab and they said it was my calipers and tried to sell me a whole new brake job. I took it back to the dealer and they said there is nothing wrong with my brakes at all. I know Les Schwab is just trying to sell me crap and the dealer just doesn't want to fix anything so not even really sure if my brakes are ok or not. Don't know if calipers would even make that noise. And btw it rides really nice so I don't think my shocks are shot. Maybe there is something wrong with the strut turn plates. Any ideas are greatly appreciated.
Hello iam haveing the same problems did you find the problem i would like to know Thanks.
Same old guy

Elizabethtown, KY

#19 Feb 18, 2012
Hello any iam haveing the same squeaking sounds an creaking in my 05 Equinox when i steer to the right. is it the sway bar links or someting else i need some Advice Thanks.
Same old guy

Elizabethtown, KY

#20 Feb 18, 2012
anyone know?

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 3
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Equinox Discussions

Title Updated Last By Comments
05 Equinox trouble (Sep '06) 6 hr Lamar 222
Equinox Central.com --- Owners have posted lot... (Oct '06) Dec 24 Robf1988 503
oil leak after oil change at dealership (Oct '13) Dec 23 narthur1 2
2006 Chevy Equinox heater blows cool air? (May '08) Dec 21 Philly 713
Chevy Equinox - PCM Root of Problems (May '08) Dec 16 Jr E 135
2007 Chevy Equinox (Dec '06) Dec 16 PaulJ 400
Turn Signal Question (Apr '10) Dec 13 Tony 02 8
More from around the web