2003 Cavalier - Check Engine Light!

2003 Cavalier - Check Engine Light!

First Prev
of 4
Next Last
Joai

Bellefonte, PA

#1 Oct 1, 2007
Ok, this is a bit of a long story. About a month and a half ago, my check engine like and low trac lights came on, as I sat at a bank. I took it to a dealership to be told that my 4th valve was misfiring, and the best bet would be new spark plugs. So, I got that done. A month later, as I was driving down the road, my check engine light came on .. AGAIN! I took it to a different dealership, and the same thing was happening and suggested spark plugs, but after I had told them that I just had new ones put in, they decided it was the module - so that got replaced. Then 3 days ago, the light comes on AGAIN! The car runs fine - no loss of power or anything. This time we took it to my fiance's garage, who looked the car over and couldn't see anything 'serious'. They reset the light - so it currently isn't on, but who knows how long that will last. Any suggestions??????
Saviolidis montreal

Verdun, Canada

#2 Apr 4, 2008
I have same problem..My mechanic says it is a leak in one of the vacumm hoses. i just spent 700$ having my water pump and head gasket changed...and problem reoccured..i'm going to get it scanned at another garage....also check your gas cap
chris

United States

#3 Apr 4, 2008
go to a parts store and get a code reader, should cost about 60 bucks. read the manual, and you'll know if the dealer is trying to screw you...your car is over 5 years old, it's pretty sure that the problem is in the emissions system....the injectors and hoses will remain a constant problem, not one that recurs after a while. Those water pumps leak, and the only problem may be a stuck code...will replace my girlfriends water pump monday, but only because it is the kife expectancy of that part. but do check your serpentine belts, and timing belts.......have the code checked at the parts store, for free, the dealer is not there to screw you, but they have to follow diagnostic procedures, which will cost you a fortune. many reliable mechanics out there, but you have to shop for them.
Bill

Schaumburg, IL

#4 Apr 14, 2008
2003 Chevy Cavalier.
Check Engine Light kept lighting up...
Mechanic kept resetting it.
Bought a new gas cap 64,000 miles on my car.
Mechanic reset the light and it never came back on. Hopefully this helps.
buddy

Horseheads, NY

#5 Jun 17, 2008
check your o2 sensor my check engine light flashes on and off all the time and if you have an after market air intake then the sensors screw up more for some reason...
Getizzyback

Kingsport, TN

#6 Aug 26, 2008
If you get the car scanned here are a few codes I have come across:

Po122 = Throttle Position Sensor (TPS), I here it's about 30 dollars.

Po128 = Has something to do with the thermostat

Po440 = Has something to do with EVAP. Some people have discovered a white ground wire which has a 10 inch 2 wire harness often breaks.This wire connects the EVAP Module which is located next to the fuel filter.Harness GM part:22687059
Branden

United States

#7 Sep 21, 2008
I have a 2002 cavalier and my check engion light has been on for 2 months. I had it scanned and it said my 4th valve is misfiring. I brought it to the shop and they had it for a week. They checkd the spark plugs witch i had also replaced, they replaced the fireing module, they contacted chevy who said they had problems with the fuel rail, but none of that worked, my mechanic said it might be the valve in the head that could be sticking. If anyone had the same problem and got it fixed let me know.
russell

New York, NY

#8 Sep 21, 2008
my 2000 had the check engine light my shop refered my to a shop to have the vaccum lines smoked they found that a module next to the gas tank was stuck in the open position. Had it replaced for $60 the smoke was $45 car runs great
Willie

Little Rock, AR

#9 Sep 22, 2008
I've been screwed too often by the BS check engine light. If there is a serious problem, the Service light should come on.

Last time I had a check engine light investigated (which occurred on my way home from having a repair done at the dealership), I was given my car back and they said it was 'fixed'. I asked what the problem was and they said 'maybe the gas cap was loose'. MAYBE? They didn't even know what they 'fixed'. Amazing. Never going back to a Chevy dealer. They're crap.
Brenda

De Pere, WI

#10 Oct 17, 2008
My check engine light comes on at least 4 times a year on my 2002 Chevy Cavalier. Each time I take it in they find nothing and just reset it. It's really quite annoying and makes you want to ignore it completely. It makes you realize how important it is to find a mechanic you trust (which is almost never at a dealership).
Jenn

Phoenix, AZ

#11 Nov 16, 2008
Maybe you went to a different gas station...

I noticed my "check engine" light up on my 2003 Cavalier one day, so I looked at the manual. It said something about checking the gas cap. In fact, I went to a different gas station a few days before it lit up and then it simply turned off. It wasn't anything to worry about. It has lit up a few times and it has only done so when I go to different gas stations.

I hope that's all it meant for you, too.
daniel

AOL

#12 Dec 2, 2008
I have a 2003 chev caliver gas light came on at like 55,000 and i took it to a autzone and they said it could be a couple of things like a vaccaum leak or the gas cap sure enough it was the gas cap. And like two days ago it came back on again and know i have like 67,000 and took it again to autzone they tired to tell me it had a vaccaum leak i said i know it has to be the gas cap sure enough it was the gas cap again. 8609
ChevyCavaletter

Gilbert, AZ

#13 Jan 9, 2009
We've had several problems with, and spent alot of money on, our 2002 Chevy Cavalier recently. Replaced fuel pump, then Catalytic Converter then a condenser unit and the battery in between all that. The "Check Engine" light won't go out. The NAPA people checked it out, it shows no problems and are now telling us that us that they talked to someone at GM and they said it's not uncommon for the Check Engine light to stay on for up to 150 miles after you've fixed the problem. Does anyone know anything about this?
RAIF

AOL

#14 May 2, 2009
Saviolidis montreal wrote:
I have same problem..My mechanic says it is a leak in one of the vacumm hoses. i just spent 700$ having my water pump and head gasket changed...and problem reoccured..i'm going to get it scanned at another garage....also check your gas cap
I have 210999 on my Cavalier oil filters tires, belts and brakes. My engine light came on at 200,500 or so, Checked out to be a vacumn leak. The car runs great mileage 30 plus. The light is on again after we reset it but no issues...I may poke it out!!!! Go Chevy 210999 and still going! Lets see a hocus pocus focus do that....
RAIF

AOL

#15 May 2, 2009
I have 210999 on my Cavalier oil filters tires, belts and brakes. My engine light came on at 200,500 or so, Checked out to be a vacumn leak. The car runs great mileage 30 plus. The light is on again after we reset it but no issues...I may poke it out!!!! Go Chevy 210999 and still going! Lets see a hocus pocus focus do that....
jim

AOL

#16 Jul 16, 2009
We bought 2003 Cavalier LS coupe new...now has 178000 miles. Service engine light and traction off light have been on since 2 hours after buying the car. Runs great..wiring harness was changed 2 times under waranty...reset couputer at least 50 times..chevy has no idea what the problem could be......LOL......will just keep driving it til the wheels fall off
Bobby B

Asheboro, NC

#17 Aug 13, 2009
have a friend that has a 2000 cavalier check engine light has been on sence he bought the car about 1 year ago has just started flashing and now car idles rough and run rough at any speed went to autopart store to have put on computer to give me some idea what it might be but no one can acsess the computer on the car they plug in and nothing happens so decided to change spark pluggs & wires still does the same thing any help would be aprecitive
TABN Fleenor

AOL

#18 Aug 24, 2009
I have a 2002 Cavalier LS 2.2 ecotec, drove to work Thursday, ran excellent, got off work, barely got it started. Drove it less than a mile, wouldn't hardly run. Parked it, catalytic convertor was glowing red on the outlet side. Ran scan, pulled code 300, random cylinder misfire. Replaced plugs, coil pack, cut open catalytic convertor to check for blockage. Now it wants to run very rich. Can smell fuel at the tailpipe.Still have check engine light. Anybody got any ideas?

Since: Jun 09

Yucca Valley, CA

#19 Aug 24, 2009
You didn't mention what you found when you cut open the CAT. When a CAT fails, it's usually a quick death. The ceramic monolith in the CAT melts and retricts exhaust flow, causing back pressure in your motor. That in turn sends conflicting signals to the PCM which controls the sensors to run your engine smoothly and causes a loss of power. First thing you need to do is check your CAT. I'd replace it if it was glowing red. After that, reset your PCM by disconnecting the negative side of your battery for about a minute. That should reset your codes and turn out the CHECK ENGINE light. There are many other things that could be wrong but with limited info, this is the simplest.
TABN Fleenor

AOL

#20 Aug 25, 2009
Terrytoon wrote:
You didn't mention what you found when you cut open the CAT. When a CAT fails, it's usually a quick death. The ceramic monolith in the CAT melts and retricts exhaust flow, causing back pressure in your motor. That in turn sends conflicting signals to the PCM which controls the sensors to run your engine smoothly and causes a loss of power. First thing you need to do is check your CAT. I'd replace it if it was glowing red. After that, reset your PCM by disconnecting the negative side of your battery for about a minute. That should reset your codes and turn out the CHECK ENGINE light. There are many other things that could be wrong but with limited info, this is the simplest.
OK, next stupid question, would that cause the #1&4 cylinders to misfire? That is the only trouble code that comes up. I changed the coil pack, thinking that the coil that fires those cylinders was bad. No luck. You can smell a strong gas smell at the tailpipe. Almost like it is pouring out the exaust. I was wondering if my ignition module might be bad, but nobody can test it.

Tell me when this thread is updated:

Subscribe Now Add to my Tracker
First Prev
of 4
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Cavalier* Discussions

Title Updated Last By Comments
service light stays on (Jun '06) 53 min Coolnick46 99
Cavalier engine swap/interchange (Mar '07) 12 hr Big Al 253
obd wiring Mon Year 2
Cavalier automatic transmission won't shift int... Aug 18 Walls23 1
Abs Jul 25 mernzen54 1
turn signals not working on 94 cavalier (Dec '06) Jul 24 Ray simone 10
brake lights stay on when the car is off (Aug '06) Jul '17 Ben young 154
More from around the web