1991 Pickup 4.3L S10 - acts up af...

1991 Pickup 4.3L S10 - acts up after 8 to 10 minutes and stalls out.

Posted in the Chevrolet Blazer* Forum

Rod

Spanaway, WA

#1 Mar 2, 2011
Just got a truck, and trying to figure out what is going on with it. It starts up just fine, and sounds like it is in tune. After driving it for 8 to 12 minutes it starts missing, and does not want to idle, you have to rev it up to keep it going at a stop sign, sometimes it will still stall out. It starts back up and then keeps acting up, if you let it sit for an hour or so then it will again drive great for about 8 to 12 minutes before acting up. Engine and tranny seem strong... any ideas on what is going on?

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Blazer* Discussions

Title Updated Last By Comments
Blazer won't go up hills (Aug '17) Apr 9 ralph 4
Blazer 4 wheel drive problem (Feb '07) Apr 9 Nate 568
News Ask the Auto Doctor (Mar '06) Feb '18 Seduciary 1,559
Gas Gauge Malfunction (Sep '06) Feb '18 Tom 91
Rear window and horn quit working and I checked... Feb '18 Escapegoat973 1
2002 blazer vacuum lines (Jun '09) Feb '18 Jimbo 24
97 blazer with stuck key in ignition (Jun '07) Jan '18 Jesse 40