Comments
1 - 20 of 27 Comments Last updated Saturday Aug 23
First Prev
of 2
Next Last
steve

Alliston, Canada

#1 Aug 17, 2009
We were driving down the highway, the rpm dropped to an idle, all of the warning lights came on then the engine shut off, and coasted to a stop.
Got it back home, tried starting it and the started is not engaging the engine, but the solenoid engages when jumped. We have checked the engine codes and its reading, a knock sensor code. Checked the timing belt, the fuel system, tried bump starting it, and called GM dealer, the technician had no idea what it could be.
Does anybody have any ideas, or thoughts on where I could start looking. I don't have a lot of money so would like to avoid taking it to the dealer.
Harold

Indian Trail, NC

#2 Aug 25, 2009
The solenoid engages what about the starter itself...if not then I`d say remove the starter and take it to a local auto parts store...most do a free test
steve

Canada

#3 Aug 30, 2009
thanks for the input. However.. The starter I doubt is the root issue. The starter is spinning and not engaging so the solenoid would be the problem but i have checked the solenoid already and ruled it out. I believe there is a safety switch in the computer keeping the starter from engaging because something else is telling the computer there is a problem. I am trying to find out what that could be.
Harold

Indian Trail, NC

#4 Aug 31, 2009
So the motor is turning over when the starter is engaging?
Jim

Halifax, Canada

#5 Oct 10, 2010
Steve, I have an o4 aveo as well and what you describe in your posts is the exact problem I have right now. I don't think its the starter and I believe you were right in your guess that the computer is telling the starter not to engage for whatever reason. I noticed your post was a year ago and I was wondering if you found out what it was. Any information would be greatly appreciated. Thanks

Jim
rjnodine@gmail.com
Jim

Halifax, Canada

#6 Oct 18, 2010
Replaced the starter over the weekend and the problem is the same. A new starter, not used, so the chances of a new starter being bad is very slim. The starter winds out but des not engage the engine so the engine is not even trying to turn over. Anybody with any ideas?
Jean

Dartmouth, Canada

#7 Nov 1, 2010
Just stumbled upon this site. The problem seems to be a lack of current going to the solenoid itself. Was the small wire going to the solenoid verified for power/continuity?
jim

Mount Morris, MI

#8 Nov 1, 2010
replaced the starter and turned out to be the timing belt the whole time. the tensioner broke causing the belt to slip on the crank shaft. replaced the belt, tensioner and water pump.... now have bent valves.... my car is yellow... they all should be because they are all lemons
mcthumber

Gardner, MA

#9 Nov 1, 2010
Jim,

How many miles on your '04?

Since: Feb 10

Lowell, MA

#10 Nov 4, 2010
Actually I meant to ask Jim from San Jose-- how many miles on your car?
Jim

Halifax, Canada

#11 Nov 10, 2010
I have 60,400 miles on my '04 Aveo. Just got her back last night... all valves were replaced as well as the lifters and head planed down. She works good now but I wouldn't suggest anyone go over 50 thousand miles before changing the belt, water pump and tensioner. That part of the job cost me just under $300. I bought the car used and was never aware of the timing belt issue. Instead it cost original $300 plus $850 for the head rebuild and $550 labour for a total of $1700. I really think Aveo owners should band together and get a class action suit against GM.
Jim

Halifax, Canada

#12 Nov 10, 2010
apparently Jim in San Jose and Jim in Halifax are the same person.... its all my posts but for some reason my location changed...I am in Halifax,Nova Scotia, Canada

Since: Feb 10

Lowell, MA

#13 Nov 10, 2010
Hi Jim/jim--

From everything I've seen and read, the '04 & '05 Aveos had inferior timing belts that tend to fail early.

I have an '06 Aveo LS and just changed the timing belt/tensioner/water pump at 50,000 miles and the belt was still in good condition, no cracks or wear.

I'm not sorry I did it early as I'd rather be proactive about the issue than get stuck with a big repair bill.

Yes, Aveos are inexpensive cars that have some known issues but owners just need to be vigilant about learning what to look for (just Google "Aveo problems" to start learning) and do what needs to be done in a timely fashion. I know many people who own Volvos, Audis and other high end cars that experience issues that cost a lot more to fix.

My wife also has an '05 Aveo with 36,000 miles on it so between us we have 88,000 issue-free miles on 2 cars we paid a total of $23,000 for. I'm pretty happy with that.
Ohio

Cleveland, OH

#14 Apr 10, 2011
2005 Aveo, 112,381 miles

Got the car new. Only problems so far were head lamps going bad. and radiator lines. Now its sitting in a lot waiting for tow truck. sounds like solenoid or computer. Other then that its been a great car. Ive taken it across the country and into canada from Ohio. The tires are expensive due to size being considered ( high performance size) Funny !
Its not the Dodge Ram I have now, but its been a good runner for past 6 years.
DavidEast NBCanada

Fredericton, Canada

#15 Apr 27, 2011
We have a 2004 Aveo that finally cacked on a two-lane bridge during major construction - also had a timing belt that broke/came loose..........BUT it was NOT the first issue we experienced w the car - O no! Found out a few years back out Chev was really a Daewoo..........hmmmm
Denise

Phoenix, AZ

#16 Jul 10, 2012
I LOVED my '05 Aveo...until this past winter when the thermostat housing broke while going 70 down the interstate!
$2550.00 later it's ok....has been for the past 5 months or so, but now has begun shutting off just after starting smoothly...."just have to get home", I tell myself. Then it goes days until it does it again?! STUPID car...only has 77,000 miles on it and has a million new parts in it from when it blew up on the freeway?! I will never buy CHEVY AGAIN.
I would love to CLASS-ACTION GM....anyone?
woman of god

Charleston, WV

#17 Nov 14, 2012
I own a a chevy aveo and it ran really good at first, the fuse block went bad. im paying for something i cant drive . we need to form a group and sue gm
steve wrote:
We were driving down the highway, the rpm dropped to an idle, all of the warning lights came on then the engine shut off, and coasted to a stop.
Got it back home, tried starting it and the started is not engaging the engine, but the solenoid engages when jumped. We have checked the engine codes and its reading, a knock sensor code. Checked the timing belt, the fuel system, tried bump starting it, and called GM dealer, the technician had no idea what it could be.
Does anybody have any ideas, or thoughts on where I could start looking. I don't have a lot of money so would like to avoid taking it to the dealer.
woman of god

Charleston, WV

#18 Nov 14, 2012
We as owners of chevy need to form a lawsuit and sue gm. My chevy aveo is 2000 dollars to be repaired. please tell me how and i will start the proceedure
chris

Oklahoma City, OK

#19 Apr 10, 2013
Dude it gave you a knock sensor code fix that it might start. Duh.
Jen

United States

#20 Apr 27, 2013
I have an '04 Aveo and have gone through the same thing twice with the timing belts each around 65-70K. The first time I took it to a mechanic this time my bf is doing it and we sent the head to be redone and he put it in but needs some help on how to do the valve job to get it running again. Anyone have any help??

Tell me when this thread is updated: (Registration is not required)

Add to my Tracker Send me an email

First Prev
of 2
Next Last

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Aveo Discussions

Title Updated Last By Comments
09 Chevy aveo won't start (Feb '13) Aug 29 Irfan 12
Chevorlet Aveo 2009 Not starting Aug 29 Irfan 1
the chevy aveo's big secret power all owners mu... (Oct '08) Aug 25 I love my blue aveo 336
Chevy Aveo 2007 Aug 25 GM Customer Service 2
Trouble filling gas tank (Nov '06) Aug 23 Jay 441
GM recalling 1,968 cars for braking defect Aug 14 laura ryals 1
2005 Chevy Aveo-Maintenance and Timing Belt! HELP (Nov '11) Aug 9 David 17

Buy a New Car


Zipcode:
•••
Enter and win $5000
•••

Chevrolet Aveo People Search

Addresses and phone numbers for FREE

•••