James Sydney Nova Scotia

Antigonish, Canada

#21 Feb 23, 2009
I just swapped motors in a 2004 Aveo that had a stripped timing belt and from what I've seen I have to say the AVEO is a big BOO BOO...GOOD WORK GM.
John

United States

#22 Apr 27, 2009
dnick wrote:
FYI folks,
I went ahead & got a 2006 engine at a local junk yard, and the head & block are exactly the same. BUT, the valve cover, intake manifold, throttle body, etc. are different (has "drive-by-wire" throttle). So all I had to do was take my old intake system off & put it on the newer engine. Still working on getting it back in the car (lots of clean up of old parts), but looks good so far. No problem using the newer (06 or 07) block/head.
:-)
I was wondering if you ran into any other issues with that engine replacement. I have a 2004 that I wil be replacing with a 2007. Thanks for you help.
Bill

Cleveland, OH

#23 May 26, 2009
Kim Smith wrote:
I just took my 2004 Aveo in because the engine was running rough. They just informed my that the engine needs to be replaced. I only have 67,000 miles on the car! A car engine should last longer than 4 years! I guess I bought a disposable car....
Same problem with mine. Was told that timing belt should have been replaced at 60,000,,,,but I was not told until after it broke,,,,so it broke and damaged engine (needs replacing). Who would design a piece of crap like that. GM shame on you!!
brad40

Montgomery, AL

#25 Jun 9, 2009
So Pablo thinks aveo's are good cars. Funny, I am seeing more bad than good. My daughter also has/had a 2004 aveo. Timing belt broke at 36,000 miles.$1200 later that was fixed, then two months later the engine blew. Yes, maybe the dealership messed something up when they repaired it the first time, good luck with proving that though. More likely, they used the crappy factory parts and the engines are just crap. You cant shine a turd....Now we owe the bank money for a car that doesn't run...it has been one problem after another. If you want a cheaper "throw away" car, go with an older honda or toyota,,,,stay away from this 3rd world crap
Lakeside GTP

Joliet, IL

#26 Jun 10, 2009
You can not put a 2006-2008 cylinder head on a 2004-2005 block because the 06-08 had an extra oil galley in the block and head. If you replace the entire long block and swap over your old intake manifold I believe it will fit just fine.
Brad from Canada

Port Perry, Canada

#27 Jun 29, 2009
Daniel wrote:
new enegine from the junk yard"
If you are looking to spend anywheres from 800 to 1200 for a used engine thats the way to go!!!!!

I am just replacing valves and away I go...

baught the car after the timing belt went for cheap and hope to fix and drive or sell.
Lugar3

New York, NY

#28 Aug 13, 2009
Just bought a 2004 with 50K for 1,000 going to do swap to 2007 engine as well. wish me luck
Dan

Olds, Canada

#29 Sep 1, 2009
Carol wrote:
Took my 2004 Aveo into the shop back in Feb 2008 because the engine light kept coming on. I was told that it was bad gas, they put fuel injector cleaner in the system & reset the codes.(Hmmm I shouldn't have to add anything to my fuel for my car to run properly) The code was a random misfire they said happened at 10k. Recently my car rolled over to 30k, suddenly the car was driving really rough. Shaking when waiting at lights or during acceleration. Would constantly get a flashing engine light. Took into the dealer and was told it was fuel injector #2. They told me it was all good to go and went to pick it up. Got only a block away before the engine light came on, took it right back. Now the car has been in the shop for a week. They are going back and forth with the manufacturer. The last engine light set a code about the transmission. They have since changed out the gas cap and now are stating some wires & possibly the whole electronic module needs to be replaced. hmmmmmmm i have checked out many of these discussions online about the aveo and many of them were talking about the exact same things happening. I'm really concerned about all the postings about the timing belt snapping right before the warranty expires or right after (soo around 50-60k). I have a feeling that once this gets fixed, I'm going to be searching quick to get something new before something else breaks
its actually quite common, depending where you get your fuel, to develop a clogged injector or two. The additive they used is a fuel injector cleaner.
And the timing belt interval for this 1.6L DOHC is indeed 60000km.
Dan

Olds, Canada

#30 Sep 1, 2009
Bill wrote:
<quoted text>
Same problem with mine. Was told that timing belt should have been replaced at 60,000,,,,but I was not told until after it broke,,,,so it broke and damaged engine (needs replacing). Who would design a piece of crap like that. GM shame on you!!
Check your owners manual for your timing belt interval schedule..... And most late model OHV engines are designed to be an "interference" engine... meaning that if you dont change your timing belt when it says to, when the belt fails the likelyhood of piston to valve contact is high....
Dan

Olds, Canada

#31 Sep 1, 2009
brad40 wrote:
So Pablo thinks aveo's are good cars. Funny, I am seeing more bad than good. My daughter also has/had a 2004 aveo. Timing belt broke at 36,000 miles.$1200 later that was fixed, then two months later the engine blew. Yes, maybe the dealership messed something up when they repaired it the first time, good luck with proving that though. More likely, they used the crappy factory parts and the engines are just crap. You cant shine a turd....Now we owe the bank money for a car that doesn't run...it has been one problem after another. If you want a cheaper "throw away" car, go with an older honda or toyota,,,,stay away from this 3rd world crap
Read your owners manual!!!!!! and maint. schedule!!!!! jeez
Dan

Olds, Canada

#32 Sep 1, 2009
Brad from Canada wrote:
<quoted text>
If you are looking to spend anywheres from 800 to 1200 for a used engine thats the way to go!!!!!
I am just replacing valves and away I go...
baught the car after the timing belt went for cheap and hope to fix and drive or sell.
wow, i'm doing the same!!!!
don

Newmarket, Canada

#33 Sep 21, 2009
I have a 2004 aveo, im having problems with the day running light sometimes when i start it its on another time its not. if i play with the head light switch sometimes it will stay on. Can anyone out there give me some advise?????
Sweetpea

United States

#34 Sep 25, 2009
Fiance has a 04 Aveo. Luckily his was idling when the timing belt stripped about 10 teeth. So we got it towed and was told timing belt broke.$3000 in repairs...so we said goodbye and leave my car out front. We have a mechanic who said $1500 so he came a towed it...put in new valves...16 I believe...Still wouldnt work. It isnt giving any signals to any computer he conects to it. He has changed every sensor and even the 2 coil paks...but he isnt getting any fire. The weird thing though is that he was able to start it a couple times but once it warms up it shuts off. Any suggestions?!? Been missing the Aveo for 7 weeks now. We had to buy a used car for my fiance and still borrowing my parents car for me to use.

If you think you can help dont hesitate to e-mail. Im ready for some good advice. Thanks!
sweetpea1_8_85@yahoo.com
Kentuckygirl

Mount Sterling, KY

#35 Oct 13, 2009
I had the same issue, we just replaced the timing system and had to get the head redone, now it will not start, called chevy they are saying that it may be a code that was thrown from the anti theft. We can get it to run but for only 30 secs, seems like it is the fuel injectors not firing. Really do not know what to do with it now. Is any one else had this problem?
dbennett

Cheyenne, OK

#36 Oct 21, 2009
How is the car doing now? Did you run into any notable problems with changing everything over?

Thanks
dnick wrote:
Hi all,
Well, got the engine replacement done on Tuesday, and she's running great.'Got a bit of a scare when we started her up,'cause there was a good amount of valve rattle - sounded like maybe we got a older engine than planned. But, turned out it just took a few minutes of running (actually a couple of miles of driving) for the lifters to get loosened up. They had probably been sitting undisturbed for a few months in that junk yard & just needed to get pumped back up again. Also had a hefty amount of smoke when we started her up, due undoubtedly to the oil in the exhaust system that had been stoking out through cylinder #1 where the piston had broken down to mush in the old engine. That cleared also after several miles of driving also. Now she purrs like a near new car .... all except for the failure to shift into 4th gear. FYI, I discovered after some research; you need to have the dealer (or someone with a diagnostic scanner) do a "Crankcase Position Variation" relearn task. That's why it won't shift to 4th. This programming is no big deal, but has to be done whenever an engine or certain other sensors/parts are replaced.
Summary: 2006/2007 Aveo engine block & head are interchangeable with 2004/2005 types. Intake manifold (& mounted sensors/fuel system), harness, & valve cover are not, so plan on reusing those from your old engine. Everything bolted up beautifully, so if you have to get a replacement engine, go for a newer one, especially since 2004s are hard to find anyway (so many have had to be used, given the crappy timing belt / valve train design). Good Luck Gearheads!
:0)
lexubw

Loveland, CO

#37 Dec 11, 2009
Chevelle 66' I was advised they do nto care the valves, do you still have part numbers?
Thanks
chevelle 66 wrote:
<quoted text>
just did a valve job and bought the valves at Advance auto.
GBFD aveo

North Hatfield, MA

#38 Jan 2, 2010
I own a '04 aveo, about two years ago the timing belt broke, we had a used '04 engne put in it, and now the engine light will not go off, it has been to about 6 mechanics and the dealer, and they have done everything from engine diognotics to new a alternators, to suggesting fuel injector cleaner. they have found a few problems, but one of them should be sending off the light. They are all suggesting either re-wiring the entire engine, or a new car. When they did the diagnostics they found that it was reading a RANDOM MULTIPLE MISFIRE, it did not say whih cylender, nor is it misfiring. please HELP!!!!
Tera

Atlanta, GA

#40 Mar 2, 2010
Okay. Well, I need a new engine for my 04 Aveo. The radiator hose busted while going down the interstate at about 75 and the motor is horribly blown. I am having trouble finding one at a reasonable price. I don't want to put too much money into the replacement since Aveos seem to have so much trouble. Does anyone know of any interchangable engines? Like maybe a Malibu or Cobalt???
SuzukiSwift

Mississauga, Canada

#41 Mar 6, 2010
Suzuki swift+(same as aveo). Also had valve issues at
48 000kms, and had my valve problems (misfires on cylinder 2, got worse, and worse - started happening on highway and prevented shifting into 4th gear)- even using synthetic oil from 38k when I bought it. Then dealer got valve timing wrong on new head, and got misfires at idle. On checking, again, dealer damaged 2 valves and returned to me as 'normal noise', and had to take it to another dealer for another head. Then had to replace timing belt tensioner (bearing noise). Now seems to work, for now. At least I got a new timing belt for free.
romano

Cape Town, South Africa

#42 Mar 10, 2010
i have the same prob what was wrong

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Aveo Discussions

Title Updated Last By Comments
Trouble filling gas tank (Nov '06) Sep 17 Meg vega 442
2011 Chevrolet Aveo LT Sep 14 kim roberts 1
Aveo 2004 car alarm Sep 12 Angela 1
the chevy aveo's big secret power all owners mu... (Oct '08) Sep 12 Skulky 87 341
2010 Aveo Coolant Circulation Issues - Overheating Sep 11 flood404 3
chevy aveo won't turn over (Jul '13) Sep 9 William popow 12
09 Chevy aveo won't start (Feb '13) Aug 29 Irfan 12

Buy a New Car


Zipcode:
•••

Chevrolet Aveo People Search

Addresses and phone numbers for FREE

•••