Trouble filling gas tank
mello d

United States

#368 Jan 6, 2013
I have a 02 hyundai sonata that takes forever to fill up. Don't know why this is happening but i am glad its not just me. I usually have my man to put gas the car for me but..i know he ia not happy. Looking for a solution....pleeease
ford tech

Stoneham, MA

#369 Jan 8, 2013
there is a spider called black ethenol spider that actually prefer fuel vapors to make there webs.i see it every once in awhile and is pretty common . find the web and clean it out and it will be all set.
JRR

Norfolk, MA

#370 Jan 10, 2013
99 lexus 300 cant fill gas into tank did replaced filler tube still the same problem
Ford tech

Springfield, NJ

#371 Jan 10, 2013
JRR wrote:
99 lexus 300 cant fill gas into tank did replaced filler tube still the same problem
there is a block some where in the ventilation of the fuel system . The vent system is not only in the neck but through the whole evap system . Prob spider web. Find the block and u will fix the prob.
Latoya

South Bend, IN

#373 Jan 29, 2013
Im haveing the same problem now. What Do I do to fix it
David

Lawrenceburg, IN

#374 Feb 13, 2013
I have a 1998 kia sephia and air pressure is stopping the fuel from going in the tank .. What is causing this ??
Jim

Troy, MI

#375 Feb 13, 2013
I bought a 2000 CLK 430 Mercedes Benz with the same problem. I guess that's why the dealership delivered the vehicle with 1/4 tank of gasoline. I thought that was odd. When I stopped to fill for the first time it would only take 1/4 gallon before the gas began to back up shutting down the pump. I have never had anything like that happen to me before. I am an old GM guy, perhaps this is a payback.
Scott S

United States

#376 Feb 18, 2013
Everybody seems to have the same problem Trying to put fuel in. But no 1 has an answer. I'm about ready to drive this Safari up to Detroit and into their building. Spiderwebs, please!!!!! That is the most crazy horse crap reason I have heard yet from dealerships.
Danny 62

Randallstown, MD

#377 Feb 20, 2013
I am having the exact same problem with my 2003 Suzuki Aerio. It is driving me insane and I'm always stressing about having to go to the gas station now. For the life of me I have no idea what's wrong.
Patrick

El Paso, TX

#378 Feb 24, 2013
Sometimes the fuel pump gives out so when it is replaced the fuel tank has to be drop on some vehicles ....lots of times the person doing the job pinches the fuel line...or breather line ...so u need to find the lines and check to see if the not pinched .....
Hans

Thousand Oaks, CA

#379 Feb 28, 2013
I have the same problem with the nozzle shutting off after a few gallons. Never had the problem until the EPA required the latest new nozzles. It is apparently them with certain cars, BMW, Infinity, Toyota. Theyt ell you not to top off but I will not leave the station with2 gallons more than I came in with. So I keep filling and wait between shutoffs before I start to refill. It can take me 10-15 minutes to fill my tank when I used to be able to do it in less than five and not spill gas. Thank you EPA and how much pollution do you think you are adding to the air with the cars behind me idling away waiting for me to finish? The problem is these guys make the rules and never ever have to pump their own gas. Our government once again run amok but what else is new?
abby

Scarborough, Canada

#380 Mar 5, 2013
I have a Cadilac Escalade and it takes a very long time to put gas in the tank. When I am filling the gas tank, it would fill up to $2.00, then the pump will shut off and air would start coming out from the tank of the vehicle. I would have to take out the pump and wait about 30 seconds for the air to come out, so I could start filling the tank again.
I think the air hose is blocked up and the air is trapped in the tank, preventing the gas from going through the tank freely.
Fed up

Muleshoe, TX

#381 Mar 5, 2013
Same problem with my 2007 Kia Sonata. I can only put 5 dollars at a time.
sjr

Anderson, SC

#382 Mar 12, 2013
who makes the fuel tanks for all of these brands, they have to know what the deal is!!!!
They are treating us like sheep, we paid good money for our cars and trucks.
Ford tech

Springfield, NJ

#383 Mar 12, 2013
sjr wrote:
who makes the fuel tanks for all of these brands, they have to know what the deal is!!!!
They are treating us like sheep, we paid good money for our cars and trucks.
. It is pretty simple u have a block in the evap system . It is no body fault just the way it's is. Find it and prob will be fixed . It's not rocket science. Techs are not making up magical spiders that make webs it's the truth . Look it up before u guys bitch. They are called black ethanol spiders. So I guess I would blame god for creating it. Good luck
jay

Savannah, GA

#384 Mar 28, 2013
I have the same problem around 3.25 gas pump shut off as if my tank is full. As I read we all have the same problem I think it,s got to be a manufacturing problem and someone needs to be resposable and mabey we can get a recall and solve this problem. As much as these cars cost we should I hate to spend more money on fixing this problem we pay enough for insunrence and car not....u think. Please help
kevis

United States

#385 Apr 1, 2013
jay wrote:
I have the same problem around 3.25 gas pump shut off as if my tank is full. As I read we all have the same problem I think it,s got to be a manufacturing problem and someone needs to be resposable and mabey we can get a recall and solve this problem. As much as these cars cost we should I hate to spend more money on fixing this problem we pay enough for insunrence and car not....u think. Please help
. Has anybody tried running a borescope through their tube? You might be able to visually find the problem.
Tim

AOL

#386 Apr 11, 2013
Same problem with my 04 Chevy Aveo. Took for ever to fuel the tank. Found out it was my Fuel tank evaporator control valve on the back of the frame. Has a 1 inch hose running to it. Works much better know.
joe

Burleson, TX

#387 May 6, 2013
have a 1997 mazda mx6 when pumping gas it trips the pump about every $dollar
Scott

Belleville, Canada

#388 May 15, 2013
Having this same problem with my 99 cadillac catera....seems alotta people have had the same issue but nobody really has any amswers.does anyone have the answer to this issue?

Tell me when this thread is updated:

Subscribe Now Add to my Tracker

Add your comments below

Characters left: 4000

Please note by submitting this form you acknowledge that you have read the Terms of Service and the comment you are posting is in compliance with such terms. Be polite. Inappropriate posts may be removed by the moderator. Send us your feedback.

Chevrolet Aveo Discussions

Title Updated Last By Comments
the chevy aveo's big secret power all owners mu... (Oct '08) 5 hr Maria_Aveo 506
Looking to buy used 2006 Aveo Mar 24 flood404 2
Coolant loss Mar 15 flood404 7
engine stall when starting (Dec '07) Mar 15 chris miller 35
2010 Aveo Coolant Circulation Issues - Overheating (Sep '14) Mar 13 David_NC 19
2011 Aveo Problems (Jan '12) Mar 13 Jjjjjjjj 36
chevy aveo won't turn over (Jul '13) Mar 12 Cquinn011515 34
More from around the web